5k+ Serial 203/204 Beta Firmware.. how big is FOV in 144Hz mode?

If anyone try this Firmware out, how big or small is the FOV in 144Hz mode?
Is it smaller then 120Hz in “small” FOV?

2 Likes

I cannot select 144Hz with SN 204. Which FW is it, is there a new one?

1 Like

yes but for SN 204/203 only! Careful guys make sure you have the right SN!

4 Likes

I just tried it today with beat saber and pistol whip, the 144hz really looks and feels great! The FOV is fine, someone should do a proper measurement but subjectively it doesn’t feel any/much smaller than 120hz, very playable. The only other headset I’m using regularly is a Quest and compared to that the 144hz FOV on normal is still much bigger.

4 Likes

So now other 204 users get another refresh rate while some of us are still stuck with just 90 and nothing else. :frowning:

Once again I got excited thinking finally I’ll get the same features others have… nope capped at 90fps no other refresh rate works, motion smoothing doesn’t work. Just more disappointment. Eight and a half months and it still doesn’t work properly. I think it is time for that honest amazon review they asked me to put on Amazon.

2 Likes

Sounds good thank you

even the 202 guys got 110hz and everyone has smart smoothing what are you on about

4 Likes

Well dont forget the large FOV in 90Hz mode, at the moment i prefer 90Hz in large FOV over 120Hz because of its large FOV. Even i could use 120Hz, it´s just not why i bought the Pimax 5k+. I bought it because of it´s large FOV which you only have in 90Hz anyway.
Basicly you´ve got what Pimax adverticed for the 5K+… 90Hz…
But on the other hand i see where you coming from.
I hope you get your HMD to work proper.
Cheers

6 Likes

Does this mean a higher refresh rate at full fov ?

Added DfuUpgrade.zip to release notes.

1 Like

Doesn’t seem to work well for me, almost like it isn’t working correctly at all - 120 Hz mode is beautiful but has a more egg shaped FOV. When i select 144 Hz it is a large rectangular FOV that looks like 90 Hz, except there is some pronounced ghosting on white text or sharp objects during quick head movements. For now 120Hz for me. Digging the new pitool though!

2 Likes

I have ghosting at 120hz, but at 144 it is much worse :disappointed::
FOV is correct for me(oval)
203

1 Like

becouse your PC probably cant handle 120 nor 144 hz. Have you tried lowering your SS or game settings ?

1 Like

You get “ghosting” normaly in fast paced games like racing games if you´ve turned on “smart smoothing”.
Turn OFF “smart smoothing” maybe?

2 Likes

I have smart off, and 144fps in steamvr home, beat saber etc, and I have ghosting in both for eg

1 Like

The profiling for the 144hz is really bad.

feels like my eyes are more cross-eyed, and i feel really off when i take the headset off.
not sure how to describe it, but it was the same issue when 120hz came out, and later pimax had a pitool update to change how 120hz looked/worked, and it was smoothed after that(felt more natural to the eyes).

Pimax 203 here.
(and FOV was the same as 120hz as i could tell)

1 Like

I had to turn the gpu cat setting to zero in pi-tools ( 1080ti) to make it behave well

1 Like

Okay, i had to go back to the last FW for 203(.255).

Since 144hz was causing major discomfort, and the profiling was off, And i wanted to go back to 120hz mode.

But. when i did, i noticed the panels where more dim and slightly flickering(like it was struggling to maintain 120hz), these where the SAME symptoms that where in the last FW when 120hz first came out as well.

@Heliosurge i had another post 2 posts above that i explained as well.

2 Likes

Guys, after switching refreshrates reboot everything after it has settled its settings and reacquired tracking. Best to turn Headset off (power off, pull that plug), then restart Computer, then give back Power to Headset. Then check it out.

3 Likes

@Alex.liu
First off thanks for the effort in bringing us yet a new firmware, it’s great to see you innovating on a released product.

144Hz mode is speedy and all, but i have an issue with my right panel not being able to keep up with the refresh rate. Approx. in the middle of the screen there is tearing “look at attached picture”


This mode is unusable unfortunately.

Tried 120Hz mode but the displays are dimmed, rebooting HMD and powering off HMD, rebooting PC did not resolve this and can be replicated 100%

Reverting to M255 firmware

ps. 5K+ 203 Serial here :smiley:

4 Likes