5kxr will not take firmware past .214

5kxr will not take firmware past .214
0

Hi.i was wondering of anyone has had this issue.i cannot change to any pitools past .244 as when I start the latest pitools I’ve downloaded my hmd starts to go through the driver update with the lights changing colour.it then says its updated then just blinks and turns red and will not turn on.

Can you post your system specs?

He force rtx2080ti Intel core i7 9700k 8 core intel z390 chipset 11 gb 32gb 3000mhz ram 500gb m.2 NVME ssd 2tb hdd 650w psu Windows 10 home

2 Likes

Nice. Have you tried to reflash the firmware?

Run DFU.exe from pitool directory. The p2.dfu is in pitool subdirectory dfudriver

Yeah bud I tried that.i also tried the flasher tool

1 Like

Sorry to hear that. I would recommend submitting a ticket with Support.

Aw mate I’m kinda and over it.i had the issue at Xmas that u helped me with (thanks for that too) when I thought it had bricked but in actual fact it was this issue that was the problem…opened a ticket then and only got a reply 2 weeks ago.think I’m just gonna have to stick with what I got…the hmd casing is also cracking…think it will b my last pimax had tbh.thanks for the help

1 Like

I can appreciate your position. I would still file a ticket and get it RMA’d over the cracks.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.