8K-X and modules not working on new PC build

[My setup]:
Headset: Pimax 8K-X
Headset Firmware: v2.1.255.294
PiTool: v1.0.1.266
Pimax VR Experience: Beta
Pimax USB Modules: Eye tracking connected via 5m ‘Oculus Link’ USB cable & Hand tracking using built-in USB.
2080 Ti/Ryzen 3800x/32Gb memory.

1.Headset display shows green Pimax logo only so cannot see Pimax VR Experience (‘Start Pimax VR Home’ is ticked in Pitool) or use headset.
2.Green LED chevron is flashing on headset casing.
3.Purple power light is illuminated headset, was green.
4. Yellow text warning message in Pitool ‘Leap Motion device not ready’ so no
handtracking options shown in Pitool.
5. No Eye Tracking options shown in Pitool despite Pitool detecting Eyetracking module and
automatically installing software and ‘runtime’ left on desktop.

[What I’ve tried so far]:
Turning headset on/off using button.
Rebooting PC
Rebooting headset in Pitool software.


Both Eyetracking & Handtracking show up in
Windows 10 device manager without error.
Eyetracking shown as: ‘Droloon Pi 1’
Handtracking shown as: ‘Leapmotion’

When turning on headset, Windows pop up message reads ‘Pimax headset detected’ with familiar Windows USB connection sound.

Any ideas what I’m doing wrong?
Did Pimax ever produce a Step-By-Step Setup guide for their modules?

Thank you for any advice.

1 Like

Have you checked to see if games are working in SteamVR?

These 2 are related. It just means PP on.

Leap motion software installed?

As for ET not sure have one but have not installed it yet.

Guides? There are a couple in Pimax Official Updates.

I think you have insufficient power via your USB. A few things you can try:

1 - try different usb ports on your pc for the headset power. This can vary.
2 - disconnect your accessories and make sure the headset is operational without them
3 - connect them one at a time and test


Thanks for the reply, I appreciate it.

For USB I’m using the USB 3.0 sockets on the back of an Asrock X570 ATX motherboard.

The headset Green chevron is no longer flashing. In Pitool, nothing happens to the headset chevron colour if I change Chevron colour in options though.

I tried to calibrate Eyetracking by clicking an app icon at the bottom right of the screen and selecting ‘calibrate’ but it hangs after showing two black squares and a text box telling you to look in the centre. Once, it got further and there was a grey background with a sort of red crosshair but then nothing happened after that either.

Steam VR home loads but the graphics keep glitching out, e.g. tree tops looking out the window vanish then re-appear.

When I turn the headset on without loading Steam VR, I can see like a moonscape with grey rocks and a planet/sun on the left. I can also see a pair of grey VR hands which looks amazing (handtracking) although only if I put them outstretched or up to the headset. If I look down at the keyboard, the virtual hands disappear and they lag a bit.

I’ve installed Pimax VR Experience but for some reason it won’t load, when I load PiTool. I’d love to try the handtracking with Pimax VR experience and select the menus with my finger as Sweviver demonstrated on a Youtube video.

I tried to play a DVD quality movie clip in an app called ‘Simple VR Video Player’ but the quality, it looked like 360p resolution or worse, much worse than on a CRT TV. In ‘Simple VR Video Player’ the video clip also played behind me, so I had to swivel around to ‘see’ the movie behind me.

The images below are part of the grey moonscape/rocks I can see, it’s empty though with no menu or anything to click on.

1 Like

For PE you can reach out to @SweViver or @arminelec and they can assist with getting that running. Sounds like you have the headset itself operational.

On the ET module we’ll have an update for that quite soon via firmware and software update.


The flashing just indicates parallel projection being on.

I don’t think the chevron colour changing works on the X.

I’ve had this happen too. When the two red dots disappear it means it can’t see Your pupils.

Try getting closer and/or restarting the service (also make sure You actually start the service in PiTool - “launch aSeeVR”).

The red crosshair after the two dots is what You’re supposed to look at/follow to calibrate the eye tracking module.

You need to use the latest PiTool beta with Pounded Experience:

You can center the view by clicking the middle mouse button or Index Controller thumbstick.


Glad to hear you got your headset working!

Regarding PE, as @DrWilken already said, you need to install Pimax VR Experience. It seems like you have only installed PiTool which does not include PE, and therefore only shows the empty old Pimax galaxy.

And I highly recommend you to use the latest PiTool and PE versions here:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.