8k x led status purple and green light bar flashing

@PimaxQuorra

Pitool 271 + firmware 298 Last Release

This is the everyday Procedure

All Off
I put the headset at the center of the game area
I connect the headset (First DP, Black Usb, Yellow Usb)
At the end I give a gentle pressure to the hub of three cables from both sides
I connect Base station 1
I put ON the The Electric Power strip of the PC
(Base Station 1 in front of the headset change to ON - white led)
I put On the Power Supply
HMD LED Status is red
I put ON the PC
W10 BOOT
I Wait the green led from the router
I run Pitool
I check HMD LED Status: IT IS PURPLE INSTEAD OF GREEN
I close the window of pitool asking for room setup
I connect Base Station 2
I check Both Base stations are Blu inside Pitool
I run Steam
I run Steam VR
I put On the controllers
I check both Base Stations and Controllers are ACTIVE inside Pitool/Steam VR
I wear the headset
I wear the controllers
I run a Game from Steam VR Home

As i have said the led of the hmd is purple instead of green and i don’t have PP ON

The effect of this is i can run games but 3D is broken or i have other issues with room scaling
or the game

What I have to do ?

Have you tried selecting PP then saving, restarting PT and turn PP off and saving? Just a thought.

4 Likes

Thank you for the answer

I have tried , but perhaps (very little hope)i have not made the try well

I have 10 games and i have launched only 4 of them.

They don’t need PP, so I never activated it

In Pitool PP is OFF

Moreover I have seen another strange thing: Usually when you close Pitool , all the processes of Pimax and the same Pitool goes away inside task manager . Instead now with Led Purple they are there

1 Like

Was worth a shot. I had seen PT versions that don’t save settings on exit, Using PT 261 on a 5K+ so sorry couldn’t be more help. Maybe open a ticket would be advised.

4 Likes

So the led being purple means pp is on? I did not know that. Pretty sure my led is on purple when i use my 8kx.

4 Likes

Just tested it, my led is green when i turn the hmd on with no game running. When i start a game with pp such as msfs, led stays green lol! Pp is definitely on (its on in pitool) as its msfs 2020, Normal fov, and i see no culling/graphical artefacts like you’d get with pp off.

Thinking about it, i seem to recall the purple led only being on when you get the planet scene in the hmd when no game is running.

Edit: i have the planet scene in my hmd right now and the led is green. Tbh, im not sure when the purple led comes on or what it means.

3 Likes

To be honest you do not see a review from me of Pimax 8K X
because I can’t make a good review in this moment

However VR is fantastic: this is my first HMD
and i have to adapt to this HMD
not the opposite
Until I win and the final judgement of 8K X will be Good

In that case i will buy Pimax 12K
On paper is the best to have fun in VR

For example
In last days Base stations always grey at start in pitool
Why ?
What is the solution ?

  1. To power cycle bs !!! Yes but wrong
  2. to detach yellow usb port (data) !!! Yes but wrong
  3. to change usb port !!! Yes, but wrong . Never , only if your usb is broken (watch device manager) because pitool/w10 remember the config. This is the last resource after a w10 reboot . So this is 4)

The first thing to do is instead

at start this reduce the % of this issue ; Today no grey BS

But coming again to Purple led

First time i had it ; I have been capable of getting out with some reboot hmd and restart service
but i had not found the right sequence. I remember that when the LED went green, bs were grey and then i detached yellow usb port to solve the issue (i have discovered the tip of the hub after)

Second time i had it ; My pitool was at 1,5 with 90hz and Normal FOV at start .
The issue coming again with pitool rendering at 2.0
I have thought that this was the issue
No problem; If it’s this i can start always with Pitool rendering 1.0, 75 hz and Normal FOV
However i did not put this in practice

Actually i have the issue coming from another issue i have tried to solve
Steam VR error did not run because it has disconnected the HMD for a fatal error happened before
??? What is saying ? I know nothing.
Manage Add-on do not work because need restart Steam VR so the issue come again
I have un installed Steam and SteamVR
When you install all again then you have to do the room scaling again
I made as first time - wrong
You can’t put at step 3 of 3 the headset on the table because the result is you are a child of 10 years
No one have told how to make room scaling well - youtube video, you don’t find nothing
So i have made again , this time i weared the HMD and another person have pressed the button on the pc inside steam vr because the trigger of the index controller did not work !!!
This time height inside vr was great but at start in SteamVR home i was not in the correct position
In this moment i noted the Purple status and games not working well
I rebooted the pc from start a couple of time, nothing
I have discovered wifi ON
I put wifi OFF
Tried again
Always purple

This is the story!!!

1 Like

Strange and the Chevron is not flashing as pp might be stuck.

Hello,

The LED indicates purple = Parallel Projection is ON.
But you have mentioned you never activate the PP, so it’s kinda strange.

I recommend you to close any related Pitool/Piservice in the task manager.
Make sure you have toggled OFF on PP option.

Restart the Pitool and connect the HMD.

Regards.

2 Likes

about 6+ months ago changing parallel projection stopped changing the led color for me unless i clicked restart service in pitool. however pp was still getting turned on and off by way of testing render resolution in steamvr and of course fixing the pp problems in the games i run. as far as i can see this is purely an aesthetic bug.

1 Like

@Pimaxquorra Thank you for the answer

@Heliosurge
I would like to change the title (I don’t know if i have permissions for that) to

“8K X LED STATUS PURPLE AND GREEN LIGHT BAR FLASHING”

@All
I was busy this morning but whey i come back to home

immediately i have weared the HMD

So, I run Pitool (see everyday procedure) and I had

Basestation 1 grey the other was off
and
Led Status Purple with green Light flashing

I have detached the yellow port and put again: basastation1 blue

At this point i have changed in Pitool Rendering from 1.25 to 1 with 75 hz and Fov Normal
Apply
Save

I have closed Pitool
I have put OFF The pc
(This is important for the try I don’t have touched the power supply button…)

I run Pitool 271 (fw298 last version)
Base station 1 blue
SUCCESS : Green LED on the HMD and green Light bar not Flashing

Base Stations and Controllers are ACTIVE inside Pitool/steam VR home

Unfortunately i have still tracking issues: I am very high in SteamVR home room
and the active laser pointer of the controller has a short movement than disappear

I have made a new try and

SUCCESS : Green LED on the HMD and green Light bar not Flashing

But still issue with tracking

I have checked SteamVR Setting file and i have find a strange thing

After the second and third room calibration in standing mode
I don’t have anymore a “Pimax Vision 8K X”
but a “VIVE mv”

Then I dont have “audio” and “power” section perhaps because i don’t have made changes
but the original SteamVR setting file in “audio” section is full of “Pimax Vision 8K X” every line

Perhaps I have printed this file after launching pe …

1 Like

hello
I have this bug sometimes
when I turn on my 8kx before pitool
you save in pitool and you restart your hmd
:+1:

2 Likes

As the Op you shouldn’t have a problem to change Topic title. If you do let me know. Just go back to your first post and edit title.

2 Likes

In the afternoon I have made room scaling number 4

At this point i believe that to make a room scaling it’s not necessary to uninstall steam vr
and install it again

However this affirmation will be true in case of perfect result

Room scaling number 4

This time I have put the headset at step 1 and 2 on the table
Instead at step 3 i Have weared the headset putting 180 cm

well, now i am more expert than before
and i already know that also this try was bad
before going in steam vr Home

Here the height was good
but tracking not centered at start
Jitter was High

I loaded a room of Half Life Alyx
and i began in a wrong place
Staying still i could see the chair moving

Potentially Pimax 8K X vote for tracking could be 10

If you are curious

ROOM SCALING 1 TRACKING VOTE = 8
ROOM SCALING 2 TRACKING VOTE = 2
ROOM SCALING 3 TRACKING VOTE = 2
ROOM SCALING 4 TRACKING VOTE = 4

You must not calculate the arithmetic mean
because when you have for example a tracking 8
if you have stability this vote do not change

Room scaling Tracking (Standing) vote 10 is
Centered area
Correct Height
Correct floor
Perfect tracking of controllers
No Jitter

Room scaling 1 was centered area, accettable height, correct floor, near perfect tracking of controllers, no jitter

Next try tomorrow the tracking target will be 10
Taking some tricks to solve everything

PS

In this last try

SUCCESS : Green LED on the HMD and green Light bar not Flashing

1 Like

can you try room setup in pitool AND steanvr?

set up room scale in piTool before starting steamvr.

the run steamvr roomsetup

1 Like

Yes i can but for me now it’s not suitable

If you give a look to “Pimax setup” on the website they don’t tell to make Pimax room setup

If you give a look to Pimax Manual you will find this line:

Room Setup: Guide users to room settings/ (If you only use steamvr, please do room settings only within Steamvr.)

This is my case

2 Likes

Room scaling 5 was a step in the right direction to perfect Tracking

After that i have to lower Room scaling 1 vote to 7 with this note

Apparent Centered Area, accettable height but low, correct floor, near perfect tracking of controllers, no jitter

I have played a lot with Room scaling 1 and it has the best Jitter of all the try

So what i have changed in Room Scaling 5 ?

The position of both towers because the room is strict and long

Now The towers are in the middle of the room instead that near the opposite angle of the room
like should be

This time i have verified in pitool the tracking of each basestation and both at 360 degree
inside the game standing area on the table and wearing the headset also moving outside the game standing area…

All OK, always blu

About the steam VR procedure i have put the HMD on the table at step 1 and 2
I have weared the headset at step 3 (calibrating the floor)

ROOM SCALING 5 TRACKING VOTE = 6

Note

Apparent Centered Area, Correct height, incorrect floor, near perfect tracking of controllers, low jitter

This room scaling 5 is enough good to play.
The incorrect floor is a bad experiment: I am 180 cm but I have write 170 in the procedure
Without this, the vote would have been 7
Here you see jitter if you are searching it, there is some

Today no issues with stability:
basestations always blu at start
green led and green light bar

Perfect Stability vote 10 for Pitool 271/FW 298 last release is
Correct installation of Firmware
Base Stations tracked at start
Green led and green light bar
No issues of any kind (90 hz/ SS 1.5/ 114 hz)
Perfect tracking (vote 10)

Pitool 271 has not auto installation of firmware
and manual installation went well
I liked this more than Pitool 272.

I am working on other points

Next:

Room scaling 6 : searching for perfect Tracking (vote 10)

Gaming with ss 1.5 /90 hz without issues (crashing steam vr/purple led…)

We will see again sunday evening

1 Like

This is the report of last days

Room Scaling 6

I have made the exact procedure of Room Scaling 5

but the result was … that I was flying in the air

ROOM SCALING 6 TRACKING VOTE = 2

I was angry, so for room scaling 7 I have changed again

The index controllers were on the chairs (at left and at right of gaming area)
always on during all three steps

Step 1 I have weared the headset but then i put it on the floor
Step 2 I was behind the monitor, i have calibrated the center position
Step 3 Without changing nothing i Have accepted 0 cm

I have checked all wearing the headset before closing:
I was centered in front basestation1,
the monitor was near at the left of tower at mid air

I have tested room scaling 7 a lot

ROOM SCALING 7 TRACKING VOTE = 9

Note
Perfect Centered Area, Perfect height, Perfect Floor, perfect Tracking of controllers, low Jitter

Now that i am sure that i am at the center of gaming area (you see it inside the vr headset)
After all the testing I am also sure of perfect Tracking of index controllers
Height : when i went in the bedroom i have smiled watching the bed because in steam VR home is the same scene
Floor : absolutely perfect. the controller touch the floor where is in vr. I also tried to grab objects. No issues
Jitter : Room scaling 7 is on par with room scaling 5. It does not bother me

I have tried to improve jitter making some experiments without success:
direct path to power
connecting the headset with Two yellow usb

Instead at start i had grey Basestations
Restart the pc did not work
I made an experiment: to put on controllers
Eveything went blue
but then i did not have good tracking in steam vr home

i put off the pc
changed the connections (one black usb and one Yellow usb)
restarted
and
again grey basestations
i detouched yellow port and reconnected
Base stations blue in Pitool
But then surprise: steam VR error
I was lucky this time because Manage Add-on work
and restarting Steam VR
I had again perfect tracking

Another try i have made was to play lowering latency

Preliminary
Very happy i can run VR with Record Latency (low)

So we can take some conclusions

Pimax 8K X has perfect tracking
But
Random room calibration result
and Random usb issue at start (Basestations grey)

Today i have played at 90 hz normal fov Pitool 1.0
VR Kanoyo
Together VR
The walking dead Saints & Sinners

without issues (flickering etc)

Today I have played in Upscaling mode 114 hz
No Man’s Sky

without issues (Headset never blacked)

I have also played with Pitool 1.5 and SS 100% at 5764 x 4740
Led Status always green and green Light Bar
At end i have put the headset at default Pitool 1.0

Next
THE REAL BATTLE: To improve Sweet Spot
The last resource for jitter and usb issue
No Mans sky at 60 hz (flickering ?)
Fallout 4 with PP