8K X Occasionally Blacks out for a few seconds (Potentially Solved, EMI Ground Loop/ Interference likely the cause)

I am very clueless what you’re talking about


What kind of amplifier?!? DisplayPort? Please provide details

1 Like

So just a heads up… Yesterday I had a nearly perfect session for 2.5hrs straight. (one line flashed across the screen at the end, but not a blackout flash,etc.)

I had ferrites on that the other user recommended above and they were definitely helping with the crazy sensitivity of the headset when i was touching it, where the image would float away or if i held it long enough it would blackout. So, with the large ferrite cores looped through 3x, it was perfect.

Then TODAY, i start getting blackout flashes again. In 5 minutes i probably saw 5 of them. So something’s definitely affecting it and it could just be EMI, instead of a ground loop, since the ferrite seemed to have helped against the crazy sensitivity the headset had.

So I decided to remove the ferrite magnets. But then right before a race session as about to start, I touched the optical cable with my fingers to move it. A complete blackout and disconnect happened.

Then i restarted, got back in and raced but started to get the blackout flashes again. I decided to move the cable a bit again with my fingers and boom, another full blackout and nearly disconnected but it stayed on.

So it would seem that the ferrites are helping with a ground loop, but there also seems to be EMI interference getting through either way somehow and needs to be tamed somehow.

I will be receiving an EMI Filter tomorrow so hopefully that will get rid of it all - I’ll report back more when i get the filter installed, and also with this ground loop-shielded optical cable.


This space intentionally left blank.


I have to check which fw im using but i did get experimental fw that made 90hz work with the new drivers like 2-3 weeks back
And also pitool 271 and the 461.77 drivers (latest ones nvidia released)

It is too random but today touching the cable the way i did and twice it blacked out, is only telling me 2 things. It is almost exclusively caused by 2 things for me - A Ground Loop is Present AND EMI is present as well.

Both are causing issues for me.

By end of the week i’ll have an EMI filter. Ill test after i get that. And hopefully next week this ground loop shielded optical cable will get to me, and i can test with that.

1 Like

18 posts were split to a new topic: 8KX panels off in 90 Hz mode

I had a complete blackout and disconnect just now. I really dont get it any more.

1 Like

I tried to reinstall an earlier nvidia driver 461.09 - and then i got real bad stutter/lagging. Went back to 466.47 (the one before the current one), and this time it ran fine.

This is really hard to track down.


have you ever tried this?
Hotfix 466.79 - Clean Version | guru3D Forums

Direct link - https://mega.nz/file/8hpGTBYZ#ywTRIimKEjIaB_ySc0U294g-sIVD28h0wPCmTPG2UXA

1 Like

No. I tried 466.77 which is where i saw problems but im not certain its driver related although it could be


Newest update:
I Added an EMI Filter and separated the line the PC and accessories is on.
I had a nearly flawless 2.5hrs today except for 1 flash blackout.

So it seems that the issue is hiding in the background and is as i may have expected - due to a ground loop exclusively… Waiting on the shielded cable to arrive hopefully next week and if that works i’ll report back


Looking forward to your conclusion regarding the new pimax optical cable without groundloop.
I’ve been holding back on buying the optical cable due to the limited 6M length, and it seems this was in my favour if the cable design is indeed faulty.


We have yet to see if this “ground loop shielding” works. I’ll report back for sure.


Hi had loads of blackouts today to the point it actually stopped me from being able to use the device.
I decided to look into earthing the headset. My first thought was using the USB2 connector to earth the headset via a charging plug, although I haven’t got one so I thought I’d just fire up the PC again with the usb2 connector removed. Strangely the headset runs absolutely fine without this plugged in! I then just had an hour of flawless running no blackouts.

Early days yet but it made me think, could the usb2 cable be causing EMI along the main cable???

I assume you mean the original cable with the USB 2 and 3 cables? If so, why do you think it’s the USB 2 causing it?

Just so we’re on the same page… EMI and a Ground Loop are different things and very common to confuse the 2.

I believe the issue I’m having is a ground loop possibly.
How would you go about earthing it? You mean just taking the USB 2.0 cable from the default cable and plugging it into the ground port in your wall only?
I wish I had that option with the optical cable to even try.

If it is a grounding issue which i think is still the likely cause of the blackouts and flashes in my case, hopefully this “ground shielded” optical cable they sent me to test will fix the problem altogether.

Can anyone clearly explain what theyre testing here? Does this mean theres a ground loop in the original cable (2nd cable they tested), or in the optical (first cable they tested)

They’re testing for electrical charge. The original one has some charges.

Have you tried testing by placing the headset on the rig before turning on everything? That might work. Place it on a rig or metal object.

1 Like

Sorry for the confusion. My original intention was to ground the electronics via the usb2 power supply connector (at least that’s what I thought it was for!).
Although now I’m not running with it plugged in maybe both usb connectors are causing a earthing loop?
I really don’t know, as I said it’s early days testing it like this. I wonder why Pimax included a usb2 cable if clearly it works without it plugged in?

1 Like

not every mainboard has enough power reserve on the single USB3 port

1 Like

That is an easy one to Answer. Laptops often do not have enough power and some desktops do not have strong 5v power so having an additional connector gives options to ensure the hmd is receiving ample sufficient power available.