8kx delivered and not working

displayport doesnt connect, only audio works. tried usb power adapter, reinstall pitool just nothing. 5k+ works fine

The cable isn’t hardwired to the headset (and can be removed), it might be worth to check whether it’s properly attached to the headset. If it still doesn’t work you might have to open a ticket for RMA :confused: At least they seem to have sufficient amounts of headsets now according to the last update, so waiting times are hopefully not too long.(…)

its not going in further. just getting error 10936. also the hmd reboot button does nothing but works fine with 5k+

Also try the restart service button if you haven’t. I do this almost automatically already, otherwise neither the 5k+ not the 8kX works for me 9/10. Think the service/driver doesn’t like the place where it’s loaded in the boot order on my machine.

i tried everything that fixed the 5k+ when it didnt work.

:confused: Sounds like a case for a ticket then. Fingers crossed that it can be replaced fast!

You need domen’s help:
https://support.pimax.com/en/support/tickets/new