8kX not showing up on windows 11 and pitool

Hi,
Got this problem when trying to use the 8kx on my new windows 11 build.
The headset won’t connect to the Pitool and the led on the headset turns yellow/white.
any advice ?

Frans

Ir sounds like maybe a Firmware issue. Have you tried to run the dfu.exe in the pitool directory to see 8f it detects the headset? If so you might be able to re flash the firmware. @playa has site with all pimax releases just be sure to download firmware for your hmd model. If the firmware on pimax site doesn’t work

I would also recommend filing a support ticket links below. There was a topic where someone said his hmd is working on w11.


PimaxVR Support

Main Site
  • Self Help Database
  • Submit a Ticket
PimaxVR Forum Support

This group consists of PimaxVR Staff Specialists for assisting PimaxVR Consumers with resolving Ticket.

Please follow this Procedure before Requesting help.

  1. File a Support :tickets: At
  • PimaxVR
    You should receive a response within x Business days.
  1. If you have not received a response after x Business days or Support personnel is having difficulty understanding your request. Please Direct Message(PM) this group requesting assistance.
  • Please provide the following Information:
    Support Ticket # & Details of issue.

if your support issue is Tech related please explore:

  1. Use Docs in Left menu to explore 2 & 3.
  2. Pi-Guides & Troubleshooting. (#guides )
  3. Community Support - review Solved and post question if needed. (#vrcentral:helpme )