8Kx Setup for a complete noob

Hi guys, quick question.

The bundle finally arrived, everything working great, no issues pairing anything, all worked straight away.

  1. I am wondering if I need to update any firmware or are new 8Kx’s shipped with the latest firmware?

  2. Things are a little out of focus, outer distortion is a lot worse than I expected, hopefully I adapt.
    I have tried tweaking the IPD. Are there any tutorials/guides so I can optimise everything to get the most out of it?

Any other tips/tricks for a noob would be epic, thanks.

Hi
1、The firmware should be upgraded automatically.


If you have the 30** GPU ,you may try the 90Hz:

2、
2 Likes

Cool thanks. Yea I am stuck fluffing around.

Trying to launch HL, doesn’t load, on PC has pink texture, in HMD game stuck in concrete land, I can hear the game load but no visual.

I run the game as admin manually as per searching recommendation, no more pink texture and it loads on PC however it doesn’t connect to HMD even though pitool and steamVR are open.
HMD still shows me in steamVR land.

Everything is updated.

I can’t see 90hz option either, I have a 3090, as I said, everything is updated.

Sooooo… what to do?

I’m starting to see red and regretting I bought this, what a f*cking mess.

So after doing the whole DFU.exe and downloading the latest 90hz DFU, my 8kx is flashing green with black screens, even when on my monitor it’s acting normal.

How is this even possible, how is there no standardised information, why do I have to dig eternally and still find no answers?

Seriously, anger and frustration aren’t strong enough emotions to describe this.

I FOLLOWED THE INSTRUCTIONS FFS

For people here to help you would need to be more specific.

For instance you say everything is updated but no version numbers. Pitool 271? Nvidia driver version? What are your pitool settings that are selected? What is the name of the file you used to flash your 8KX? SteamVR beta or standard version? Is the Pimax Experience installed?

2 Likes

Pitool 271
NVidia 466.63
SteamVR 1.17.12

Orignaly had PE installed, then uninstalled everything and reinstalled Pitool, it’s still doing it so I haven’t bothered to reinstall PE.

Used DFU.exe, used P2_RELEASE_8KX_90HZ_Beta.dfu

It’s a firmware issue as it started flashing green and screens stay black straight after using above DFU.

Everything seems fine in Pitool, everything is detected, SteamVR runs and everything.

However the HMD flashes green and screens stay black, even when on my monitor it shows HL or DeoVR running fine.

I will send you a PM.

Yes, best to keep solutions private

2 Likes

Update: I had to revert my Nvidia drivers back to 461.09

Screens came back on, however there is still a constant green flash as if it’s still in DFU mode.

I have reset my PC and the HMD multiple times, unplugged etc etc.

Everything works fine now, except HL doesn’t have any visual, just black, can hear it load to the main menu but no screen.

Other apps work fine, VR Chat loaded up fine.

Just this constant annoying green flash and gotta figure out wtf is wrong with HL.

1 Like

Are you saying the screen is flashing green or the led ?

If it’s the light on the front, that just means parallel projections is on, it has nothing to do with dfu.

And are you trying to use 90hz with half life? Put it on 75hz and see if it works

1 Like

Ok, I got it working. PE and HL.

It was the settings.

It seems that something was clashing. Render quality was set at 2 in common settings, when I changed it back to 1 then PE started to be kind again, sometimes.

Screen was blackened in PE, not off, like could barely see that the screens were on.

I restored everything but it didn’t restore HL render quality, which I had set at 2.

Set render quality to 1 for everything and it works.

This is weird as I have a ridiculously powerful machine,

128gb ram
Threadripper 3970x
GeForce 3090
and literally the fastest boot drive available

so I dunno

It’s not your pc, if I had to guess it’s just the headset is already up against the max that display port can do. That’s why everyone was asking for hdmi 2.1

Super weird that HL is saying that I have low GPU memory available, like, wtf, I have almost the best possible hardware atm.

Is there anyway to run VR games without the window running on the monitor?

I guess that would free up 33% of memory.

Its only mirror - in most games I played should not have impact for fps. You have beeefy PC and more than enough RAM and VRAM. I would consider add some virtual ram ( page file) to system disk in Win 10 to solve issue with Alyx

Please try to reduce resolution of steamVR when you saw the pink texture!!

I saw you’re comment but I don’t think a lot of people now this but hdmi 2.1 cables at the moment aren’t longer then 2 meters otherwise they can’t uphold the 48gbps required for hdmi 2.1😉

1 Like

Fiber optic hdmi 2.1 cables can go up to 50 meters I believe

Virtual ram was on auto and already had 20gb allocated which is double what the reddit guy recommended.

It runs fine, in fact I was blown away at the realism and detail, just am still getting the warning every time game loads.

I still have IPD issues, my eyes are working hard staying focused.

I’ve tried fluffing around, it’s pretty close but I can tell in a year or two, if I keep this up, I will need glasses.

People say use an app to measure IPD then set the 8Kx a couple mm fewer, I may try this, I dunno, I have perfect vision irl but can’t seem to find the same natural feel inside VR yet.

I’ve gotten that too in HL:Alyx sometimes on my 3090 and it (of course) wasn’t true as I checked with fpsVR.

Must be a bug.

EDIT: We’re not alone and it’s not a Pimax thing:

This might help:

Just a quick re-post on what solved it for me, check that you don’t have INSTANT REPLAY as ON in your GeForce Experience background application.

1 Like