Aircar problems

Wondering if anyone can help with a couple of problems.

  1. Aircar cannot be loaded from PiTool My Games, so I can’t use a custom profile for it (or is there another way?). Is there anything I can do to fix it, or is it one for the Pimax team?

  2. Inconsistent crash problem on startup - it routinely crashes, but not always. Tonight I have had no luck and had to give up, last night I had a few crashes but it did eventually work. Not sure what solved it though. Previous evenings no problem.

One change is that I switched to large FOV last night, which works great at 90FPS, when it loads.

D3D texture crash error - I assume it is something to do with switching PiTool config, but by turn, restarting SteamVR / rebooting headset / restart service doesn’t fix.

Hell, I even rebooted the machine just in case, which is not a solution to me (ie relevant app or service restart is sufficient), but still no joy.

I haven’t given up and reverted to Normal yet, as Large can work. It’s possible Normal might still crash anyway. Any suggestions appreciated, thanks.

LowLevelFatalError [File:Unknown] [Line: 819]
Rendering thread exception:
LowLevelFatalError [File:Unknown] [Line: 328]
Direct3DDevice->CreateTexture2D(TextureDesc,SubResourceData,OutTexture2D) failed
at D:\Build++UE4\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Texture.cpp:481
with error E_INVALIDARG,
Size=17068x5268x1 Format=DXGI_FORMAT_R32G8X24_TYPELESS(0x00000013), NumMips=1, Flags=D3D11_BIND_DEPTH_STENCIL D3D11_BIND_SHADER_RESOURCE , Usage:0x0, CPUFlags:0x0, MiscFlags:0x0, SampleCount:0x1, SampleQuality:0x0, SubresPtr:0x0000000000000000, SubresPitch:0, SubresSlicePitch:0

Try less supersampling & or reduce pitool render. Don’t have title is it Oculus? If so one youtuber reccommended pi render at 0.5 to 0.75 & use Oculus home tweaks & in game settings.


Sure thanks let me check, it should have been running on PiTool 1.0 and no SS but res isn’t right, and I did manually edit my SteamVR config a while back.

Not an Oculus title AFAIK, I’m using the free Steam version. Impressively immersive for its simplicity and unmissable for anyone who likes Blade Runner :+1:

1 Like

Any idea what to do if an app won’t launch from PiTool?

1 Like

I usually launch titles like that from steam. Just change pitool global settings to suit


OK thanks yeah that’s what I’ve been doing. I wasn’t sure if I could fix it myself by manually editing a config somwhere (not spotted an option yet), or if only Pimax can fix it.

1 Like

Yes we could use an external tool to edit the unfounded.

When home again will need to find some time to dive again.

@park though may have some great input on this.

1 Like

I did a search through the Pimax install folder and checked out any .cfg, .config, .json, .settings, .xml files but didn’t spot anything for the custom app settings…

1 Like

I can launch this game, but I see no car or anything, just floating above the city. Controller buttons do not work.

SteamVR shows error: “Failed to load input bindings for “AirCar…”. Please Select another binding option.”

But no matter what I select in SteamVR, such as ZKNIGHTS7 binding, there is no controls available. Beautiful city, tough.

1 Like

The intro does that until it picks up a controller button press. On the Index controllers, most of the buttons work by default so I got past that screen, but turbo did not. I had to choose another profile to fix that. It seems that defaults have problems.

You haven’t mentioned which controllers you have, not sure why you wouldn’t be able to select a compatible profile for your controllers, sorry.

1 Like

I have Vive controllers. I did choose ZKNIGHTS7 binding, as it seems to be the only one in there, but it does nothing.

There’s not many controls, see if you can create a custom one yourself?

Dev mentions a wand binding here but maybe it’s been deleted or changed:

1 Like