Base station flashes blue in pitool

Got my base stations 2.0 and one of them flashes blue in pitool. I tried turning off the good one and changing channels on the flashing one atleast 20 times. I’ve been using my 1.0 stations just fine. In fact I’ve gone back to them.

Anyone have a fix? Support is dragging their feet a bit

I also tried updating the base station

1 Like

I too have both base station 1.0 and 2.0… and I find that base station 1.0 to be more reliable. However, one way I did get 2.0 to be more reliable (a lot less blinking in PiTool) was to change the channel number of one base-stations on version 2 so that the two stations have different channels. You might want to give that a try.

Hello Decapper,

If the base stations are flashing blue, this indicates that the Base Station is not stable or is encountering vibrations. This will prevent the laser from functioning. Make sure your Base Station is in a stable location and is not being subject to vibration or shaking. If the problem continues, consider moving the location of your Base Stations.

Or else you might try to switch the channel of your base stations. When the base station is plugged in use a paper clip to press the button inside the tiny holy in the back of the base station. You will hear / feel it click. This increments the channel up by 1 and will allow you to change base station channels without bluetooth being enabled.

Sincerely,
Quorra.Pimax

4 Likes

Hi,
I have the same exact issue and I’ve just received the Base Stations as well. Did some digging into the problem, also with the help of Pimax support, that I must say has been responsive.
Please note that it is NOT the LED of the BS blinking blue, but the PiTool BS Icon. The channel 2 BS is not tracking, no matter what.
It seems that the BASECALIBRATION parameter of the BS is set to 0, 0, 0, 0, 0, 0, 0 and this is the problem… and I couldn’t find a way to set that param.
To check this, you could open up a command prompt and in the PiTool runtime folder execute the command lighthouse_consolle.exe , then type dis …

You should see a line of [0 0 0 0 0 0 0 0 0] or something… this would confirm you’re in my same situation, but at least it’s a common problem that could find a common solution.

Also you could check the file lighthousedb.json in the folder …ProgramData/pimax/runtime/config/lighthouse to see if you find a basecalibration paramater set to a row of 0.

2 Likes

Thanks for sharing this @IlPres

Just checked my 2 KS 2.0 BS received a few days ago, both have non-zero BaseCalibration and both stay lit in pitool (no blinking icon). Checked with lighthouse_console.exe + dis command, and also in lighthousedb.json.

I remember I have swapped the channel from 1 that was blinking in pitool (using the pinhole), but maybe I wouldn’t have needed to if I just waited a bit longer for pitool to detect it. BTW doing this I have noticed the BS sound pitch was changing as I was changing the channel.

Before doing the above I first made them detected in steamVR using my OG Vive because I though it was mandatory in case it was needed to upgrade their firmware, but I don’t remember I needed to upgrade them (I just remember I have upgraded the index controllers fw, bought from valve).

1 Like

Does the vive detect 2.0 base stations ?

The og Vive has v1 sensors so no.

It only works the other way round (V2 sensors are backwards compatible).

1 Like

Just checked again, OG vive doesn’t make v2 LH detected in steamVR indeed (even when they are plugged with the USB cable).

1 Like

Just a brief update… Both Pimax support and Steam support agreed to open a RMA for the base station. Tried to push them to give me a manual firmware update procedure, but they told me I could possibly brake the unit even more. So… long wait now… :frowning: