Basestations in steam vr not seen unless pitools launched first

i can’t seem to figure this one out or why it’s happening.

if i launch steam vr, it doesn’t see my base stations or controllers. in fact, it tells me bluetooth is disabled.

if i launch pitools first, base stations are seen along with everything else. launching steam vr AFTER pitools, SVR now sees the base stations and controllers.

that’s cool and everything is working. i’m just curious why steam vr wouldn’t even see bluetooth as active until pitools is launched?

any thoughts?

1 Like

simple, your pimax is the used BTdongle… pitool is the ON switch.

but i have the steam vr break out plugged in, that is my BT connection.

1 Like

Pimax hmds and controllers communicate with SteamVR. The controllers ti be able to use say in Oculus mode uses pimax’s wrapper driver. The wrapper is how SteamVR get’s controller. This was in part why originally HL:Alyx being free with Index Controller had a redemption issue as SteamVR was reading tge Wrapper driver vs directly detecting the Index Controllers requiring users to submit a ticket with Steam Support.

Pimax has no BT communication with Lighthouses for updates or power state control. So without pitool running no Lighthouse data is sent to SteamVR. Unless your using say an Index or HTC hmd.

oh i got it! you’re saying that steam vr won’t see anything until a headset is on, the headset being the primary device, then the base stations are seen.

that totally makes sense, thank you

1 Like

It’s even more simple than that. SVR prompts on launch to check the hmd is on if it isn’t :grinning:

3 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.