Brick after firmware

Hi, my helmet didn’t work correctly and I decided to try different versions of Pitool and it didn’t help. Next, I decided to reinstall the helmet firmware, I used the DFU.exe application and p2.dfu firmware and did everything according to the Pimax instructions and do you know what happened? I got a brick! The helmet shines with a violet LED and USB does not detect it (code 43).
33

Well, I tried to read the helmet again using the SweViver instruction and it did not help.

I created a ticket in support # 23,270 and the specialist answered me and you know what he offered me? He suggested that I flash the helmet using the SweViver instruction and firmware p2.dfu * facepalm * I wrote in response that this does not help. but they didn’t offer me anything else.

I looked at the diagnose.json logs and as far as I understood my helmet downloaded firmware 8k although my helmet is artisan.

2 Likes

@Alex.liu can you post a link to Artisan Firmware?

16bit have you tried to flash firmware 255 from latest pitool?

Earlier Pitools firmware wouldn’t likely have Artisan compatible firmware.

2 Likes

253-254 pitool Pimax\Runtime\dfudriver\p2.dfu i used this.

1 Like

the problem was solved by engineers, it was a whole special operation on remote access, thanks to the support for the good work.

4 Likes