DCS world throwing "error unknoun command: world" when launched from pitool 1.0.1.258 ppimax 8k+

DCS world throwing "error unknoun command: world" when launched from pitool 1.0.1.258 ppimax 8k+
0

Hi I try to launch DCS from pitool to take advantage of pitool settings but “error unknown command:world” appears, I have a 8k++ headset.
Tried with DCS.exe DCS_updatter.exe with same results.
Tried with steamVR launched, with it off, with Oculus software launched and with oculus software off.
If I run from dcs_updatter.exe or from DCS.exe it runs but I want to tweak with pitool settings
Its DCS non steam version.

Move post if not well placed please

1 Like

Can you post your system specs, Pitool version and Steam settings?

@mirage335 can likely help sort out getting DCS to run.

3 Likes

Hi:
pitools version is 1.0.1.258
HMD pimax 8k+
Windows 1909
Latest steamVR beta version (DCS works fine if launched from desktop with several supersampling options)
Intel i7 4790k 4.6Ghz
16 Gb DDR3 RAM 2300
GEFORCE RTX 2080Ti stock clock

If I something please ask.
Thank you.

I strongly recommend launching DCS World from PiTool only one time, and only if needed to eliminate the need for parallel projections or prevent inexplicable double framing.

My experience running DCS World through PiTool has been that it is extremely buggy, triggering a few error messages. Doing this at all is very likely no longer necessary for any reason, but at one time, it changed something about DCS, the graphics drivers, or some unknown magic, improving performance thereafter, regardless of whether DCS was launched from PiTool.

Personally, I just use a checklist spreadsheet, manually setting everything before launching simulator apps. Until PiTool supports command line parameters so things can be set by macro/batch script, I think this is the best that can be done for anything that runs under SteamVR.

You may get better results by ‘overclocking’ your RTX 2080 Ti. Unlike CPU overclocking, these GPUs simply aren’t clocked to their safe limits out of the factory. Most can reach >2000MHz without doing anything that has any chance of breaking a good condition card, voiding warranty, etc. Should be as simple as downloading the program your manufacturer provides, setting voltage and power target to max allowed, and setting core clock to something like 1975MHz for starters.

_
That said, if you really want to diagnose this further…

First, please ensure you have provided, all of the exact error message. A screenshot would be preferred. Quick google search turns up nothing DCS World relevant, though this at least confirms it is possible a ‘hello world’ LUA script entry is lurking somewhere - http://www.unrealsoftware.de/forum_posts.php?post=400667 .

Next, disable all modules (aircraft like FA18C, FC3, etc), especially any with any kind of DRM. You can enable them one by one later.

You might also try installing the stable or openbeta version of DCS World.

Moving relevant Saved Games folders, and uninstalling any mods, may also resolve this, since a LUA script may be responsible.

1 Like

If there is no benefit from launch it feom pitool I wont bother messing with that.
I’m not at home right now but the message was literally copied from the one in the screen, if there is an errata must be a misplaced character but anything more.
I google it before post here but I found nothing.
Performance is really bad and I’m surprised. I used lower settings than with the hp reverb and it performs worse than it.
I had similar results with other games but when tweaked and launched from pitools performance and graphic results where munch munch better, I just had my hopes that the same results would be achieved with DCS :cry:

Please try the following. I strongly believe you should be able to get acceptable performance with your system, unless maybe you are using maps with huge custom object counts.

  • Consult my spreadsheets. In particular, it is very important to set Render Quality to 1.25, Pixel Density to <1.2, and SteamVR Video Resolution as well as SteamVR application resolution to precisely sane values (these can get messed with by SteamVR, so check).
  • Enable Smart Smoothing if not already. Artifacts, but usually tolerable and basically necessary…
  • Run FPSVR. Look for either CPU/GPU frame latency graph showing red spikes, or values close to half framerate (full graph). Also watch CPU statistics including temperature - that chip will show 100C if thermal throttling. I cannot stress enough, disregard any performance metrics from any other framerate counter software whatsoever.
  • ‘Overclock’ your GPU.

However, keep in mind the HP Reverb may require less supersampling than the 8k+, because it may have a higher physical resolution. That means the HP Reverb, having more real pixels, may actually require less GPU per pixel, to achieve similar visual quality. Also keep in mind that the PiTool FOV setting does affect performance, and at Normal/Large, the Pimax headsets have about twice the screen area to render to (taxing your GPU more).

Of course, my favorite VR headset is the Pimax Vision 8kX, which defninitely requires the absolute minimum amount of GPU for great visual quality. :wink:

By the way, this weekend (March 21-22), I expect to publish a more formal tutorial video showing how to configure DCS World, among other things, for optimal performance with Pimax headsets, among other things.

EDIT: By the way, try PiTool .254 . I have not yet tested .258, and some other recent versions unambigiously showed 10-20% performance regressions, particularly on the more constrained CPU side.

1 Like

Thank you for your indeep reply.
I had DCS tweaked for reverb with Thud guides.
I will try to follow yours and tell mu results.
My last ok setting was with Normal fov 1 ss in pitool and 150ss in steamVR. I have set refresh rate to 72hz (I tolerate that well after some test) and smothing is on.
Checked fpsvr and there is no thermal throttling (in fact CPU performs reasonably well) and fram time iys in low 20s most of the time. But cannot stable sustain 45 fps (as with reverb) thats why I lowered refresh rate to 72.

1 Like

150% SS in SteamVR is probably way too high…

Try using around 2700 vertical pixels for your SteamVR resolutions (making sure Parallel Projections is off).

This spreadsheet should have the settings you want, and you can change things quickly with the drop downs.
https://github.com/mirage335/extendedInterface/blob/master/app/DCS/_sequence/000-param-Pimax_5kp.ods

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.