Diagnose 10600: DP Cable Unconnected

Got my backer box with base stations so time to dust off my 5K+
Installed Pitool, it did a firmware update for my headset
I started the guide
Got to part 2 and got the error DP Cable Unconnected

Checked forums uninstalled and reinstalled Pitool several times, delete the app data files etc
Still got the 10600 error.
Even tried the manual firmware update using Dfu.exe in the pimax/runtime folder in the pimax install folder
Still got 10600 error.

I noticed that the USB cable on Pimax is a USB 2.0 plug.
I had it plugged into a USB 3.0 port.
Though nah that cant be it.

Plugged USB into a USB 2.0 port and fixed!

@PimaxQuorra @PimaxUSA @SweViver I think you need the tech guys to look into this, obviously a bug with it being plugged into USB 3.0 ports. And the fact that this hasnt been fixed in over a year is concerning!

1 Like

Oh great, just put on my headset to see the screen.

it’s on the black screen with message:
Please take off the
Headset and follow the
on-screen instructions

But what else do I see, flashing white dots randomly appearing all over.
Now this was an issue with the cable and need a replacement right?!

Nevermind, just started up my PC today, and it’s not being detected again

Have to unplug the USB cable and plug it back in again.
Though this may be an issue with the cable as stated above.

Hello,

Does the issue has been fixed yet?
Or the cable still causing some issues to you?
Please submit a ticket to us, we will have the technician ready for you.

And we already forwarded this problem to the R&D team, they are now sorting the issue.

Sincerely.

2 Likes

Check this post, maybe is the same issue, due to failure during firmware upgrade

1 Like