Doom VFR poor visuals

Hi there,

Just got my 5K+.

System:
Intel i7 4770k
16GB DDR3 2300mhz
1080Ti

All working, but what I was really looking forward to - Doom VFR using the Pimax - is an issue.

I cannot get the graphics to look good at all. Looks like low resolution and all lines are extremely blocky, particularly noticeable with the lines of light that line the walls and the white lights in med kits etc. Really looks ugly.

Have tried various combinations of settings, SteamVR ss from 20% to 200%, and Pitool rendering from 0.5 to 1.5, all with no real change.

Grateful for some advice please. Was really looking forward to this but it really looks bad…

Thanking you in advance,
Dogmai

1 Like

In Nvidia Control panel turn off display scaling.

Is Doom VFR the only program with poor visuals?

Thank you again Heliosurge, will try tomorrow and report bsck.

1 Like

and he never returned =D
So it worked?

3 Likes

I’ve tried DoomVFR on my 5k+ and confirm theres something not right. The right eye does not look the same as the left eye as though AA is only being applied to the left eye. The Devs need to look at this.

Doom’s own dynamic resolution scaling is trying to keep fps at 90 and makes the game blurry. Open the console (key below esc, ~) and the console should show up. Type rs_enable to see the options but rs_enable 0 is what you want. If you add rs_enable 0 as the last line in Steam\steamapps\common\DOOM VFR\base\vr_default.cfg it might work too, or not because I had problems even trying display the console.

5 Likes

Same issue with the right lense - the resolution is different than for the left one - video

Anyone ever found an issue. I got low res on both lenses. No matter what I change Pitool render 2 or SteamVR at 200% it allways stays blocky.

I just tried Doom VFR for the first time and rs_enable 0 does nothing for me. Not in the config files and not when I type it in the console. The resolution stays at a very low level, even with pitool and SteamVR set to 200%.

1 Like

I had a similar experience months ago and gave up. Unfortunate as this is a pretty cool shooter. One of the very few titles I can’t play on the 5k.

1 Like

found something :smiley:

I played with the settings some more and I can’t really pin down which setting breaks the resolution scaling but here’s what works for my Pimax 5k+:

PiTool and SteamVR-SS at 1.0/100%

added this line: rs_enable 0
to these config files:
\steamapps\common\DOOM VFR\base\vr_default.cfg
\Users[User Name]\Saved Games\id Software\DOOM_VFR\base\DOOM_VFRConfig.cfg
(although the latter does not seem to stick)

In-game I disabled AA, only FXAA and SMAA work without issues, anything that has (1TX) in its name, will produce artifacts on the right screen. Activating “Compatible with parallel projections” didn’t help, and instead broke the resolution again for me but ymmv.

And most importantly:
PiTool V1.0.1.258 settings:
64Hz, FOV: potato, Smart Smoothing off

After getting it to work with these settings, I was able to up it to 90Hz/normal FOV.
120Hz will result in stutter-like distortions. Large FOV will break the resolution again.

To check if the resolution is higher you can just take a look at your hand controllers in the main menu. They will be very pixellated in comparison to the way that they are rendered in SteamVR.

To make fiddling with the settings easier it is a great help to skip the intro videos with this Launch Option in steam:

+com_skipIntroVideo 1

5 Likes

I bought it a couple of weeks back but it didn’t support Index ctrls so I refunded it.

I suppose this could be fixed the same way as people figured out support for the oculus rift controllers

Have you checked your SteamVR settings (the steamvr.vrsettings file)? In particular, the “maxRecommendedResolution” default is too low for wide FOV headsets and is exacerbated by the need to turn Parallel Projection on. This can cause a low resolution image to be displayed in VR.

If you haven’t yet overridden this setting, search this forum for info.

Hmm, that’s interesting. It was back at 4096 in here:
\steamapps\common\SteamVR\resources\settings\default.vrsettings

But the file that comes with PiTool was at 16384:
C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\resources\settings\default.vrsettings

I only bought it because it was cheap.
With Alyx knocking at my door, I suspect my interest in Bethesda games will be muted. Even the new Doom Eternal without VR support does nothing for me. No interest in non-VR games.

4 Likes