Double Vision when moving, PP off, 8KX, 6900xt

Double Vision explanation
Pitool starts Pi Experience. SteamVR not started.
Looking at the settings page in Pi Experience.
PP off
SS off
All view sizes e.g. normal
All Render quality e.g. 0.5
Low resolution so GPU and CPU have no issues
Looks great UNTIL
I move my head set or reposition the Pi Experience page (a bit left, or a bit right).
The double vision.
All text and the white round circles with the “<” “>” show in two or three places at the same time.
This is only for a short time, while moving. When stationary, it looks great again.

This was taken from my monitor (TV) to show GPU usage. It looks like this from in the 8Kx.
Notice in pic the text “GPU UTIL” in not double and is on the monitor.

I just did a BIOS update to 3603 and AMD AM4 AGESA V2 PI 1.2.0.1 Patch A, this made it more clear that this is a Pi Experience issue and not a 8Kx issue. Or that is my thinking at this point.

I started Support Ticket with Pimax: ## #14306 Missing VC components
And OpenMR thread: 8kx double visions not pp 6900xt

I have removed all overclock
Pitool V1.01.270
Headset v2.1.255.298 (was 296)
SteamVR 2.16.10
Pimax VR Experience 0.85.0.3
AMD Radeon RX 6900xt (27.20.15003.5017) from pitools
Radeon software: 21.3.2 (released 26/3/2021)
BIOS 3603

AMD Ryzen9 5900x, AIO 360, TUF Gaming X570 PLUS WiFi, AMD Radean RX 6900XT 16G, 32G (16*2) G.Skill Trident Z neo 3600MHZ CL16-19-19-39, PM600 1TB NVMe M.2 PCI-E4.0, 4T HHD, GX 850W 80Plus Gold, HOTAS PXN-2119II, Logitech G27 Racing Wheel. (20H2)

8Kx, Valve Index controllers and 2x Valve Index Base Stations 2.0

2 Likes

I am concerned that the issue explained above may not be a Pi Experience only issue.
Other pertinent info:

I just had great success with 90 Hz.

But I am having great problems with Project Cars 2: Which does not look the same as this
and
Project Cars 3: From the moment i start it (even while still in steamVR), makes GPU go to 2% and screen is very jerky ~3FPS maybe).

This issue with Pi Experience is all but gone.
I think it had something to do with my mother board BIOS update and something to do with resolution settings.
I am still mystified as to what controls the refresh rate and resolution for PE.
However, i wanted to let you know.
It has not gone, but it is SO much better. When I get more time it will report back.

2 Likes

Thank you for reporting this issue. Please provide us your log files to see what might have been going wrong there.

1 Like

Issue back with a vengeance.
Then updated to

Download Link: (Right-click and Save-As)

Still have the issue.

I am not convinced this is a PE issue. I am having trouble in other software.

I can not upload the logs here.

Best i can do is copy paste. Sorry!
Player.log

Mono path[0] = ‘C:/Program Files/Pimax/PE/ExperienceHome_Data/Managed’
Mono config path = ‘C:/Program Files/Pimax/PE/MonoBleedingEdge/etc’
Initialize engine version: 2019.4.23f1 (3f4e01f1a5ec)
[Subsystems] Discovering subsystems at path C:/Program Files/Pimax/PE/ExperienceHome_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 11.0 [level 11.1]
Renderer: AMD Radeon RX 6900 XT (ID=0x73bf)
Vendor:
VRAM: 16082 MB
Driver: 27.20.15003.5017
Begin MonoManager ReloadAssembly

  • Completed reload, in 0.077 seconds
    D3D11 device created for Microsoft Media Foundation video decoding.
    Initializing input.

Input initialized.

Initialized touch support.

WARNING: Shader Unsupported: ‘Toon/Basic Outline’ - All passes removed
WARNING: Shader Did you use #pragma only_renderers and omit this platform?
UnloadTime: 0.608876 ms
DontDestroyOnLoad only works for root GameObjects or components on root GameObjects.
(Filename: Line: 606)

2021-04-14 22:34:59:698 :[Debug] Awake() Initialization started…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:702 :[Debug] Searching for SteamVR Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:704 :[Debug] Steam install path found (64 bit Windows): C:\Program Files (x86)\Steam
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:707 :[Debug] Searching for Oculus Home Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:707 :[Debug] Searching for VivePort Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:707 :[Debug] Searching for Revive (SteamVR Plugin) Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:707 :[Debug] Searching for PiTool Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:707 :[Debug] PiTool install path found (64 bit Windows): C:\Program Files\Pimax
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:711 :[Debug] Awake() Initialization finished!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Starting import of new SteamVR games…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Update: Last-Played time for all SteamVR games has been updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] SteamVR game import finished! Imported 0 new SteamVR games to library.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Starting import of new VivePort games…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] WARNING: VivePort games cannot be imported because the manifest file (with an index of all installed VivePort games) is missing: C:\Users\darre\AppData\Local\HTC\Viveport\installed_apps.json
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] VivePort game import finished! Imported 0 new VivePort games to library.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Starting import of new Revive games…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] WARNING: Revive VR games could not be imported because the manifest file (with an index of all installed Revive games) is missing: \revive.vrmanifest
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Revive game import finished! Imported 0 new Revive VR games to library.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in steam platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in oculus platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in revive platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in viveport platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in pimax platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:863 :[PVR-Unity] Starting
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:942 :[Debug] Start() Initialization begins…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:944 :[Debug] Checking if all games have profiles…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:946 :[Debug] Checking if all SteamVR/VivePort/Imported games have a SteamVR profile…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:966 :[Debug] Waiting 2 seconds to retrieve all values before continuing…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:984 :[Debug] Changing view mode Basic/Advanced…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:34:59:984 :[Debug] Panel view mode show advanced: True!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Setting up 6 worker threads for Enlighten.
Thread -> id: 3254 -> priority: 1
Thread -> id: 1734 -> priority: 1
Thread -> id: da4 -> priority: 1
Thread -> id: f70 -> priority: 1
Thread -> id: 10b0 -> priority: 1
Thread -> id: 3780 -> priority: 1
Leap Service not connected; attempting to reconnect for try 1/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:871 :[Debug] PiTool Connection: Awaiting response after sending these values:
{
“ready”: true,
“message”: 0
}
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:873 :[Debug] PiTool Connection: PiTool Responded and Settings are Applied!:
{
“parameter”: {
“backBrightness”: 31,
“blackEnable”: false,
“brightnessleft”: -0.059999998658895493,
“brightnessleft_B”: -0.059999998658895493,
“brightnessleft_G”: -0.059999998658895493,
“brightnessleft_R”: -0.059999998658895493,
“brightnessright”: -0.059999998658895493,
“brightnessright_B”: -0.059999998658895493,
“brightnessright_G”: -0.059999998658895493,
“brightnessright_R”: -0.059999998658895493,
“colorChannelValue”: 0,
“comboFov1”: 2,
“comparapro”: true,
“contrastleft”: 0.20000000298023224,
“contrastleft_B”: 0.20000000298023224,
“contrastleft_G”: 0.20000000298023224,
“contrastleft_R”: 0.20000000298023224,
“contrastright”: 0.20000000298023224,
“contrastright_B”: 0.20000000298023224,
“contrastright_G”: 0.20000000298023224,
“contrastright_R”: 0.20000000298023224,
“controllerRightProduct”: “knuckles”,
“currentRefreshIndex”: 1,
“displayName”: “Pimax Vision 8K X”,
“displayquality”: 1,
“foveatedSupport”: false,
“headTracked”: true,
“hiddenarea”: true,
“homeSupport”: true,
“horizontalOffsetLeft”: 0,
“horizontalOffsetRight”: 0,
“panelMode”: 0,
“refreshValues”: “90 75 60”,
“smartfill”: false,
“startalone”: true,
“suppervivegame”: false,
“supportFoveated”: false,
“title”: “CAR”,
“verticalOffsetLeft”: 0,
“verticalOffsetRight”: 0
}
}
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:889 :[Debug] Updating SysInfo values…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:890 :[Debug] Updating/refreshing Main-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:896 :[Debug] Main-Settings updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:909 :[Debug] Listing profile settings from profile: CAR
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:913 :[Debug] Updating/Refreshing Quick-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:916 :[Debug] Quick-Settings updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:916 :[Debug] Initializing HMD values from PiTool…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:917 :[Debug] Init HMD values done!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:02:918 :[Debug] Active Advanced Image Adjustments loaded from active profile
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:625 :[Debug] Loading all Main-Settings + Quick-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:625 :[Debug] Changing view mode Basic/Advanced…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:625 :[Debug] Panel view mode show advanced: True!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:644 :[Debug] All Main-Settings + Quick-Settings loaded!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:648 :[Debug] Listing profile settings from profile: CAR
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:681 :[Debug] Refreshing Quick-Customize settings panel…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:685 :[Debug] Start() Initialization finished!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:686 :[Debug] Attempting to disable auto-start of SteamVR when VR controller is powered on (or when VR controller System-button is pressed)…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:686 :[Debug] Looking up the active config file used by SteamVR…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:686 :[Debug] OK! Found vrPathReg.exe in: C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrPathReg.exe
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:686 :[Debug] Now trying to locate the active SteamVR configuration file…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:709 :[Debug] OK: SteamVR active config file steamvr.vrsettings found in: C:\Users\darre\AppData\Local\openvr\steamvr.vrsettings
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:712 :[Debug] OK! Disabled auto-start of SteamVR when VR controller is powered on (or when VR controller System-button is pressed). After next SteamVR start, this will be saved!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:713 :[Debug] Updating/Refreshing Quick-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:716 :[Debug] Quick-Settings updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:724 :[Debug] Sets window hidden.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:731 :[Debug] Sets window hidden.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:769 :[Debug] Sets window hidden.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:850 :[Debug] Sets window mode
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:35:03:891 :[Debug] Sets window mode
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 2/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 3/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 4/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 5/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

1 Like

I can not upload this type of file here.
Best I can do is copy paste. sorry!
Player-prev.log

Mono path[0] = ‘C:/Program Files/Pimax/PE/ExperienceHome_Data/Managed’
Mono config path = ‘C:/Program Files/Pimax/PE/MonoBleedingEdge/etc’
Initialize engine version: 2019.4.23f1 (3f4e01f1a5ec)
[Subsystems] Discovering subsystems at path C:/Program Files/Pimax/PE/ExperienceHome_Data/UnitySubsystems
GfxDevice: creating device client; threaded=1
Direct3D:
Version: Direct3D 11.0 [level 11.1]
Renderer: AMD Radeon RX 6900 XT (ID=0x73bf)
Vendor:
VRAM: 16082 MB
Driver: 27.20.15003.5017
Begin MonoManager ReloadAssembly

  • Completed reload, in 0.076 seconds
    D3D11 device created for Microsoft Media Foundation video decoding.
    Initializing input.

Input initialized.

Initialized touch support.

WARNING: Shader Unsupported: ‘Toon/Basic Outline’ - All passes removed
WARNING: Shader Did you use #pragma only_renderers and omit this platform?
UnloadTime: 0.656229 ms
DontDestroyOnLoad only works for root GameObjects or components on root GameObjects.
(Filename: Line: 606)

2021-04-14 22:17:52:466 :[Debug] Awake() Initialization started…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:470 :[Debug] Searching for SteamVR Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:472 :[Debug] Steam install path found (64 bit Windows): C:\Program Files (x86)\Steam
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:475 :[Debug] Searching for Oculus Home Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:475 :[Debug] Searching for VivePort Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:475 :[Debug] Searching for Revive (SteamVR Plugin) Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:475 :[Debug] Searching for PiTool Installation…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:475 :[Debug] PiTool install path found (64 bit Windows): C:\Program Files\Pimax
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:480 :[Debug] Awake() Initialization finished!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Starting import of new SteamVR games…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Update: Last-Played time for all SteamVR games has been updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] SteamVR game import finished! Imported 0 new SteamVR games to library.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Starting import of new VivePort games…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] WARNING: VivePort games cannot be imported because the manifest file (with an index of all installed VivePort games) is missing: C:\Users\darre\AppData\Local\HTC\Viveport\installed_apps.json
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] VivePort game import finished! Imported 0 new VivePort games to library.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Starting import of new Revive games…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] WARNING: Revive VR games could not be imported because the manifest file (with an index of all installed Revive games) is missing: \revive.vrmanifest
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Revive game import finished! Imported 0 new Revive VR games to library.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in steam platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in oculus platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in revive platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in viveport platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

[Debug] Listing all games in pimax platform…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:633 :[PVR-Unity] Starting
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:717 :[Debug] Start() Initialization begins…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:719 :[Debug] Checking if all games have profiles…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:721 :[Debug] Checking if all SteamVR/VivePort/Imported games have a SteamVR profile…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:741 :[Debug] Waiting 2 seconds to retrieve all values before continuing…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:759 :[Debug] Changing view mode Basic/Advanced…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:52:759 :[Debug] Panel view mode show advanced: True!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Setting up 6 worker threads for Enlighten.
Thread -> id: 3618 -> priority: 1
Thread -> id: 578 -> priority: 1
Thread -> id: 34bc -> priority: 1
Thread -> id: 357c -> priority: 1
Thread -> id: 3370 -> priority: 1
Thread -> id: 2b9c -> priority: 1
Leap Service not connected; attempting to reconnect for try 1/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:648 :[Debug] PiTool Connection: Awaiting response after sending these values:
{
“ready”: true,
“message”: 0
}
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:650 :[Debug] PiTool Connection: PiTool Responded and Settings are Applied!:
{
“parameter”: {
“backBrightness”: 31,
“blackEnable”: false,
“brightnessleft”: -0.059999998658895493,
“brightnessleft_B”: -0.059999998658895493,
“brightnessleft_G”: -0.059999998658895493,
“brightnessleft_R”: -0.059999998658895493,
“brightnessright”: -0.059999998658895493,
“brightnessright_B”: -0.059999998658895493,
“brightnessright_G”: -0.059999998658895493,
“brightnessright_R”: -0.059999998658895493,
“colorChannelValue”: 0,
“comboFov1”: 2,
“comparapro”: true,
“contrastleft”: 0.20000000298023224,
“contrastleft_B”: 0.20000000298023224,
“contrastleft_G”: 0.20000000298023224,
“contrastleft_R”: 0.20000000298023224,
“contrastright”: 0.20000000298023224,
“contrastright_B”: 0.20000000298023224,
“contrastright_G”: 0.20000000298023224,
“contrastright_R”: 0.20000000298023224,
“controllerRightProduct”: “knuckles”,
“currentRefreshIndex”: 1,
“displayName”: “Pimax Vision 8K X”,
“displayquality”: 1,
“foveatedSupport”: false,
“headTracked”: true,
“hiddenarea”: true,
“homeSupport”: true,
“horizontalOffsetLeft”: 0,
“horizontalOffsetRight”: 0,
“panelMode”: 0,
“refreshValues”: “90 75 60”,
“smartfill”: false,
“startalone”: true,
“suppervivegame”: false,
“supportFoveated”: false,
“title”: “CAR”,
“verticalOffsetLeft”: 0,
“verticalOffsetRight”: 0
}
}
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:665 :[Debug] Updating SysInfo values…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:666 :[Debug] Updating/refreshing Main-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:672 :[Debug] Main-Settings updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:684 :[Debug] Listing profile settings from profile: CAR
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:688 :[Debug] Updating/Refreshing Quick-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:691 :[Debug] Quick-Settings updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:691 :[Debug] Initializing HMD values from PiTool…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:692 :[Debug] Init HMD values done!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:55:693 :[Debug] Active Advanced Image Adjustments loaded from active profile
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:413 :[Debug] Loading all Main-Settings + Quick-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:413 :[Debug] Changing view mode Basic/Advanced…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:413 :[Debug] Panel view mode show advanced: True!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:432 :[Debug] All Main-Settings + Quick-Settings loaded!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:437 :[Debug] Listing profile settings from profile: CAR
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:469 :[Debug] Refreshing Quick-Customize settings panel…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:474 :[Debug] Start() Initialization finished!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:474 :[Debug] Attempting to disable auto-start of SteamVR when VR controller is powered on (or when VR controller System-button is pressed)…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:475 :[Debug] Looking up the active config file used by SteamVR…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:475 :[Debug] OK! Found vrPathReg.exe in: C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrPathReg.exe
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:475 :[Debug] Now trying to locate the active SteamVR configuration file…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:496 :[Debug] OK: SteamVR active config file steamvr.vrsettings found in: C:\Users\darre\AppData\Local\openvr\steamvr.vrsettings
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:499 :[Debug] OK! Disabled auto-start of SteamVR when VR controller is powered on (or when VR controller System-button is pressed). After next SteamVR start, this will be saved!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:500 :[Debug] Updating/Refreshing Quick-Settings…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:502 :[Debug] Quick-Settings updated!
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:510 :[Debug] Sets window hidden.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:516 :[Debug] Sets window hidden.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:557 :[Debug] Sets window hidden.
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:639 :[Debug] Sets window mode
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:17:56:680 :[Debug] Sets window mode
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 2/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 3/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 4/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

Leap Service not connected; attempting to reconnect for try 5/5…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:18:08:227 :Showing Monitor 1 (Monitor 1)
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

2021-04-14 22:18:08:227 :Switching to Mouse Mode for Virtual Desktop (minimizing PE Window)…
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 39)

1 Like

Thank you for posting the logs. The logs do not indicate any issues. If you are open to it, we could have a look at it later together remotely to see why PE would behave this way on your machine.
In case you find other apps that the same issue happens on, let us know what they are, so we can find a commonality between them and narrow down the source of the problem.

2 Likes

arminelec,
Thank you for your reply.

I am happy to work together (online).
I live in China (+8 GMT).
Skype: DarrellDRea
Wechat: DarrellDRea
I still have an active Zoom account.

I have not tried many programs.
I am having a different, but similar, related issue (stutter) in
Project Cars 2 &3, and DCS world.
i did have success, without steamVR, with beat saber, and space pirate trainer

Desktop+ in steamVR look fine.

Trying to help.

The only two that are usable are SteamVR room and Space Pirate Trainer. Both easily hit 90 FPS, and look good.

All other pic have problems: Jitter.
I tried to show a range of settings. Most of the settings are listed in the pic name.

PE has a problem that does not look like the others, it does not look like jitter. It looks great stationery then Double Vision when moving HMD or resetting (moving) PE. But they probably are related.

Edit: All tests are with Pitool/PE Quality at 1 and SteamVR SS100%. This should give native resolution.

1 Like

All what i see, your steamVR resolution is much much to high

1 Like

Agreed. What’s strange is that the SteamVR resolution seems to vary quite a bit. The fact that is so high will (in and of itself) cause stuttering AND the double-image issue, in my personal experience (because the fps will be very low at that res).

First, @Darrell, what is your PiTool/PE Quality setting? For now set it to 50% and set SteamVR super sampling to a % value which yields a screen resolution where the HIGHEST value is no higher than 2000. This is just a test. I would expect a fairly low, somewhat blurry VR experience.

Now run PE and the various games you’ve been testing. Make sure that the SteamVR res for each game is the same as you set above. I would expect that you would not see the double-image or stuttering.

Assuming that is the case, your problem is simply that you’ve set the res too high, which leads to low fps, which can cause stuttering and double-images. Note that fpsVR can report the res and fps in-game, so you can verify the settings actually in use.

Personally, I’ve found that leaving SteamVR on Manual super-sampling at 100% yields a slightly higher quality (since it can omit a resizing step) and I control the actual game res using PiTool Quality. Unfortunately, that is a fairly coarse setting, but I live with 0.25 adjustments.

2 Likes

@Darrell use pitool 1.25 and SteamVR Supersampling between 40 (PP) and 60% (without PP) and your world is fine. (for normal FOV)
if all ok, than you can try in 5%Stepps go in SteamVRSS a little bit higher if you need.

2 Likes

Sure. I will try that when I get home.

Thanks for all the advice.
I have tested as you suggested, to no avail.

Description in the file name. I have no overclock on GPU or CPU (Yet - turned them off)

Even at Pi 0.5 and SteamSS at 20% pp on or off, I am getting this jitter. Still plenty of head room on my GPU and CPU. I think this is not a GPU, CPU issue. This is a Pi driver issue. Not sure how it could be a setting (but still looking).

I also thought it may have something to do with the TV I have connected to this rig (1920*1080 60 Hz). But then I was able to hit 90FPS on Space Pirate Trainer, no jitter.
If this was just Project cars 2, the why Project cats 3 is the same and why is Pi Experience having slimier (but not the same) issues.

Just for you.
Normal FOV. 8Kx LED = green.
I was not able to make PP off work. As in it still needs PP.
I added to the two dll’s and the txt file. That was the same. Both still had Jitter.

I do not really think I should play with the ppoff fix until I have this issue fixed. Good try though.

Description in the name

Strange…
Have you try to set your GraphicCard in Compute Mode?
Maybe this helps.

Well, I did not know there was one.
I have looked, i can not find it on my Radeon.

Looked ad AMD found it on their site for old Radeon
https://www.amd.com/en/support/kb/faq/dh-024

So I think they must have removed it.
That was a good try, i thought you had it then!

important update

1 By turning down in game settings, mainly track detail, i get stable imagine. still under utilized GPU. It does not say i am pushing the CPU, but the evidence says i am.
Next overclock CPU. or play for a bit with low settings.

2 smart smoothing is out of focus. When stationery, not moving hmd; It looks like two imagine side by side, slightly apart.

3 SMART smoothing, when moving; has double visions - same problem with Pi Experience.
Is it possible, there is some smart smoothing on pi experience?

It’s certainly possible that PE uses smart smoothing.

I think that there is some code in the drivers (unrelated to smart smoothing) which attempts to insert frames based on your head position, when the fps is low. This would help reduce nausea. In the low fps situation, I sometimes see double images and also (if I turn my head quickly) some black areas at the outer edges of my vision, which I think is “empty” areas that the previous image frame did not calculate, but which have now angled into view.

That is, smart smoothing takes depth into consideration, to synthesize new frames. I think this is something different, which simply shifts the last frame, according to your current head angle.

For me, this only happens when the frame rate is very low.