F1 22 VR mode - support for Pimax HMDs?

Has anyone tried the VR mode for F1 22 with a Pimax yet and if so, what was your experience?

3 Likes

I activated EAPlayTrial on steam and got F1 22.
The game did not recognize my T300RS and I proceeded to use the keyboard to set it up.
The game blacked out when loading for a ride in single time attack.
Only 2D signals are drawn and everything is blacked out and nothing is visible.

I have checked the drawing of the main menu on my 8KX.
Just the main menu displayed on a flat screen on the HMD.

Blacked out when the race is loaded…

Perhaps you need to fiddle with the graphics options.
My first impressions after an hour are the worst.
Probably under development.

I am now able to play with PIMAX for the time being by updating the graphics & wheel drivers and fixing the OSD settings.

It recognizes the headset type and works fine without PP.
Performance is not bad with graphics max settings.



4 Likes

Super good news, thanks for checking this out and informing the community!

Now to get it working in openXR

1 Like

So, this game seems to work for me with the 8kx without the need for parallel projection and using ‘normal FOV’ mode, which in turn let me run up the resolution settings enough to get a fairly sharp image, including off in the distance, while still having a high frame rate (using DLSS quality) for a smooth and comfortable experience.

Are others also able to get it working without parallel projection? I haven’t used my 8kx in several months, and last time I did use it pretty much everything required paralel projection, so I may just be quite late to the game on this:)

Hi @coverman ,

I still am struggling with getting the 8KX to work with F1 22, all menu’s and 2D I can see, but once i load up the race in VR i see only the 5 red lights countdown and the rest is black, no 3D at all , then i get disqualified and I get to see the replay just in 2D, @coverman could you please explain me precisely what you have changed in the VR settings to get rid of the Black VR? i changed the OSD to 22, but the VR resolution is greyed out to change to 9924x6320 ??? how should i change this ? FPSVR ?
I have a 8KX with a 12900K with RTX3090, what are your other preferred graphics settings ?

Agirato !

In VR settings: Stencil Mesh has to be OFF

and this helped me :

I got it to work with these settings :

I think the solution to the blackout is to turn off OSD22 & OSD fixed mode maybe.

About graphics optimization, my screenshot is 200% SS but it is very heavy.SS is 100% It would be better to keep it below. The resolution value should refer to the steamVR resolution value.

I already uninstalled it after checking it works because the wheel controller was not recognized properly in my environment and it was difficult to operate.
So I can not advise in detail.