FW update failed and nothing works [solved]

I forgot how stressful it can be to be a PImax owner as I had not used mine for a while.

And the crazy thing is I recommend them all the time and just yesterday Pimax sold another 8KX based on my recommendation and now I kind of feel bad.

Not even sure what this post is for, venting or help. I don’t think anyone can help, I have already submitted a ticket but I imagine that will take a long time to be answered and will become a nightmare to resolve once I’m back at work.

It sucks that my headset is unusable now when I want to use it.

Yes I tried manually updating it but the updater can’t see my headset same as everyone else who has posted this issue in the community. I could not find a single thread where this issue has been resolved so I’m worried.

Also my 8K+ does not have a power adaptor, it has the two USB cables like the 8KX.

1 Like

Well support got back to me very quickly and gave me instructions that got my headset working again, :slight_smile:
FW updater now says my headset is a P2 5k Formal, it’s a 8K Plus. Pitool still says it is an 8K Plus. Not really an issue, just odd.

Happy that the headset is now working but unfortunately missed my window to use it. At least if this happens again next time I get a chance to use it hopefully I can resolve it quickly.

1 Like

This is the fix that worked for me if someone else has the same issue Solution for failure upgrade to latest firmware on Pitool 259

2 Likes