Half life Alyx needs parallel projections?

Has anyone noticed the shadow in Half life Alyx isn’t quite right? If enable parallel projections, the artifact dispears, but this has a performance hit! Anyone see the same thing?
I am using Pimax 5k+ with pitool 254 alpha. Any solutions?

1 Like
4 Likes

For now, it needs PP enabled. Thats up to Valve to fix it. Which they might or might not do…

5 Likes

Turned shadows to low. Looks ok to me without PP. Or maybe i just didn’t notice, although i did play 1 1’2 hours.

5 Likes

I tried it in Large FOV with PP and again the resolution is very very bad. I changed maxresolution but I don’t know if it doesn’t work now.

I’m playing with normal FOV and PP

2 Likes

Yes, you need PP. There are artifacts if you won’t enable it.
Not sure Valve will fix it though.

2 Likes

I don’t even know what PP is but I tried it and it made it look better. Still crazy pixelation in some areas though. Even with a 2080 ti.

EDIT: What are the Foveated Rendering settings? I don’t get what they mean. Close, Aggressive, Balanced and Conservative? Close = Disabled?

2 Likes

I’d like to know this too. How can we set Max resoution 8192 nowadays?

2 Likes

I’ve read that this game has automatic adaptive resolution, so it’s possible that when framerates drop below the refresh rate you’re getting a huge resolution hit. Hopefully someone finds a way to disable this.

Also yes, close = disabled.

2 Likes

That’s true, it has adapting resolution.

It’s a very blunt implementation though, it doesn’t seem very adaptive. It’s either full, or rubbish

2 Likes

I have the VALVE INDEX controls, I have ub PIMAX 5K + and the free download of HALFLIFE ALYX in STEAM does not appear. Can someone guide me what to do?

1 Like

Contact Steam Support with copy of Hardware Survey and Serial code of Index Controllers. Let them know you have a Pimax and if you bought them through pimax.

2 Likes

the index wont show up in the hardware survey - thats the issue pimax does not expose it to steam properly apparently - you need to give them the serial numbers of the index controllers you bought with plan f and then hopefully they will add to your library - thanks to pimax for giving this critical information way ahead of time so we could all enjoy the game day 1 /sarcasm

4 Likes

And yet Valve and Pimax worked together resolving issues.

I believe Mrscopi had his show in the survey “About” in steam.

1 Like

according to this the index controllers are not being presented to steam properly which was probably why steam support said they could not detect them despite me sending a report to them

I have a bug nobody seems to get: I see black wireframe triangles instead of textures! Latest driver, 2080 Ti and latest pitool. Tried all possible settings by now. :frowning:

1 Like

Two of the best pcvr games need pallarell projection? This needs to be addressed by Pimax honestly. I played with pp on and then pp off and the difference on framerate and quality is massive. Too big infact that I started playing on 144hz small with pp off and I’m just dealing with the flickering and stuff.

This and the comfort of the Pimax is still extremely poor even with my vive das mod. Two things I hope is fixed by the time my 8kx arrives.

Please don’t just blame the devs you need to contact devs and sort stuff like this out these are the biggest titles of there.

4 Likes

I have an issue where no matter if pp is on or off 120hz 90hz 72hz or 64hz everytime I move my head left or right the screen will flicker, if I just use the movement snapping its mostly fine with a few flickers on a 5k+ sn203

3 Likes

Looks like this here…

4 Likes

This sounds like a workaround. But honestly, the shadows on High/Ultra is what makes the game so pretty and atmospheric. I would rather lower the SteamVR resolution if PP causes frameloss.

You need to increase the maxRecommendedResolution. With default 4096, everything will look bad on Large FOV, even on 5K+. The config file in use can be found in 2 different locations:

C:\Users\USER\AppData\Local\openvr\steamvr.vrsettings
or
"C:\Program Files (x86)\Steam\config\steamvr.vrsettings"

Just add this line and restart SteamVR:

maxRecommendedResolution

This is Fixed Foveated Rendering. A feature rendering a lower resolution in the peripherals of your view, to increase performance. Start by turning it off. If you have framedrops, try FFR on Conservative or Balanced.

See above.

Hmm it looks like only the polygons are rendered. Very weird. Try re-installing the game maybe? Something is most likely wrong with your game installation.

4 Likes