Half Life Alyx on Pimax 8KX

Just fired up the game and played around for less than 10 minutes and the initial report is:

  • Stable 75fps (75Hz) more or less the entire time in native 4K mode with PP enabled.
  • Looks crazy sharp and insanely beautiful!
  • Can be played without Parallell Projection, but clipping on right peripheral view will be a problem + some shadows will look wrong. With PP enabled, all problems are gone.
  • Fixed Foveated Rendering is working when enabled, help with frametimes and frame rate
  • Valve Index controllers work without any issues as far as I can see

Settings:
SteamVR SS 100%, PiTool 1.0, PP enabled, No FFR enabled when testing performance
RTX 2080Ti & 9900K at 5Ghz.

Correction:
With PP enabled and SteamVR SS 100%, the framerate can drop down from 75fps to 68-70fps (unless you enable FFR (conservative at least).
But having PP enabled and lowering the SteamVR SS to 76%, giving us a rendered resolution of 3836x3440 per eye, the game is fully smooth in 75fps so far. And it still looks as good.

25 Likes

Enjoy! Sounds like X owners will be in for a treat later this year.

5 Likes

Dont like that i have to have PP on :frowning:

1 Like

Hopefully the PP problem can be modded or is easy to put up with.

Think i’ll wait for my 8KX to play this properly, but might have to give it a quick whirl in the old 5K+!

4 Likes

I also want to wait for my 8KX, but I wonder how long I’ll have to wait.

4 Likes

just played a fair bit half life alyx on the valve index,damm what a game!
And those graphics are insane!Also superb movement options…

Never seen this in VR… Its a blast!

7 Likes

I found the clipping went away after I played a bit, but i also turned off fpsVR once I found my sweet spot.
I had a crash that seemed like a possible memory leak in the first few minutes. once i backed down the shadows to low everything seems good.

1 Like

I originally launched the game with PP on and was getting flickering in the lower/outer corners, switching PP off got rid of this. It’s odd that the PP needing to be on is only affecting certain aspects of the game, as my experience when PP is needed you are ‘cross-eyed’ without it. Is this something a PiTool update could fix, or should we ask for Valve support?

2 Likes

Sounds odd.

Well the image is not cross-eyed without PP. It looks normal. But the clipping is there and some shadows and reflections looks strange. Until you enable PP.

The clipping is caused by the game, which on purpose doesn’t render certain objects above 140FOV or so when PP is not used. What PP does is to render the whole game from a different perspective per eye (corrected for canted displays), which means there is a bit more of the peripherals rendered, and luckily, this helps by the fact the clipping happens “outside” of the viewable area of Normal or Large FOV, resulting in no clipping visible.

We can only ask Valve to fix the clipping issue. In Unity engine thats basically 3 lines of code. But Alyx is not made in Unity, so who knows how much work that involves.

4 Likes

By the way, correction:
With PP enabled and SteamVR SS 100%, the framerate can drop down to 68-70fps (unless you enable FFR (conservative at least).
But having PP enabled and lowering the SteamVR SS to 76%, giving us a rendered resolution of 3836x3440 per eye, the game is fully smooth in 75fps so far. And it still looks as good.

4 Likes

I noticed that without the PP, there is degradation or oddities in certain scenes. So I think it just best to turn PP on and enjoy the game. So far the game is crisp on my 5K+ and works quite good.
I only have: Intel 8700K (~4.6Ghz), 16G memory and NVIDIA 1080TI.

6 Likes

Gotta say the game is amazingly good looking. Not everywhere, but some scenes are insane.

Played for approx 1 hour now. No stutters at all. Smooth 75fps with 3836x3440 per eye and PP enabled. Game settings on Ultra (max). Lovely optimization!

I wonder if VRSS will be supported?

8 Likes

Damn - its the “The way its meant to be played” kind of feeling I get there!

6 Likes

I played smooth in a 1080ti, settings Ultra, Pitool 1.5 and PP in my 5K+. Medium FOV max resolution. Impressive.

8 Likes

Have you downloaded the new Nvidia drivers ?

4 Likes

Same here, although not sure where to find this ULTRA settings.
Like in Half Life 1, I feel I’m the protagonist of the story and everything is new (puzzles and mechanics) and lets face it, we are in the honey moon period of the game, I hope it never ends :grinning:

6 Likes

Its probably the in-game settings, Ultra preset is highest.

3 Likes
1 Like

That is if the different L/R camera angles are not supported at all. Which does not seem to be case here.

There are other calculations though - like the object visibility/clipping, shades and reflections (or other things) calculated in shaders etc. which might still need the camera positions and might not take them into account correctly.

Yep, reflections and some shadows are not matching up left/right having PP disabled. Latest Nvidia drivers didnt help. It IS fully playable without PP, but clipping is annoying, especially in down in the serwers where doors clip out and you see a bright texture instead in your peripherals.

Im sure its possible to fix, but its up to Valve to make it happen.

3 Likes