Helmet does not Turn on

Hello

I have a 5K +
pitool 253
firmware 264B
my spec
Gigabyte X570 AORUS Elite
AMD Ryzen 3900x
Gpu GeForce RTX 2080 gaming X Trio 8gb
G.SKILL F4-3200C16D-16GTZR Trident Z RGB Series 32 GB

and my problem is that the helmet does not turn on the first try,
I have to turn off and turn on several times before I can use it,this is really frustrating,
I try on different USB port, external and internal,
I remove the wire and put back in place with always the same result,
I do not know what to do,
someone would have an idea to solve the problem

Thanks for your help

I suggest you run the Pitool internal diagnostics when the headset is *not recognized and run it when it *is recognized the compare the results. This may reveal the issue.

Also you could try clicking the restart service button and see if it recognizes the headset without cycling the power.

You could also make sure the headset cable is seated properly. You can pull directly on the cable right at the point where it mates to the headset, when you reseat it the rubber cowling should be perfectly flush with the headset body.

If I were guessing I would speculate your issue revolves around a rogue driver somewhere interrupting access to the usb controller long enough for it to time out. I saw this issue occur a couple of times, once it was the CPU fan LED color cycler app and another time it was a persons usb printer driver - in both instances a clean windows 10 install solved the issue.

2 Likes

thank you for your reply
I actually use the software diagnostic and it tells me that the headset is not connected usb and the service has no problem it is still the usb connection which is not recognized, my windows installation is new and the pc is only for vr, I will try to find what could as you suggest me find what interrupts the usb port, and for the wire I actually remove and replace in the headset without change

2 Likes

Close all Pi tool Related items in the back ground then restart pitools then physically Turn off the HMD on and off Should work.

3 Likes

I had this problem before, using a different port on my GPU solved it for me.

2 Likes

Thanks for the suggestion i will try that

1 Like

Yes that is good advice. My og 8k likes dp1 on my gpu and 5k+ on dp2 only my r7 2700x 1080ti. While my other system seems fine on dp1.

I had this problem before, using a different port on my GPU solved it for me.

Thanks :wink: it works well so far, only once the headset didn’t want to turn on but it’s a big improvement compared to before !

2 Likes

Hello,
to follow up on my problem
now I have to completely turn off my pc and restart it,
this way my 5K + always turns on first when I turn it on,
it is only in this way that I found a solution,
I do not understand why!
its a little crazy!

if not i have to turn on and off several times before it turn
on and when, i have error code 20300 my pimax 5K + turns on
and before i still have error code 10600,
i tried yet, all usb port but no solution found for me …
maybe a firmware problem ?
I would like to find a solution!
because I love my pimax !!!
(and sorry for my english ;-)!

1 Like

if it’s firmware then try to install new 263 pitool it should uupdate FW on your HMD automatically.

But I guess it’s something related with your PC hardware, drivers & software.

Try this batch script:

Copy content from below section & put it in file with .bat extension, now with only 1 click you will stop all pitool services & processes. if doesn’t work try to run it with administrator rights by right clicking on it & selecting appropriate option.

BAT file content

@taskkill /F /IM PiTool.exe
@taskkill /F /IM PiService.exe
@taskkill /F /IM pi_server.exe
@net stop "PiServiceLauncher"
set /p WAIT=PiTool software services were stopped. Hit ENTER to continue...

2 Likes

Thank you !
I will try this and I will give you some news

1 Like

Set windows power plan to high performance. Then go into the power plan options and disable usb suspend/sleep.

3 Likes

Thank you all for your help
but nothing changes I will live with it, the most important and that I can get my headset working and maybe a firmware will make a change one day :wink:

I see you have quite fresh GPU so I almost sure it’s nor relevant in your case but worth a try:
https://www.nvidia.com/en-us/drivers/nv-uefi-update-x64/ try to update GPU with this to enable latest DP port features

I suppose you update drivers periodically so it also should be fine

I see ppl with 2080 also have a lot of issues with detecting the 2nd monitor & some stuff with 144hz mode & so one which 5k+ supports https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/289049/rtx-2080-doesnt-detect-second-monitor/

So I bet it’s something with your GPU & some firmware/hardware internal logic that detect & switches the ports

Try also this hack:


do all he did & plug only 5k+ once capacitors in SPU of PC is over run your PC & in 30 sec plug your monitor it can change some GPU internal state & it might work better for you
3 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.