Help, game patch missing

So I haven’t been able to get my 8KX headset to track, the icons for the base stations are blinking blue but not connecting. After some troubleshooting I found that the “diagnose” button in the “help” tab told me that I had two patches missing, KBKB3033929 and KBKB2670838, and that I needed to install them. I have absolutely no idea what these are, where I get them or how I install them. Any help with that would be appreciated.
before anyone asks, I had already sent a support ticket to Pimax but they haven’t responded after almost a week.

remove the second kb and its the normal name scheme for microsoft patches
only odd thing is that they seem to be win7 patches

KB2670838

KB3033929

1 Like

I use windows 10 and not 7, but I tried both of those anyway. The first one said that it wasn’t applicable to my computer and the second was already installed. On that train of thought, I had gone to windows update settings and there was an update there for download, but I installed it and rebooted and that didn’t seem to change anything in pitool.
Thank you for the suggestion though.
Though on that note, the diagnosis window also seems to think I’m using windows 7. Would that cause any problems and if so, how would I fix that?

1 Like

If you have upgraded from Win 7 to Win 10, and never made a clean Win 10 installation, which I suspect: don’t wait for MS or Pimax they won’t solve it for you. Format C. Get a clean, up-to-date Windows 10 installation.

Honestly.

3 Likes

not sure if it need that kind of drastic measures, might be enough to remove pitool with all the different settings folders
maybe its just some old settings pimax uses when creating a report

at least it explains why pitool suggests win7 updates

Actually this machine has never had anything other than windows 10 on it, though I did have to reinstall windows about a month ago because windows decided to stop working. I had thought that I fixed it, but I guess maybe I didn’t. I don’t know. In any case reformatting everything seems like a big task and I won’t have time to do that till this weekend. Still, I guess that could be our “nuclear option” for now if there isn’t another fix. Thank you for helping.

I had actually already tried that. And I mean not just uninstalling pitool but deleting everything left behind in program files, documents, program data, appdata and wherever else I could find it. Thank you though.

Ok, so. I went and reformatted my entire computer and it did indeed fix the game patch issue. Everything in the diagnostics window is green across the board. However now it’s not tracking because the it says that the sensor detection is abnormal in the motion compensation window. I’ve actually had this issue before and fixed it, but I don’t actually remember how I did it.
In any case, thank you guys so much for helping me.

Hi

(Edit: Caution! Please do not do the following. It will be troublesome.)

May be low possibility but please check as below.
properties of pitool.exe shortcut -> compatibility tab -> Compatibility mode ->
:ballot_box_with_check:Run this program in compatibility mode for
windows7

Edit:
Sorry for my late posting

And now my PC is in the same condition as you before starting pitool.exe with windows7 compatibility.
Even if I reverted the compatibility settings, reinstalled piool and restarted my PC,
Pitool’s DIAG required always the game patch to be installed.

I am a little afraid, but the solution is to uninstall pitool and delete all the folders below
(including folders without problem, it may be).

C:\Program Files\Pimax
C:\Users\yourname\AppData\Local\PiTool
C:\Users\yourname\AppData\Local\Pimax
C:\Users\yourname\AppData\LocalLow\Pimax
C:\Users\yourname\AppData\Roaming\PiTool
C:\ProgramData\pimax

I think it is the content of “enough to remove” mentioned by @IG88.

It’s a repeat of what @IG88 mentions that Pitool seems to have some hysteretic configuration
issues that can’t be solved by just uninstalling.

yeah at some point you start to do documentation and change management like you do at the workplace

1 Like