How to force smart smoothing

How to force smart smoothing
0

Is there an option to force smart smoothing so I will always have 45fps? I can’t stand jumping from on/off every few seconds. It’s very noticeable when SmS get activated.
Maybe I can lock fps in steam vr using reprojection?

As far as I know there’s no option to force it “always on” like You know from SteamVR, so what people mostly do is make sure FPS stays between 45 and 90 or 36/72 and so on depending on which refresh rate You’ve chosen.

1 Like

Is there an option to lock fps via 3rd party software? For example can I lock maximum fps on 89 so SmS will be always active.

Not that I know of, no.

I forgot to reply here, but I have forwarded this request to the devs. Indeed we need a “force” option for this, as the transition between 90fps and SmartSmoothing kicking in on framedrops is causing a slight delay and stutters.

5 Likes

Thank you SweViver. This option is a must in a performance segment. Hope they will add it within a month :wink:

2 Likes

Good idea:+1:…

So, what was the devs reply? There is no such feature in the latest PiTool yet…

Is it possible to force it via steamVR?
This option really should be added as an essential for ppl using smart smoothing in sim games.

Depending on the title you can try limiting the FPS of the game or games in question using Riva Statistics Tuner. It works for me in some titles but not in others, and I’ve found that if I set it to exactly the FPS I want I get stuttering. For example, I don’t ever want SkyrimVR to run above 45fps - I always want it to use Smart Smoothing, but it tries to turn Smart Smoothing off in many indoor areas. Adding the SkyrimVR executable to Riva Statistics Tuner and setting it to 45fps results in major stuttering, but setting it to 47fps works well for me. Occasionally Smart Smoothing will attempt to ramp up the fps to 90, but it will hit that 47fps ceiling immediately, bounce back and forth and get stuttery for just a few seconds and then give up. That’s way better than what was happening when it would bounce to 90 and the get stutter all over the place for like 20 seconds when I turned a corner and the view opened up again. Hope that helps a few of you. Wait, maybe I’m thinking of Fallout 3 running through vorpX (but still using PiTool Smart Smoothing). Sorry, not at my system right now. Either way, my example holds.