How to Play Half Life Alyx WITHOUT Parallel Projection on Pimax Headsets and StarVR One!

Includes clip of me playing HL:Alyx culling free:

Add this command under Half Life: Alyx -> Properties -> Set Launch Options

-console -vconsole +sc_no_cull 1 +vr_enable_volume_fog 0


That is pretty cool. I wonder why Valve doesn’t have this setting visible and/or on by default. Nice find.


Culling usually improves performance. That’s why the command is not used by default. But I think Valve should have made us aware of this command for us wide FOV users. I notice no reduction in performance but that might be because of how well optimized the title is and the dynamic resolution.


Yeah can see that. Also by keeping it off and not having it a visible setting gives them an edge on their narrow FoV headset vs a Wide one.

Ie " Looks nice with Wide FoV, but will the culling better on Index"


Ooooooor, they could calculate the culling frustum correctly to begin with, so that you don’t need to disable it. :7

I guess the same option should work with SteamVR Home, by the way…

EDIT: Watched the video… The black smudge looks like the shadows spazzing out.
The shadows were already rendering incorrectly before, when not rendering parallel projections, along with various forms of decals (bullet holes, spatter) - not seeing any of that?
(…and still not noticing any difference in performance, if you disable adaptive quality?)


Agreed it would be a good experiment in VrHome.

Liked and subscribed. This is incredible


Excellent work! Nice! Perfect timing for the 8KX release… well, hopefully.


I put this here, I let you do the rest (thx to dmel642):
you can edit this file to have the same effect for steamvr home (still have shadows issue):
path: “your_steam_path\steamapps\common\SteamVR\tools\tools.vrmanifest”
bellow “app_key”: “openvr.tool.steamvr_environments” you have the key “arguments”, you can add the necessary command at the end.


There are some slight moments of jitter in certain spots where it goes down to 80fps but I haven’t played it enough in various areas to know for sure. Probably the larger the map level, the more affect it has.

As for black smudge. I’ve tried every “shadow” related command and haven’t figured it out yet. It looks like the shadow problem is coming from dynamic objects/props. I’ve been reading about dynamic object lighting here:,shadows%20from%20those%20light%20sources.

My goal is first to disable shadows on dynamic objects. Then enable it but find some kind of strength settings. I’m hoping reducing intensity will help. The third possibility is that since this issue only occurs on the right eye it must still be some kind of culling/rendering issue beyond the camera’s FOV.

I did notice spatter and water reflections were also a problem. Will try to fix that too. Haven’t noticed bullet holes.


@dmel642 Your persistence and patience is admirable, thanks :slight_smile: