Index Controllers tracking issue with Pimax 5k+

Hello Community!

I’ve been having issues when I change my HTC wands for the index controllers and I can’t pinpoint the source of the problem. I’ve contacted Steam Support but I was still wondering if any of you guys had a similar situation. Steam support said: “The Vive controllers are tracked directly by the base stations, while the Index controllers use a combination of Lighthouse tracking and radio communication with the headset.”

So here it is:

When playing beat saber, after 3-5 min, I start seeing the saber losing tracking. After 10-15 minutes, it starts going crazy with the saber going under the floor and coming back after as long as 5 seconds. Crazy thing, when I quit beat saber and go into Steam Home, moving my hands quickly will result in the same behavior. I also start seeing this king of behavior in Creed: Rise of Glory.

It’s quite annoying when trying to beat that expert + song XD

I did it all: disabling wifi, Bluetooth, covering windows, unplugging all unnecessary components, etc.

Any ideas?

Thank you Pimaxers

1 Like

You might want to try using different USB ports on Your PC as it sounds like when using Index controllers extra data might be going through USB from the headset to the PC.

If nothing else, it’s easy to try to switch ports… :upside_down_face:


Thanks, I’ll try that!

I just hope it’s not a compatibility issue between Pimax and Index, as many backers will receive Index controllers and base stations.

OMG, hey ho, i’m actually in the middle of a RMA process about this specific problem. I didn’t think of it being a compatibility issue between Pimax and the index controllers but i’m almost 100% sure it’s not because. I tried with my old HTC Vive headset and it was the same there. I believe it’s a vibration issue.

If you go into to “How to play” in Beat saber. Then point the sabers on each other so they start vibrating. Do they start glitching around a little bit? My left controller start glitching really much after a while and then it starts losing tracking completely. Same with my right but it’s better than the left.

I got a new pair from Valve now but they are the same, though they are better and i can at least finish 2 songs in beat saber but then they start jumping around.

I also tried playing with my original Vive controllers and they work completely fine. I also tried on another computer and still the same problem. Just now i tried the index controllers with my Odyssey+ and it happens there as well.

Guess i’ll have to send these back :frowning:

Does it work if you turn off beat saber vibration?

I’m sorry to hear that, but thank god I’m not crazy!

I cannot pinpoint if it’s the vibration that’s causing this unfortunatly. Are you using base station 1.0 or the valve index base stations?

Paul’s suggestion is worth a try. Googling and I found a way to disable the vibration:

I’ll try that on sunday when I’ll have a minute. Keep me posted if you don’t mind :slight_smile:

I was able to record the problem. This video was taken after a 15min play session in beat saber. I quit the game and start shaking my hands in steam home. As you can see, it’s pretty easy to loose tracking:

Does your problem look like this?

1 Like

I’ll check if it does.

gonna check now if it does. I’ve seen on youtube someone with the same problem as yours, he did the same movement and it lost tracking btw. Anyway gonna check if it’s the exact problem we both have

I have 2 Friends with 5k XR e 5k+ with your same problem…they are still looking for a Solution…

Now Pimax support propose to one of them to check by TeamViewer…but he Is still waiting for this check…

I don’t believe it’s a problem with pimax since the same problem appeared when i was using Odyssey+ yesterday but im not 100% sure, i just saw the vibration issue was there with Odyssey+.

BUT today i tried without vibration on my Pimax and the controllers started losing tracking so it’s maybe not a vibration issue. hmmmmmmmm.

Since i have 2 pair of Index controllers at home now I tried switched controllers when the problem appeared and the other pair had the same issue even though i didn’t use them before. So maybe it’s not the controllers? Maybe it’s actually some software on our computers but it seems unlikely since i’ve tried this on another computer. Can it be the lighthouses?

Now my controllers for some reason don’t get the problem all of a sudden, not sure why. I could play a whole hour without them glitching away…


Odissey it’s inside out WMR not a Lighthouse System… it’s normal that with Odissey… it’s a big problem for a Lighthouse System…

My friend if use the same controller with Vive not has any problem. The problem Is on Pimax

I dont know if it’s a problem only with some old model…I dont know I hope so…but the risk exist…

I used Odyssey+ with a program so you can use Valve index controllers. The controllers tracks only from the lighthouses then and not the headset.

1 Like

I know that System…I dont know if Is a perfect System.

Anyway about problem that has my friends there Is no doubt that it’s because of problem with they HMD Pimax. With Vive works perfectly

Does it happen with Pimax only, or with any headset (Index, Vive)?

For me it was the same issue with my OG Vive using 1.0 lighthouses. But maybe I have another issue. Here is my problem. 2 pair of controllers having the same problem. Am i unlucky so the controllers are defective?

Notice how the left one shakes much more than the right while vibrating. This time the right controller glitched out more than the left towards the end. I can still sometimes move them but the vibration completely stops for a while. As you can hear.

I don’t have any other hmd, but Zoyer tried with a bunch and they all had the same problem.

@zoyer yer I’ll do multiple tests as doon as I can to see if I have the same behavior.

@Marco, would it be possible to keep us posted about your friend’s teamviewer session?

Hopefully, this gets resolve before a whole bunch of pimaxers receives their index controllers and bases stations :slight_smile:

Sure, I’ll let you know

1 Like

Sounds more like some sort of Beat Saber or base setup thing. Don’t own BS, but I can offer that my Index controllers with V1 bases work great in all my games (especially Oculus Touch games) in my Pimax.
I had to RMA my Index controllers for a bad ministack and returned to wands for a week then back to Index. No issues with either working in Steam. 20 controller based games installed.

1 Like

I actually don’t have problems with any games that I own, except beat saber and Creed: Rise of Glory (Creed bugs but only sometimes). I need fast paced game to test it but even Pistol Whip works fine.