Inverse colors at startup/initialization, sometimes invalid replaced color

Hi all

My Pimax Artisan has a presisting issue.

After the pitool shutdown, computer restarted or similar, and then restarting the pitool, the screen colors are often reversed. This happens maybe 3/4 probability when restarting the headset.

Usually they are initially both displays reversed in color, so that the screens look like a negative image (black->white, white->black, yellow->green etc). After restarting pitool or clicking “reboot HMD” it usually fixes one of the displays but rarely both. After several reboots, restart service clicks, or restarting pitool it by luck starts up properly and then the colors are normal again until next time the headset is shut down and restarted.

It may be that cycling the power of the headset by disconnecting and reconnecting power supply has highest probability of fixing the color inversion. I did not test extensively but it may be that “cold power-up” by having unplugged power cord instead of unit on standby by pressing the power switch on the headset gives more reliable startup regarding this inverted color issue.

Sometimes just a small range of colors (darker ones) are somehow “bit-shifted” so that there is a color effect on all pixels with certain level of darkness tone. Rebooting HMD usually helps.

I believe this is driver/service level or firmware level issue. Something is not done correctly at initialization phase of the headset.

1 Like

In addition, sometimes there is a weird colored randomly pixelized fixed horizontal stripe pattern that is triggered by bright areas in the image. I’ll try to attach an image of it.

It randomly appears on right or left panel at HMD reboot. It also goes away by performing HMD reboot. The side it appears on varies. Another indication that panel start-up routine has something wrong.

In the pictures there is a small window of Elite Dangerous with white title bar that causes the artifact on the right side of it.

It could be the cable, but it also most likely could be software/ firmware.

what version of firmware are you on and pitool version

I had a similar issue with my 5k+ back in early 2019 and it turned out to be firmware

@Century also had an issue similar to yours in that same thread here

2 Likes

Yes, it was on OG 8K from time to time.
It was like some kind of picture freeze, possibly caused by a glitch.
But after the reboot, it passed.
Yes, and it was in both displays at once.

I did not notice this with 8KX, which pleases.

pitool v1.0.1.266
headset v2.1.255.269
win10, X570, ryzen7, amd 6900xt, all latest drivers

Maybe it has something to do with temperatures or leftover bit states in the controller chips, because I don’t recall this happening (at least not often) at the first start-up when the headset has been completely off for several hours. At warm reboot it is very common.

This is gettingi annoying. I just restarted the headset, rebooted computer twice, unplugged&replugged the headset power adapter etc. for at least dozen times. Finally started up without either display having white (inverted) screen.

A fix is needed. By the way, the headset is just a few weeks old.

Is this forum something that Pimax people read or where should I report this?

Hello!

Unfortunately I have the exact same issue with my Artisan.

I had it the first time yesterday, after being force to update my AMD GPU driver (for a reason I don’t know). I don’t know if there is a connection.

I’m using the following versions :

  • Pitool V1.0.1.266
  • Firmware V2.1.255.266

I’m using R5 3600 and RX 5700XT Nitro+.

Even if I feel like support dedicated to Artisan is quite low, would be very nice to get this solved as it’s more than annoying when you have to join a championship online race on time…

@PimaxQuorra
@Alex.liu

The last firmware patch rollout did not involve the Artisan model.

Is a fix for the issues turning on the display panels possible in a firmware patch and coming anytime soon? (inverse colors, brightness induced stripes, or panels not turning on at all. also had once gyro tilting 20deg when left on the table)

I’m averaging ~10 HMD reboots each time until I get lucky and it works properly.

1 Like

Here some pictures of how it looks :



Hope it can trigger some advices…

I had contact with Pimax technical support after submitting a support ticket. They tried another firmware, did some checks and I sent them images and video of the issue. The issue persists. It appears the technical team is looking into this.

The sales team, on the other hand, directed me to contact the seller since my headset is purchased from a seller in EU and not directly from Pimax. The sales team’s advice was to try to replace the cable or, if that does not help, the headset. I don’t have a recommendation from the technical team as they only passed the information to the devs.

I’m not sure if the headset replacement helps or if this is a firmware issue with latest AMD drivers but maybe I will try to do the replacement with the seller.

1 Like

Alright then I would prefer to wait for a possible fix. As I really doubt it’s an hardware issue. And it appears right after my AMD driver update…

When the headset boot correctly I don’t have any issues at all, it’s working fine…

Did they try a fresh new and “clean” installation of Pitool too?

Thank you for sharing your information!

Same problem, I think this is Artisan driver’s bug, it haven’t compatible with AMD 6000 series card,my card is 6800xt, I tested with NVIDIA 3070, it’s no problem, according to online content, I know 8kx, 8k plus has repaired this bug with AMD 6000 series card, hope Artisan’s bug will repair soon

In 120hz mode, after restart service some times maybe normal, in 90hz mode, always have display problem, in 72hz mode, it can’t connect, led always is red

1 Like

Maybe Artisan devs couldn’t get any of the new AMD cards on their hands :smiley:

Hi RedX,

Have your problem been solved?
If not ,you can contact with Pimax technical support again.

Apple

No solution yet. I’m about to receive a replacement cable in a few days. I’ll write here if it has any impact.

1 Like

Ok.Looking forward to your reply and confirmation.

Apple

Hello,

I received and replaced the cable but nothing has changed.

Do you believe that a firmware update will arrive that would fix this? One hypothesis around forums is that the issue has something to do with the new AMD GPUs.

I need to communicate to the headset seller whether to wait for firmware update or pursue hardware replacement and that would involve back-and-forth shipping and long shipping delays. Any estimate on firmware schedule would be great.

Best regards

1 Like

(post withdrawn by author, will be automatically deleted in 596 hours unless flagged)

Hi RedX,

I think: you can contact with Pimax technical support again.

Apple

Hi!

Just for you to know.

I had some troubles with my Artisan firmware, after I decided to update with hope to solve this issue. Had to go through multiple flash using support from pimax website to get it back, because I went into trouble due to automatic update with PiTool.

Anyway, after a firmware flash to put firmware 270, and a fresh new Pitool installation, I still have the inverted colours issue when starting the headset. It needs multiple reboot to get it work normally. But when it does it’s great and have no other issue.

I have created a ticket, let’s see if they can do something…