IPD Settings: PiTool or PimaxExperience?

Okay, so after much fine tuning I’ve finally found my proper IPD offsets for both horizontal and vertical. Now in order to do this, I was using PiTool and a static image in the HMD- not PimaxExperience.

So after getting my settings correct in PiTool, I then go into PE to launch a game- only to discover that PE now shows literally the reverse of the settings I just put into PiTool.

In this case, -1.1/.1 and -.4/-.6 in PiTool becomes 1.1/-.1 and .4/.6 in PE; effectively zeroing out my changes.

So my question is: Where do I put the proper IPD values? I’ve been launching games and setting profiles in PE, so do I go back to the defaults in PiTool and then adjust in PE? Vice versa if I was launching from PiTool?

In other words, do you only put the IPD values in the program you’re launching from, or does PiTool override PE?

Hope that makes sense, it took alot of work to get the IPD right.

Thanks for any help.

2 Likes

Yeah saw that too I think it’s just a bug @arminelec

BTW what strategy did you use to find the right offsets?

1 Like

So is it keeping the right values then? Hopefully?

As far as finding the values, I downloaded an image referenced in another post/wiki here. The link in the wiki is a 404, but if you Google “pimax ipd adjustment image” and look on the images results it’s the second result. The one with the red, blue and green lines and the words “Pimax upscales…”.

Post here: https://www.reddit.com/r/Pimax/comments/aq77kz/heres_a_way_to_precisely_adjust_your_ipd_settings/

After snagging the image off Google, followed the instructions to replace it as the pimax default image
(directory: c:\Program Files\Pimax\Runtime\resource (rename the existing pimax_default.jpg if you want to save it, otherwise just delete it and rename the new image the same name) and rebooted PiTool.

First, I set the mechanical offset to its clearest level.
Everything else is software adjustment.

In PiTool, first turn off the PiTool and PE home experiences so it just shows the static/default image you just made the default.

Then, just a matter of adjusting the values in PiTool using the arrow keys to change the values while looking at the pic in the HMD. I had to click on the slider bar in PiTool to get it to register the keyboard strokes and change between the settings.

Align up all the lines (I used the green because it’s like RIGHT there in the middle and easy to see) using the horizontal and vertical adjustment settings.

Start by aligning the horizonal IPD (lines) and then move to the vertical. You’ll know when you get the right setting because suddenly everything will go ‘clear/sharp’. It’s a little fiddly and sometimes it can help to OVER correct the separation just so you can find that exact spot you’re after.

Also, I found that by looking at the edges of the picture with your eyes you can fine tune it a bit easier and also decrease the warp a little (at least for me). The lines should be fairly straight all the way along the image. If you can’t get them exact all the way across from edge to edge, get it as close as you can.

Once you’re done, the whole image/lines should look 3D and have some depth to them.
Once I got everything dialed in, the image is just really immersive and has proper depth. Half Life: Alyx looked damn good before, but REALLY pops now. Can’t describe it, but there’s a marked difference in clarity and depth/presence.

Well worth the time and effort it takes, but DAMN someone needs to write out an easy to follow step by step to set the IPDs. Scouring posts to glean the process was a chore.

Hope that the instructions make sense and helps you! :grinning:

7 Likes

yo IMO the pimax headsets are wonky with the way the face plate it placed. When I first put on the headset something was wrong. MAKE SURE THE FACE GASKET IS CENTERED PROPERLY. you should not have to adjust per eye ipd unless you have a screen issue, or have weirdly placed eyes. that worked for me. the gasket was like 2mm off.

I found also some opposite convergence values in PE and Pitool ( link ). I was checking that 2 times. Funny, after restarting, another day, everything was consistent, booth have “PE” behavior ( +++ = more convergence on booth eyes). It is better this way.

1 Like