Is it safe to use the PiTool updater yet?

For a while using PiTool’s built-in updater has reverted to an earlier version. Can we use PiTool to update itself, and the HMD firmware?

2 Likes

good question, I would love to know that aswell before I order my 8k X

1 Like

And PE all at the same time?

1 Like

I can’t say for sure with Firmware. Though atm with PE latest version is using 2.087_v2 so the updater will likely point to another version that is earlier as this is newer than 266.

1 Like

Just press the button and see which version it wants to update to… :upside_down_face:

Which version are You on now?

If You’re on a 1.0.2 version You’ll “upgrade” to latest 1.0.1 version (I think it’s 261?).

I think 1.0.2 versions were/are meant as internal development versions which were just released at some point causing the confusion as they’re not considered upgrades by the version checker in PiTool.

They use totally different versioning internally.

2 Likes

does the pitool 087 w/ experience 074 have a guided IPD setup?

1 Like

I don’t believe so. Haven’t installed yet. If it did it would be highlighted in the release notes.

1 Like

No it’s not there yet…

2 Likes

I just made the mistake to upgrade the firmware (got the device from the factory, so I thought it wouldn’t hurt to install the latest version, particularly as it meant it’s outdated).
The firmware update failed. My usual repair approach with disconnecting, pressing power+volume up+volume down, releasing power, releasing volume up, starting DfuSeCommand.exe 0 P2_RELEASE_* doesn’t seem to work this time :frowning:
Any ideas.
Pimax, please make your firmware updates more safe! Always being at the risk of bricking the HMD when pressing update isn’t funny!

2 Likes

If it is the 8kX try the 8kX firmware on tge forum

Yes, it’s the 8kX, tried this firmware: 8kX 294 Beta Firmware Sept 8, 2020
It doesn’t even start to load though apparently…

Here more infos from the ticket I just wrote:
I installed the latest PiTool and PimaxExperience on my machine.

As PiTool mentioned that the firmware of the 8kX is outdated (not unlikely for a device that might have layed around in the warehouse for some time) I clicked on update firmware. This failed.
Then I downloaded the latest 8kX firmware I could find:


and tried to install this. First with Dfu.exe (with the PiService being loaded).
Then with the PiService unloaded and DfuSeCommand 0 P2_RELEASE_R…dfu
The latter usually helped when everything else failed. Not this time. The 8kX just stays in DFU mode (the leds cycling between red+blue+green), but DfuSeCommand writing:
0 Device(s) found. Plug your DFU Device !

Target 00: Error Code: Unknown error 0x12340005.
Target: 00
Error Code: Unknown error 0x12340005.
TransferSize: 0
DFU State: STATE_IDLE
DFU Status: STATUS_OK
Request: (unknown 0x1C000000).
CurrentNBlock: 0x974B62D
CurrentLength: 0x76F2EF
Percent: 0

1 Like

Edit: Got it working. Before starting DfuSeCommand I had to start stm_dfu_3040_64.exe, apparently the transfer driver wasn’t installed anymore.
Uff…
This update process is still a little too shaky for my taste…

3 Likes

P.S.: The panel backlight slider still does nothing, also with this firmware…

Glad to hear you got it working. Might be shaky at times. But at least not like the Amd Vega Bios which are known to be very flaky and easy to brick. My friend whom used to write custom Bios for Amd cards recommended against flashing them when a member asked me about flashing a water cooled modded bios on his Vega.

I don’t know if the newer Amd cards have this issue still.

1 Like

This may or not be related but my controllers are behind PE. Even If I put my hands in front of my face. The sticks will move the menu up and down. The beams are also behind the screen. I have a green light on but most of the time it is a dim red or purple. Tried unplugging my 8K+ and my two BS and rebooting my computer. PiTools V 1.0.1.163 headset V 2.1.255.269

Hello,

Yes sir, you can use the built-in updater to update the version.

Sincerely.

OK, So I have my 8KX and i’m trying to go over everything needed to be done, so help me out with steps.
What is the latest Pi tool I should download and is the site safe as my Norton seems to be blocking it.
2. Do I install the latest beta PE .74
3. Do I really need to update the firmware? I don’t like seeing some people having issues to where it makes this not work, so is it necessary, prob is though for this low backlight issue I’ve been reading about.
First I’ll test it out before any firmware updating. tnx everyone hope all goes well tomorrow.

Well, for many months now I use only the built-in updater for both Pitool and firmware as I am not interested on all the various beta non-stable versions.

So far it always worked though sometimes I need to check several times (it can fail to connect/download the update).

Maybe there could be problems when people use various beta versions of Pitool/FW which were not released as main branch - such scenarios are probably not tested.

I just updated to PT V1.0.2.087 today (and PVRE 0.80 just now). Anyone know what the correct latest FW is? The check suggests ‘2294’. Is that older or newer, I can no longer tell :crazy_face:

image

image

1 Like

Must be this one (out of beta, I guess) with an extra 2 in front and no space… :slight_smile:

1 Like