Is there a BUG in the 8KX 295 update posted here?

I have used dfu.exe and the 295 firmware update for my 8kx. The LED will go from green to a dim red.
Then I get a device disconnected message.
Then the LED will go to a bright red momentarily, then I get a connected message, and the LED shows green.
This takes approx. 7seconds. Every firmware update I have done takes longer than that for the most part.
When I check the version in Pitool…it still shows the .294!!! I have done this 5 times now with the same result.

Am I missing a step somewere. I tried that flashertool program, it can’t even see my pimax, after stopping all the requested services.

Is Pitool supposed to be showing .295 on update. Is the update supposed to take approx 7 secs. Seems quite fast for firmware.

I am running the 1.0.2.87 V2. Right now after trying update firmware still shows 2.1.255.294

I saw a video earlier today, his pitool showed the .295 firmware.
I am really hating this headset more each day. I try and follow all your suggestions, just makes things for frustrating.

I get it, I’m not a power user, just someone looking for some assistance…so I too can enjoy this damn Pimax 8KX.

Thanks for any help

Try following @NextGenVR 's instructions here

he links thie 295 firmware in the video , i’ll also post it here

@Heliosurge it would be nice if these files came with an sfv for hash verification so that we don’t flash bricks. I’m not sure if dfu.exe does this check, (I would hope so , but then again it’s pimax) :crazy_face:

EDIT: You don’t happen to have a Thrustmaster steering wheel or TH8A shifter do you ?

I can’t confirm this but I know that the firmware chip on those products use the same Guillemot chip that the pimax uses and they install a different usb driver for it. It could cause a conflict… someone mentioned at but it was not confirmed if it’s an issue or not.

Also I was never able to flash my 5k+ on my old computer an MSI Z97 gaming 3 mobo it would always brick the headset and I had to flash it on another PC I had around to do it successfully maybe try that

2 Likes

I have been pushing/recommending pimax do this for quite sometime. Checksum files have existed pretty much forever.

@PiSupport

1 Like

Hello, Thank You for your input. I’m doing the procedure as per video. Here are my steps.

  1. I download the dfu file off Google.
  2. I make sure my 8KX is working properly, everything powered up, and hooked up.
  3. I go to the Program Files/Pimax/Runtime and located the dfu.exe file.
  4. I start the program. I have tried it both in Admin mode and just double click. Same results.
    5.In the dfu.exe app window, I select the .295 dfu update file. I then click on update.
  5. At that point, my LED goes from Green to Dim Red to Bright Red, then back to Green.
  6. It takes about 7 secs for all the above to occur. The LED never goes through the RGB sequence, as I have seen in the past when updating firmware.
  7. Also made sure virus/malware shut off for update. I also have an exception setup on the pimax stuff anyway, just incase.
  8. Close then restart Pitool. After 8KX is showing online and everything normal, I check the version of the firmware…still .294

One last thing re dfu update file. It is located on my Z drive. Does it need to be in the Program Files/Pimax/Runtime folder to work correctly? I never had to this before. The only other thing I have not tried, forcing the headset into dfu mode. I will research a little before attempting this. I lnow it’s on Sweviver’s Dummies video…if still a viable procedure.

Am I missing a step on the update. It has always worked fine before. Did I brick this headset? It seems to work fine in VR, albeit with .294.

Thanks
David