Issue with SW Squadrons

Hello,

I have a strange issue with SW Squadrons that I recently bought (Origin). When I start the game and switch to VR, everything is fine. But if I remove the 5K+ from my head to do anything else and put it back on, I get doubled/blurry picture when moving my head , which makes the game unplayable and I have to stop it. Any idea on this?
Also, what are the best Pitools/Steam VR settings to get a decent framerate with a good picture quality? I have a 9700K @ 4.8 Ghz and RTX2080, it’s not too bad but could be smoother (when it’s working fine at the beginning). I have refresh to 120 Hz, Pitools to 1.25, PP on of course, Smart Smoothing, Steam VR to 100%. (Pitool 273, firmware 273)
And last question, is it possible to start the game directly in VR with a shortcut? Currently it’s quite annoying to start in 2D, go to options to switch VR on etc…

Thanks.

2 Likes

@vrgamerdude and @NextGenVR may have some suggestions.

1 Like

If needed: Windows 11 fresh install, latest Nvidia driver, latest Steam VR. The issue happens even if I just lift the 5K+ a little to have a look at the flat screen of the PC, and put it back on → stuttering/double image when looking around, etc…
Note: I have no more VR controllers, Pitool set to 9 axis. I only play seated/classic controllers games.

1 Like

did you ask google. win11 and steamvr/Oculus apparently still have problems.

1 Like

I am running Star Wars Squadrons fine with Windows 11.

1 Like

Apps like fpsvr?

1 Like

That’s odd considering the Pimax has no proximity sensor.

@Lucivr I don’t run fpsVR, as it always gave me frametime drops and heavy stuttering

@Lucivr the game starts and runs fine in VR as long as I keep the hmd stable on my head. It’s not using Oculus software, I don’t have Oculus installed on my fresh Win 11. fps is between 40 and 50 at startup, not bad. But if I just lift the hmd from my head to have a look or do something on the PC screen and put in back in place, things go bad with stuttering/doubled image when looking around etc… so it’s not an issue with Win 11 where it doesn’t work at all or badly straight from the start.

Ran it this afternoon without issue. Assuming PP is on, I would suspect Win 11.

1 Like

@JoCool, what are your Pitool version, & settings for this game? Thanks.

No, no additional app. But I found more this evening, and can easily reproduce the issue. In fact it’s not linked to moving the hmd. When I switch the game to VR, the Steam VR small window comes to the foreground on the PC screen, and the game then loses focus. Picture is then smooth and good in the PImax, but I have no sound from the game since it has lost focus. If I then click on the game window, sound is back, but the picture goes bad in the Pimax. If I manage to click again on the Steam VR window, back to normal. A bit weird.

OK, workaround found. There is an audio option in the game to continue playing sound even if the game window is in the background. So I can now switch it to VR, leave the game window in the background and enjoy a smooth picture in the Pimax. BTW, it looks quite incredible in the 5K+! I also improved the framerate by lowering the 2D resolution to 1280x720 (I have a 4K monitor so I initially had set it to 4K). It does not change the VR resolution but probably saves GPU cycles because the VR fps improved after this and it’s really visible in turns/rapid movements, smooth now.

4 Likes

So how did lifting the HMD appear to cause this?

Anyway glad you find this trick. Some people would have given up right away, blamed Pimax and posted it every where that Pimax sucked and was broken. (FReality, UoloadVR…:face_with_hand_over_mouth:)

1 Like

It is strange. I will have to try that next time I’m in the game. I don’t recall if I ever took the hmd all the way off as I cut away the nose flap on mine to peek at my backlit keyboard. I do recall the SVR window coming to main focus, but just minimized it.

2 Likes

@drowhunter @dogbite, as explained, finally it was not lifting the hmd, but each time I lifted it, it was to click back on the game window to bring it in the foreground and that caused the issue, so I initially thought it was linked to the fact of putting it off/on on my head. With the sound option where the game continues to play sound even if its window is not focused, I can leave the game on the PC screen in the background, and then the rendering in the Pimax remains good.

4 Likes