Low gpu usage in HL Alyx and Dirt 2

Hi there,

I have my Artisan for a few months now and must admit that I’m a bit disappointed. When I recieved the hmd PiTool 260 was the actual release of PiTool. The first game I played was Dirt Rally 2 while waiting for my Index controllers. The gpu usage there was at about 75% with frametimes at about 12 ms. I was wondering about the low gpu usage, but thought, ok, maybe it’s not well optimized for vr. So after recieving the Index controllers I installed Half Life Alyx, which also had about 75% gpu usage, but with good frametimes and 90fps. Then the new versions of PiTool came out and I installed all of them and of course deleted all the directories after uninstalling the prior version first. And with every version it got worse. With the PiTool including the Pimax Experience beta I get about 60 fps, frametimes at about 12ms and gpu usage of 50-55%. This is pretty ridiculous. Is Pimax going to release a version which uses the gpu to it‘s full capacity?
My system:
Ryzen 5 1600x
16GB 3200 Ram
RTX 2070 OC

I know the cpu is not optimal. I’m planning on buying a Ryzen 3700x. But still it’s pretty wierd why the gpu usage is getting worse with every new release of PiTool.
Tomorrow Star Wars Squadrons is released and I’m waiting for months now to play this game in VR, so any help is appreciated!

1 Like

I have a r7 2700x but withba 1080ti.

@risa2000 might have some ideas… However we need to have folks with a more similar setup. Not as familar with the ryzen 1000 series. But I suspect it should be fine with the 2070, however it might be holding it back some.

There is an Openvr benchmark on steam that might be good to compare with.

This seems about right - consistent with the Valve engine, which will keep GPU usage around 75% and scale the resolution (and the detail) dynamically to match the requested refresh rate (i.e. 90 Hz). If you want to get a higher GPU usage, you would need to run Alyx with specific command line parameters, to disable the dynamic res and detail - +vr_fidelity_level_auto 0 +vr_fidelity_level 3 - see here (How to get rid of Shadow culling and fix volume fog in Half Life Alyx without parallel projection!).

This happens in Dirt 2 or Alyx? If in Alyx, it would be strange (as I explained above). If in Dirt 2, what was your framerate there before you upgraded?


This is in Alyx. It started with the upgrade to 262, which was said would have had a better gpu usage. I didn’t change any settings, wether it was in PiTool, nor in SteamVR or Alyx.
Dirt 2 is unchanged though.

Good idea! Will give it a try this weekend.

I also thought about doing a fresh installation of windows etc.


I installed open vr benchmark yesterday. Before I did another clean install of PiTool 264.
The benchmark used 99% of my gpu. So the problem is not the PiTool.

Additionally Star Wars Squadrons war released and I installed this to. Depending on the settings I get also a gpu usage of about 90%, but sadly pretty bad frametimes because of parallel projection being needed.
I know that there’s a thread about this.

1 Like

your cpu is way too slow for vr thats why you got low gpu usage . You need atleast a i7 8700k at 5ghz

1 Like

I thought the same. But if that’s true, why do I get 99% gpu usage in open vr benchmark (ok, it’s a benchmark, not a game) and also in Star Wars Squadrons? And according to vrfps my cpu usage is at about 50%.

1 Like

where you get such a high requirements for artisan?
I have stock i7 7700k at 4.5 with 1080ti, it never bottlenecks the gpu, frames also ok on 5k+, 5ghz is top segment of cpus nowadays, vr needs less cpu than gpu.

If he had good framerates then cpu defintely can achieve it & it looks like a software bug

1 Like

do you have smartsmoothing on? can you try disable it. Also did you disable PP for Alyx as you enabled it for other games, did you exit steamvr & restart it after settings change like PP? I guess in PE it’s done automatically but asked just in case.

while in game can you try open process manager & see do you have any other apps that consumes resources (CPU / GPU)

what’s temperature of your GPU?
try set overlays quiality setting in steam vr on min.

do you have reprojected frames?


SS is on, yes. Will try to disable it. Parallel projection is also on, I just learned this weekend that it consumes a lot of gpu resources.

I already checked the temps of the gpu, they’re absolutely ok. Heat’s not the issue.

How do I know this? Is there a way to display it?

I also thought about playing around with the catalyst settings. Last night I found a threat here on OpenMR from somebody asking what exactly it does and that he had better FPS etc. after setting it to higher values above 1.
@Teigue Do you know what exactly it is for?

Thanx for taking the time helping me analyzing this!

it looks like you have an outdated pitool, since 26x I don’t remember what version exactly they deleted it & GPU utilization also stopped be a problem.

Usually to see if I have reprojected fps I use fps vr, also if you have SS on it halves the fps & card doesn’t use it’s power so it’s kinda limited by this factor.

Always disable PP if a game doesn’t need it, the bigger FOV the more resources it takes & this is non linear dependency, large fov (not sure what it is on artisan) takes enormous amount of resources

If you want GPU utilization to be maxed disable SS, I don’t use it at all as it sometimes providees images artifacts & how to say something like image drift


It can’t be outdated, as I did a clean install of the 264. Just read about it, but didn’t check the setting on my machine. So it could be that it’s gone there too.
Will disable SS and PP for Alyx and see how it runs. Will report back, after testing.

I set FPSVR to show a smaller windows some time ago and forgot about that. So will set it back to the default settings.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.