Motion Compensation Pitool Update

@PimaxUSA Did motion compensation ever get finished in Pitool or is there a plan to do so? I have just tried it out again after not trying it since last year hoping that it would work now but notice that while it works in terms of the tracking and motion cancelling aspect, there is still no option to “Set Zero” the orientation making this unusable. It seems such a shame thats its not quite finished because the hard work seems to have been done already but all we need is a simple set zero button to make it useable.

Any update or info on this would be appreciated and Im sure there will be plenty of others wondering if this will ever be provided in an update.

7 Likes

I talked to the Pitool team and bubbled up this feature request.

13 Likes

Awesome! Awesome! Awesome! (Char count)

Thankyou for taking the time to reply and getting the word back to the pitool team, it’s much appreciated. I’ll keep my fingers crossed for a future update :smiley:

3 Likes

@PimaxUSA

Is there any update on this feature request at this point? From what I understand, this feature was already working successfully in previous PiTool iterations, namely version 180.

Thanks for your feedback on this.

1 Like

Open VR motion compensation software:
https://ovrmc.dschadu.de/

If you use FlyPt it even works without needing a tracker or physical controller.

3 Likes

Unfortunately, OMC doesn’t appear to work correctly with Pimax HDMs.

I tried both Index controllers as well as a tracker, it lags massively even with all values adjusted in OMC.

I think there may be something else not working as it should there or perhaps a setting in FlyPT? OVRMC doesn’t lag at all when working correctly. I’d give it another look to see if you can work out what’s causing the lag.

I know, OVRMC worked fantastically on my Index but with my 8KX it literally throws me outside the car on the first turn.

I‘ll be digging into settings a bit more but it‘s good to hear that others were able to get OVRMC working flawlessly on a Pimax HMD.

Do you use a tracker for reference?

It’s confirmed not to work with Pimax HMDs by the dev.

With the intention of trying to help you out and possibly anyone else struggling with this, what are the exact steps you do when using OVRMC with a Pimax HMD? I have used this program for quite a while and not had any problems - it still works great for me so I’d like to try and work out whats different between our setups.

For me I do the following:

  1. Open Pitool
  2. Turn on HMD and wait for headset to pickup 2x Light Houses.
  3. Turn on my SFX100 kit with Thanos controller
  4. Open FlyPT Mover & activate my chosen profile which also includes the OVRMC output. (My rig dims are already set in the profile which is important for the virtual tracker to work correctly).
  5. Run my chosen game selecting VR from Steam (usually RF2 or DR2.0)
  6. Inside VR, open the OVRMC app from the button on the SteamVR dash and check “enable motion compensation” (assuming the orientation of the virtual tracker has already been correctly set to the centre of my rig)
  7. Go back to game in VR, enter a race and away we go. Motion compensation works.

Thanks for your help, much appreciated.

Alas I‘m not using the sw tracking solution but lighthouse based tracking devices (wand/tracker/knuckles) and that apparently doesn’t work with PiTool HMDs.

Ahh right ok. I’ll have to try the tracker again to test it. Sounds like that could be the thing which doesn’t work then.