My PIMAX just died after PIPLAY update (RESOLVED. t.y. sjefdeklerk)

My PIMAX just died after PIPLAY update (RESOLVED. t.y. sjefdeklerk)

PIPLAY suggested to update itself and after that my headset is dead. LED does not light up. My PC does not react if I plug in or plug out PIMAX USB cable.

What to do?

PIMAX 4k is dead!! :confused: :frowning:

should I contact GearBest (I bought it there) or what should I do???

and no reaction on another PC?

what happens if you unplug USB, then keep holding all 3 buttons pressed down and then insert the USB, while holding the 3 buttons pressed ? Does the LED light up ?

I will try later today

Try contact pimax support on Skype
Looks for : PIMAX Support contact on skype

hope u will found a solution

Try the test that I just posted. If the LED lights up, you can put it in DFU mode and then flash a new FW. It might be a failed flash

I got the same notification to update… think i will not bother now!

Yes, the LED lights up. Where can I find the info to flash it?

Pimax upgrade tool does not see my Pimax unit :confused:

Ok, you might be lucky then, most probably something went wrong during flashing and you can just flash a new firmware again.

These are the steps you need to take.

First you need to manually put your device in DFU mode like this:

  1. disconnect USB
  2. keep all 3 buttons pressed and connect the USB. LED will be white
  3. Wait about 7 seconds before releasing ONLY the power button. Led will turn blue-ish green
  4. Wait again 7 seconds and release ONLY the middle button. Now the LED will start flashing like crazy and you’re in DFU mode.

Now, download my flasher tool: (it’s better than the one you were using, so use my version)

It will detect the device in DFU mode now and you can click the flash FW button !

In this topic you will find a zip with all FW’s: Firmware direct downloads

Goodluck ! I think it will work because the only reason this won’t work is if your hardware is damaged. But in that case you wouldn’t have been able to use the PIMAX before. Most likely the piplay software was trying to flash a FW and got interrupted or the process failed for whatever reason. In that case you will be back online soon !


yes, now flasher detects it. how long it takes to flash PIMAX?

thank you!! my pimax is working (y)

P.S. Pimax support did not answer my question, neither through the email nor skype :frowning:


Happy to hear you’re back online, enjoy !

1 Like

Hello…I followed the procedure (White LED, blue LED and flashing LED)
Started flasher and got “Pimax not found!” message.
Clicking on DFU mode returns “Could not open PIMAX device”

Are you sure you killed piservice & piserver & piservicestarter ?

Yes. Tried right now Killing all the processes…same result
I found this on regedit…

could the usb cable be the problem?

I just saw the topic you opened with the error code. I think you have some kind of hardware problem indeed, I guess it could be anything. If you have reason to suspect it’s the USB, then you could open your Pimax and try another USB cable (be very careful not to damage the LCD cable though).

Thx. How can I remove the usb cable? It is tethered to the hdmi and I don’t see a way to open the hmd…