Need to reboot the HMD regularly

Hi,

I regularly get a bad picture in the 5K+, with a black bar in the middle, and wrong colors below and above this bar, plus eyes desynchronized (always the same problem, see picture on the PI default picture). This can happen after a PC reboot, when Steam VR or Pitool is launched, quite anytime randomly (but never during a game session).
The only way to get out of this (apart from power off of course) is to launch a HMD reset in Pitool. Quite annoying. Anyone with this problem too?

I sometimes see thin, colored horizontal stripes, which go away after rebooting the headset. It doesn’t happen often, but is more likely to occur when I’m changing the refresh rate or restarting the Pimax service. Sometimes I have to reboot the headset more than once to fix it.

2 Likes

Interesting, seems different though, and here, a single hmd reboot always fixes the problem.

1 Like

So, I can reproduce the problem at will. Just reboot the PC, and boom, picture completely messed up in the 5K+ (the screenshot I posted initially is only one eye of course, the other one has the same kind of problem but vertically offset so the global picture is not even consistent). Looks like a hmd firmware bug I think.

I had the same problem (it’s a broken cable, submit a ticket for a cable replacement)

1 Like

Thanks, but this is not the problem I have. My problem looks like a pure software/firmware problem since it can be easily reproduced, and is solved each time by rebooting the hmd.

Very strange it’s so repeatable for you. When i first got my hmd this happened out of the box and I figured it was broken. Reseating the DP cable about 3 times fixed it, but it occasionally came back. restarting the pitool service seems to fix it.

What GPU are you using? I get this occasionally with my 1080 but I have never seen it with my 2070 super. I noticed my 1080 dp ports are ‘1.2 certified, 1.3/1.4 ready’ whatever that means…

I have a RTX2080 so should not be concerned with this problem.