New beta M248 firmware is available now

Hi , this is alex:

 The new firmware M248 is available for public beta and it is available for download now.

 http://piplay.pimaxvr.com/P2_RELEASE_M248_t20191112.dfu

 This firmware fixes the problem ,that when the Pimax5k plus at 120hz,and the brightness dimming.
13 Likes

still no 120 Hz option to select :frowning: early backer here with the “black dots panel” @Matthew.Xu @PimaxUSA

3 Likes

how do i install this?

how to rollback or install firmware:

-Have your Pimax running and active. Now open up the file called “Dfu.exe” located in the folder “C:\Program Files\Pimax\Runtime”.

for Rollback firmware:
-Inside of the application, browse to the latest firmware file included in the latest PiTool version. The firmware file is called p2.dfu and its located in “C:\Program Files\Pimax\Runtime\dfudriver”.)

for installing the latest firmware
-Inside of the application, browse to the downloaded P2_RELEASE_M248_t20191112.dfu file

-Now click “download”. It takes a few seconds until its donw, and it will restart all services afterwards and your Pimax will work as normal again

7 Likes

thanks it worked but why i cant change fov anymore inside pitool?
its on 90hz now and no option for fov ?

1 Like

this new firmware is wors then before my hmd disconnects about 3 times and then just back to 90hz
before it disco a fue times but 120hz was active after now not . … ?

1 Like

ok strange if i have brightness set to high before set option 120hz it does not work
but if set normal brightness before set 120 then after a fue disco 120 is active

Try restart/power-cycling the headset and Your PC (so the PiServiceLauncher service is restarted). Worked for me… :wink:

BTW - “Large” FoV on 120Hz = 130 degrees (instead of 120 (“small”),140 (“normal”) and 160 (“large”) degress on 64/72/90Hz).

3 Likes

Yes it works
But then why is option for set fov gone ? And same whit ss slider ?

1 Like

But in this case, shouldn’t we browse to the “P2_RELEASE_M248_t20191112.dfu” file that we just downloaded?

2 Likes

sorry. yes you are right. I just copy pasted this how to generally install firmware instruction. I’ll update it

1 Like

same here no 120hz still on my early 5k+, not that they’ve acknowledged the issue in the firmware update notes or anywhere else though

1 Like

yeah the dead silence of pimax about this is annoying me more than the problem itself

Quote from Pimax update 49:

We apologize for the lack of communication.

We are mainly made up of a group of engineers, with a global backer base, we do gradually realize that there is a barrier and difference in communication. We are sincerely thankful and appreciate for the backers volunteering in the forum and other platforms for helping bridging us with the rest of backers giving us summaries of feedbacks.

Another lesson learned is that frequent updates and transparency with the projects is essential to you, as we often shy away from initiating communication, giving frank and open report and update, which has caused much of misunderstanding.

IF YOU ARE SORRY FOR SOMETHING I WOULD ASSUME THIS MEANS YOU DO BETTER IN THE FUTURE.

That being said I would really appreciate a statement from pimax to the missing 120 Hz mode.
Considering they try to sell us new hmd’s right now while the discount for backers will run out in 1 1/2 months.

5 Likes

Dear @Matthew.Xu and @PimaxUSA it would be awesome to get some info on this.

Is the very early Panel (5k) not compatible with the current 120Hz mode?

8 Likes

Now the FOV slider isn’t working. It’s still a good firmware update though. Thanks.

2 Likes

in 120Hz the FOV slider does not make quite as big a difference as in 90Hz or lower allthough there is a big difference between small and large in 120Hz

1 Like

FoV values in 120Hz are different than the other refresh rate modes (it was like this in the 244 firmware too):

Refresh rate: 64/72/90Hz 120Hz
Large FoV: 160 132
Normal FoV: 140 112
Small FoV: 120 92

I would suggest using “Large” FoV in 120Hz (132 degrees) if You’re used to the “Normal” FoV in other refresh rate modes (140 degrees) as it’s “close enough”… :wink:

4 Likes

I would suggest that for 120Hz FOV mode, the names should be the following:
Normal 132
Small 112
Smallest 92

That would match the non-120 mode FOV types more closely.

2 Likes

It would also mean You wouldn’t have to change FoV setting between modes… :upside_down_face:

Maybe just remember last setting per refresh rate?

1 Like

Is it just me, or did the switcing to the panels native 120Hz mode add some clarity to the whole display ?

3 Likes