New Pimax 8K not tracking

Hi, Backer 42 here,

I received the Pimax 8K yesterday. I completely disconnected my Vive Helmet. (Power supply, HDMI cable and USB).
I installed the Pimax with PiTool, it then automatically updated to version HMD headset Firmware is now V2.1.255.147

I can see the very nice and very large image of steam VR home inside the helmet when “Turn on Lighthouse Tracking” is not activated. The image only rotates with my head but is not 6-Dof tracked.

When “Turn on Lighthouse Tracking” is activated; I have the error message “Not tracked, Place the helmet in the visible position of the base station”, the controllers are reported tracked but not the helmet and the image in it is only grey.

I have de-installed the magic leap kit drivers, restarted the PC 4 times and reinstalled PiTool, 3 times. I have tried setting optical and cable sync mode for lighthouses. I have tried reconnecting the Vive temporarily, tracking works ok with the Vive.

Here are some pictures:
I shot an e-mail to pimax yesterday but haven’t heard from them yet.

Can someone please help me resolve this issue ?


Maybe this can help? @yanfeng found this out earlier. It could be that at transport the connector came a little less connected.

[quote] Spamenigma: So I restored that too and ran the install manually
Still showing as disconnected… then I saw @yanfeng 's comment on here and so I pushed the connector and it moved in a bit: Suddenly PiTool came to life and went through a quick installing process! And its alive!!! [/quote]

I see your lighthouse is on the ground. Will that be a problem? Usually it should be above head height.


@Ludx had an issue with tracking. Ensure mobo bios & chipset is up-to-date. He had an issue with chipset not being updated properly.

Oh, its exactly the same issue yes.
Grey image, tracking stuff.

I had to update my motherboard chipset (and flashed bios also) to it to work, I had exactly the same issue.
So its a USB issue in a way or another according your motherboard USB can handle the signal.


People asked me about it in PM, so here is a follow up. The problem is not solved.

I received a support message from Pimax to fully uninstall vive driver and vive port and stop any process and service about vive. They said to also finish the room setting in Pitool(not steamvr). They also said that if I find the pimax is still disconnected, to restart the service of Piservicelauncher to try. (in windows task manager)

It didn’t work for me.

I followed the recommanded advice.
I made sure Vive driver and viveport were uninstalled.
I checked the process list but this did not change anything.

I could not finish the room setting in pitool because the helmet was displayed as not tracked and as a consequence the next button was not clickable.
I have tried to restart Piservicelauncher but this did not change the situation.
I have checked that I have the latest firmware and chipset drivers for my motherboard ASUS Z170-A (Version 3802), by the way I tried the USB2, USB3.0 and USB3.1 ports.

I have formated the harddrive and have installed a clean version of windows 10 x64 with latest updates, then I only installed the motherboards and chipset drivers, Steam, SteamVR and pitool Even giving it administrator rights, Pitool refuses to launch: the pi logo appears for a few seconds and then disappears, the pi logo remains inside the windows tray until the mouse hovers over it, then it disappears. The pimax stopped showing a grey image and is now dark, it does not turn on anymore. I was not able to launch pitool with a clean install of windows.

I have returned to an old hard drive with a windows 10 that has plenty of games installed , I have installed pitool and launched it succesfully. only, then I have plugged the pimax. The pimax now remains dark even if I press the power button for a short or long time. There is no chime sound when I plug the USB or unplug it. PiTool displays “Disconnected:Diagnose(10500)”

In addition, I measured the unloaded (unplugged from Pimax) output voltage of the switchching adaptator (the small transformer you plug into the wall), it reads 12,3 Volts which means the power supply is functionning normally.

I have not received news from Pimax for the time being, I will be unable to have access to the helmet for the next two weeks, so I’m a bit frustrated but I hope by the time I come back, that a software update will fix all these problems.

I am going to order an USB PCI card, just in case the issue is with my motherboard.


Thanks for sharing! There seems to be a few of us with this problem.

1 Like

Hi I have found if you have orage/red USB ports try one of those as those are High speed usb 3 ports. Blue ones seem to give connect issues.

1 Like

I have the same problem with no Lighthouse tracking on my new 5K+ (my pledged unit). Have tried everything. The new 8K works OK and old review units of 5K+ and 8K works.

Awaiting reply from Sean…

1 Like

Interesting that the review units are working. They might need to use a teamviewer session to dig deeper.

Yep. But my pledged 8K unit works fine. Thats the weird thing.

On the new 5K+, it always says (in PiTool): “Place the helmet in the visible position of the base station”.

Check the screenshot:

The image inside HMD goes instantly grey when started.

This is everything I have tried so far:

  • I have tried PiTool 90, 84 and 76 and same problem on all versions.

  • I have tried flashing the firmware with both DFU.exe and the old DfuSeCommand.exe method and both flashes successfully but tracking problem remains.

  • Turning off “Turn on Lighthouse tracking” option works ok, I can use SteamVR without positional tracking and image is OK, but as soon as I turn on “Turn on Lighthouse tracking” the headset goes grey and problem is back.

  • I tried switching the cables (tried 3 different Pimax cables, same problem with all).

  • Same problem on RTX 2080Ti desktop PC and also my GTX 1070 laptop

  • I tried using 1 and 2 basestations. Same problem.

  • Tried EVERY USB 3.0 and 3.1 ports on my PC and laptop, same problem

  • Tried all DisplayPort ports on my desktop PC, same problem.

  • Connecting the 8K to same PC works great - no problems.

  • Connecting the “old” review 5K+ unit works great - no problems.

  • PiTool Diagnose shows everything is OK:

1 Like

Hmm definitely interesting. Have you compared the wall adapters? Or using the 1 adapter with both headsets?

Might be an idea but verify with a multi meter to try a stronger wall adapter to see if it needs more power (amperage available)

Also @ludx posted something that seemed to work for him somewhat.

1 Like

I tried the same adapter with all 4 headsets (because Im lazy lol). Only the new 5K+ does not track.

But good idea, gimme a moment!

1 Like

Yeah figured they should be the same. :wink: but often power supply is where a lot if companies don’t give enough overhead.

Measuring power wattage usage might reveal a power draw issue.

1 Like

Tried a brand new adapter (the one from the 8K), different power outlet. Same problem :frowning:

1 Like

I don’t have LH to test with. But if you have a 12v adapter with higher amperage/watts available it might need a stronger adapter. It is also possible the housing might be thicker interfering with tracking sensors.

1 Like

Sure… but its strange this never was a problem with old 8K and 5K+ nor the 8K m1.

Hmm that could be a reason. But isnt the “final” 8K supposed to have same housing as 5k+?

1 Like

Should be the same. But the Demo Units were likely like a First Off as used in other Manufacturing & had additional quality tests before okaying production line to start.

I figure housing issue might in line as this was mentioned a quality issue discovered with the housings. So like most QC issues depending how soon the issue was identified a couple+ might have escaped.

1 Like

Yep, Im afraid that could be the case…

1 Like

I got it fixed the lighthouse tracking issue with the help from Sean!!!
It seems to be config-related issue.

Try to do this:

  1. Make sure headset is connected and PiTool is running showing the “Not tracked, Place the helmet in the visible position of the base station”
  2. Delete all files in folder "C:\Users\ your username \AppData\Local\Pimax\runtime\config\lighthouse
  3. Restart Piservicelauncher service (keep the headset connected and powered on)
  4. If that doesnt help or do anything, quit the process PiService.exe (headset will disconnect in PiTool) and start up PiService.exe again from folder C:\Program Files\Pimax\Runtime.
  5. A windows command prompt window shows up and stays.
  6. A few seconds later PiTool will show that HMD is connected again. Give it a few more seconds.
  7. Suddenly HMD starts to track with Lighthouses :slight_smile:
  8. Now restart PC and things will work as normal!

Now this seems to fix it, and when you reboot PC or unplug the headset from power and plug it back, the headset will track with Lighthouses again once its started!