New Pimax 8kx firmware 2.1.255.2001 no screen & no audio with optical cable

the firmware still says 2001 in pitool so i think its just they forgot to rename the firmware name in the file to 2001 from 299. i can live with it in its current state just takes a few trys to get it to properly boot. kinda annoying. also with the audio at 7.1 the audio sounds incorrect. too much bass and other audio issues. bass will randomly sound like a subwoofer is starting and stopping. i have very expensive audio equipment and i know that is totally wrong. because its running like a 7.1 system.

2 Likes

pimax has sent me yet another firmware version:

P2_DEBUG_8KX_N7_0_M2001_t20220428090031_rc879f9b_90hzonly_LTMN.dfu

this resolved the headset not turning on when needed. finally i can enjoy the headset. it is very nice. but i still have some glaring issues below:

  1. the headset runs in 7.1 audio. For some reason the headset sounds like it is in surround sound for some reason, may be due to the 7.1 implementation. This is incorrect and can make you dizzy in the wrong game.

  2. bass is severely boosted in the dmas speakers. this is even more apparent when the kdmas cups are placed over the dmas speakers. If volume becomes loud enough, the headset will have a loud boosted bass note for a second. this happens as soon as a somewhat loud note is played. might be due to the 7.1 speaker issue above. this is a huge issue.

  3. some players in game say my microphone was cutting in or out. They also said they could hear an issue with noise through my microphone. This may be game related, but the mic in windows 11 is picking up some noise it shouldn’t.

Overall I am “okay” with the state the headset is in. I like testing new firmware that comes out, and i would be willing to test more in the future if needed for free.

2 Likes

I still have to power cycle the headset multiple times before the LED goes to green and the screens power on.

DMAS audio works when set to 5.1 in windows.

I can live with it for now, but am anxiously awaiting new firmware

1 Like

yea i think they said they were going to update it. power cycling does still happen sometimes.

1 Like

did you try 5.1 instead of 7.1 for the audio?

i’ll give it a try later. support told me to use 7.1

oh new pitool update

1 Like

well could we get a file for this pitool update? cant download it. supposed to fix this headset

Hi Heliosurge,
I am having the same issue for the past 2 days…trying to get one my Pimax 8KX to work again after updating it. Have not used VR for a while and at the moment I am struggling to get rid of the baggage the 299 left. Can you kindly send me the Debug 296 as I am unable to find it anywhere. I agree that Pimax should step up their Firmware testing. I rarely have time to play and every time there has to be an issue or something that I need to search, fix or flash the headsets. It is getting highly frustrating.

2 Likes

okay ran into some issues getting 110fps upscaling mode to work with my fiber cable on the new 279 beta. so a lot of my issues are probably related to the new headset and the optical cable.

2 Likes

I finally returned it. this headset is too much work.

there are just way WAY too many problems with it. jesus christ

im so mad. i’ve never spent this much money on something for it to be a dud. my headset is defective.

Hi anyone any good with pimax stuck in what I believe to be dfu.
I have an 8kx dmas 2001 fw.
This was locked at 90hz no upsampling with pitool 177.
Tried to update the firmware so I could get the 75hz options like the other pimax 8kx, but seems this headset might be different 8kx and not named that for the firmwares out ATM.
Mine is now stuck in a red light, green light, blue light loop.
Does show as dfu in the device management, tried some programmes to take it out the state of dfu but they do not see it.
Like everything else it is now not seen.
Was working perfectly before this situation of the failed fw update.
It did say firmware not changed after the update had finished but then this issue.
I am really struggling to get it working again now.
I have tried pitools 177, 179,180 fault codes the same no usb and no dp connection.
Code 10500, 10600, 10936 have been seen randomly as codes.

Thanks all was hoping to get the SIM rig working today as I had a day to do so with the pimax, but the headset had other ideas. Lol

2 Likes

I had the exact same issues when i had mine. i returned it. idk what is going on with the new 8kx…

I have managed to sort it, took some doing but finally sorted and working now.
I use the p2 debug 299 fw.
Then installed pitools 280.
It did anothe rupdate and boom worked.
This has had many fails with fw flashes and pitools not working with it.
But managed to find a match so I am happy now, because I have the upscaling and the Hz options now too.
The way I lashed was out into dfu mode my self manual and then flash by CMD prompt.
I have every colour light you could think of, from the scrolling colours to solids yellow ect.
But still found a way to do it.
I think the main problem for me was the right fw with the right pitools with a good clean flash.
Now I hopento have a play with everything and see if I can break that too ! Lol

1 Like

another thing you could try. this usb pcie card fixed a bit of stuff with my new headset. its way more stable now.

https://a.co/d/ihaGJuQ

keep trying to boot your headset over and over. it should start 100% of the time. if it doesn’t, you haven’t fixed your issues yet my friend.

Can you share this P2_DEBUG_8KX_N7_0_M2001_t20220428090031_rc879f9b_90hzonly_LTMN.dfu firmware? I’m having the same issue. I have a ticket open with support, but responses are slow!