New Pimax 8KX Jitter

Hi all, I received my 8KX from Amazon yesterday and while I feel the headset has a lot of potential, I’m feeling especially disappointed by the jittering when using the 8KX.

I’ll preface this by saying that I’m upgrading from a Valve Index, and everything works perfectly with no perceptable jitter. I also have a Vive Pro 2 for over a week and that also had no jitter what-so-ever in my setup.

My 8KX headset has quite noticeable jitter and I’m also getting jitter on my Index Controllers when they are paired to the 8KX (but they’re fine when paired to the Valve Index).

Can some others run this jitter tester and tell me their results?

Just put your headset down on a solid surface with visibility to your basestations and press the space bar. It will record how much your headset is jittering and give you some numbers.

Here are my results with my VALVE INDEX:

  • Max Deviation (Position): 0.32
  • Standard Deviation (Position): 0.07
  • Max Deviation (Rotation) 0.03

I can run the test multiple times and pretty much get the same exact result every time. There’s no perceptible jitter with my Valve Index.

Here are my results with the PIMAX 8KX:

  • Max Deviation (Position): 2.64
  • Standard Deviation (Position): 0.58
  • Max Deviation (Rotation) 0.25

As you can see, these results are massively worse, and running the test multiple times gets pretty different results each time (almost always worse). As I said, my Index Controllers also jitter massively when paired to my 8KX and sometimes fly off in the distance. This never happens on my Index.

If I disable lighthouse tracking in Pitool and use 9-axis, the jitter is almost as good as my Valve Index results, so the 8KX headset isn’t inherently jittering, only when tracking with the lighthouses. But at the same time both my Valve Index and Vive Pro 2 work perfect when using the lighthouses.

I’m using the latest Pitool version and I’ve tried the latest headset firmware and beta headset firmware (for 90hz Native w/ my RTX3080).

I had packed everything up and submitted a refund request to Amazon, as I was assuming this is just expected behaviour of the 8KX. But I REALLY like the wider FOV and massive resolution of the 8KX so I’m hoping after comparing to other people’s results, it’ll be obvious that my 8KX is simply faulty and I should get a replacement from Amazon instead of a refund.

2 Likes

Hi JBB1984

welcome to OpenMR forums

I’ll just leave this link here for you, it will not solve your problems. and I suggest you create a ticket for Pi.ax support who might help you out the best they can.

@PimaxUSA
Hi Kevin

you might have a unique opportunity here, seeing this guy has both the Valve Index, HTC Vive Pro2 and the Pimax 8KX.
So he can validate his Lighthouse setup is working correctly.

7 Likes

So my understanding from that thread is, this is sorta just a problem you have to deal with if you want to use the 8KX?

Just curious, what will pimax do to help? Also did you get your jitter fixed ?

1 Like

Hi Cesar
Please read what I quoted above, this will answer your question.
Personally I do not own a Lighthouse 1.0 so I cannot recalibrate my 8KX, seeing the HDK from Steam does not contain the calibration tool for Lighthouse 2.0

So in short, No mine is not perfectly calibrated.
But some 8KX’s are unfortunately delivered terribly calibrated.
Pimax support can update the HMD with a default calibration profile, which will improve jitter if it’s really bad.

2 Likes

hi
I have the same problem as you with the base v1
because without the base it’s perfect

steam vr and htc1 bases are maybe just forgotten in the updates to sell v2

1 Like

Strange. I’ve never noticed any jitter on my 8K or my 8KX. I never even thought it could be a problem.

I’m only using a single v1 base station. I have a 2nd base station, but haven’t bothered to install it. I mostly play seated games which only need 1 base station, but I’ve also played Half-Life: Alyx and I didn’t actually need to mount another base station. It works fine as-is.

4 Likes

Yeah looking at the thread and talking to some owners on Reddit it seems like it you have V1 base stations, it’s fine.

I have V2 base stations and it’s terrible. I’m not going to buy V1 base stations just for this headset. Pimax really needs to sort this out.

3 Likes

I’ve never noticed it either and I only own v1 basestations.

Agree. The solution is not to buy outdated products when new ones are available and are supposed to work according to spec and marketing materials.

If possible, they should develop a calibration tool and build it into PiTool/Pimax Experience.

4 Likes

I’m actually shocked that considering how long the 2.0 base stations have been around, Pimax haven’t fixed this already.

I’m absolutely happy to spend the £1,250 I paid for the 8KX but not if it has some ridiculous soft-incompatibly with the current gen base stations. I want the best, not a compromised vr experience.

2 Likes

Is there a proper tutorial on how to calibrate it with V1 base stations or with a Valve Index, etc.?

I have 2.0 and never had such problems.

it has always worked great for me.

I do not understand the problem

3 Likes

Jitter probably because you set the resolution too high on SteamVR. Try to play around with the settings is all I can tell you.

2 Likes

Please run the jitter test in my original post and post your results please

2 Likes

Agreed. Considering what has been said, I’m glad I bought base station v1. I got them way before v2 was available.

1 Like

i also had a problem with the image but mine is solved by disabeling hardware accelerated gpu scheduling maybe you could check if its enabled and disable it to see if this also works for you
its in settings/system/display

2 Likes

Tutorial I did not find, but there are many documents for the creation and calibration of an HMD or any devices based on tracking with lighthouses in SteamVR Tracking HDK. Which can be obtained free of charge upon registration at: https://partner.steamgames.com/vrlicensing.
Once downloaded and installed on Steam, you can have the utility to calibrate the optical sensors “vrtrackingcalib”, where you only need to have your “config.json” file from your Pimax and put it in the same path. Run the program as follows: “vrtrackingcalib.exe /bodycal 800 200” and when it appears:
Ready to run capture position number 0.
Press key to begin:
Pressing enter and moving the HMD around the room and rotating it to show the lighthouse all the sensors, the calibration progress will appear until completion, where it creates a new .json “auto_ .json” ready to send to the HMD.
Using “lighthouse_console uploadconfig auto_ .json”
For the calibration you have to use a single lighthouse v1.0, if you have another you have to turn it off.

Here is a video I made with the progress of the calibration:

4 Likes

Test results from my 8KX:
average:

  • Max Deviation (Position): 1.1
  • Standard Deviation (Position): 0.25
  • Max Deviation (Rotation) 0.11

best:

  • Max Deviation (Position): 0.67
  • Standard Deviation (Position): 0.14
  • Max Deviation (Rotation): best result: 0.08
2 Likes

1.0 or 2.0 base stations?

I’m using 2.0 base stations…