New PiTool (v1.0.1.268) and new Firmware (v2.1.255.296 )

This version of PiTool is not needed because this is 1.0.1.XXX version, versus current 1.0.2.XXX (087).
I did a stupid thing and updated PiTool first, after which PE stopped working for me. Then through PiTool I updated the firmware to .296 and 60Hz mode appeared.

Then I installed the latest PiTool with PE support (V1.0.2.087) over .268 and PE started working again, the 60HZ mode remained at the current V1.0.2.087 witn new .296 firmware.

image

image

3 Likes

Hope someone can help me on this. I made the silly mistake of actually trusting that an upgrade to the firmware of my 8kx would be a good thing. Instead, the firmware upgrade didn’t work and the headset is no longer recognized! How do I fix this??

edit- I’ve already tried unplugging and replugging the USB and rebooting my computer without any luck.

1 Like
3 Likes

Thanks a million for this!!!

FYI, the headset started working again after the first 2 steps on the list. STM Device DFU never appeared on the device manager so I couldn’t complete the rest of the steps. Hope they are not necessary everything seems to be working now!

5 Likes

Alright, so if I sum up the posts above the current advice would be that upgrading PiTool to the version advertised via PiTool itself is NOT recommended at least for 8KX owners that run the most recent family .2.xxv2 firmware. This would suggest there are at least two ‚families‘ of PiTool being developed, forcing .2.xxv2 users to decide between PE compatibility and eye tracking functionality.

The most recent fw version on the other hand seems promising; does anyone have a mirror for direct download and flashing via dfu.exe?

1 Like

PE stopped working with the install of v1.0.1.268 because it isn’t included (i.e. it was overwritten with the default “Pimax Home”), so all You had to do was to re-install PE v.0.0.84 manually on top of the new PiTool install… :wink:

The reason why PE works in v1.0.2.087v2 is that it’s included in that version (and only that version) as far as I remember… :slight_smile:

8 Likes
2 Likes

I updated PiTool and re-installed Pimax Experience v0.0.84 and then tried the firmware upgrade on my 8KX.

It completed “successfully” (but way too fast) but still showed the old version of the firmware (.295).

I had to reboot Windows and run the firmware update once more to actually get it to update the firmware to .296.

I also tried rebooting both the headset and restarting the service (and PiTool) before resorting to rebooting Windows… :wink:

Oh, another note regarding the eye tracking module (and the aSeeVR update for that):

After updating the aSeeVR software (prompted by PiTool) to v2.0.0.5 I couldn’t get the calibration to work (usual stuff with the two green dots disappearing at the first screen where You’re supposed to look straight ahead), even after rebooting. I had to unplug the USB-C cable (I’m using the short one that came with the module) and plug it in again and start aSeeVR service again.

After that I could calibrate the module (tried several times also with un/re-plugging in between. Might just be me, but it works well (tried it in SkyrimVR and Saints & Sinners).

I’m just hoping we don’t have to run the calibration tool every time we start the aSeeVR service like on the usual release (didn’t try it out as I’m too tired - maybe tomorrow)… :slight_smile:

6 Likes

268 pitool and fw 296 are the newest versions of both

The 2.087 versions are internal Betas that were early released for PE. 2.087 newer than 266 and 268 is newest full release. Also listed on PimaxVR main site for download.

As @DrWilken said it seems you will need to reinstall PE as this official pitool release is not pre packaged.

6 Likes

Are we still on PE 0.84, or did I miss one?

1 Like

The new 60 Hz mode for native ist unusable for me, because visible flicker. Only tested with large FOV in Simple VR Video Player. (8KX Firmware 296 and PiTool 1.0.1.268)
Or need SteamVR a change in configuration?

The same issue had WMR devices when run 60hz. It was fixed later.

Updated both firmware and Pitool successfully, but still got the “right eye/screen shuts off” issue @114Hz mode after 15 minutes. Already tried 5 variations of the latest firmware, some are received directly from support, all versions had this same issue. Disappointing.

Firmware tested by name:
P2_RELEASE_8KX_R294_t20201015141501_rf4e5503.dfu
P2_RELEASE_8KX_M295_t20201124172637_r0cf81b2.dfu
P2_DEBUG_8KX_M295_t20201124172218_r0cf81b2.dfu
P2_RELEASE_8KX_M295_right_panel_save.dfu
8KX_R294.dfu
P2_RELEASE_8KX_M296.dfu

The fw 296 download via the PimaxVr main site is not functional.

Again, does anyone have a working mirror for the 296 .dfu file?

EDIT: opening the link via right click into a new window and hitting refresh a couple of times gave me the download.

Hi All,
Did the new Pi tool version give any of you any trouble with Pimax Experience?
Mine stopped working with the new Pitool but maybe I missed something. I reinstalled PVRHome-Installer_x86_64_v0.84.0.0 afterwards and still did not work.
Went back to the previous version 087.V2 version and the PE is working again.
Just thought it’s worth mentioning in case I did not missed something as I was away for a while.

A Happy New Year to all of you!

Kind Regards,
Pat

I reinstalled PE after new Pitool and It did run for me, after I rechecked “Start with VR home”.

3 Likes

I used the new 60 hz mode in MSFS 2020 last night and it worked fine for me. It did help with my ability to play the game on a 1080ti. Although it still wasn’t a totally smooth experience, it was smoother than what I was able to achieve at 75hz. I didn’t notice any visible flicker.

1 Like

Are you using Parallel projection in upscale mode. If so try without PP. I get the issue only when PP is on. I have updated Devs about it. No harm in raising a ticket

1 Like

Thank you Iorkhan. Your advice helped. Mine was checked already (Start Pimax VR Home). However I needed to uncheck it and then check it again for the PE to start working. Previously restarting the PC and Pimax software etc did not work.

3 Likes

Thanks for the reply. I tested the new fw without PP. Screen still goes off twice so far within an hour.

1 Like