New SteamVR Update Disables Pimax Headsets

New SteamVR Update Disables Pimax Headsets
0

Here I discuss a major issue with the latest SteamVR Hotfix update, which can disable use of Pimax headsets.

Here you can find the details of the update:
SteamVR Hotfix

As reads from the page,

Replaced “safe mode” with finer grained control over individual add-ons. After a crash, users will still see some add-ons are “blocked”, but they can be unblocked individually to determine which ones are causing incompatibility.

This is very bad for Pimax headset users, because as many of you know, restarting Pimax services would force quit SteamVR and put it in Safe Mode – but now, the only way to turn off the new Safe Mode is by re-enabling every “add-on,” including the Pimax driver. The big problem is that you can’t access settings in SteamVR without the headset connected to SteamVR; without the Pimax add-on enabled, your headset can’t connect to SteamVR to fix it in the first place. The scenario is similar to Windows Update telling you it can’t update the computer without a Windows update.

I’d just like to to point this out for anyone having the issue. In the meantime I recommend that everyone stay on the version before this if they can.

If already updated, I have found a temporary solution for this issue, but it’s a bit of a hassle to do this every time and I can’t guarantee it will work forever.

It’s the same solution people use to use SteamVR without a HMD. Here’s a link to that:
Use SteamVR Tracked Devices Without a HMD

From the page linked above:

" First Just add “activateMultipleDrivers” : true, “forcedDriver”: “null”, to near the top of the “steamvr” section of your steamvr.vrsettings config file.

{
  "steamvr" : {
   "activateMultipleDrivers" : true,
  "forcedDriver": "null",
  "allowAsyncReprojection" : false,
  "allowInterleavedReprojection" : false,
  "allowSupersampleFiltering" : false,
  "enableHomeApp" : false,
  "mirrorViewGeometry" : "1387 675 2272 1270",
  "showMirrorView" : true
 }
}

C:\Program Files (x86)\Steam\config\steamvr.vrsettings

Secondly Set enable to true in null driver to enable it.

 {
"driver_null" : {
	"enable" : true,
	"serialNumber" : "Null Serial Number", 
	"modelNumber" : "Null Model Number",
	"windowX" : 0,
	"windowY" : 0,
	"windowWidth" : 1920,
	"windowHeight" : 1080,
	"renderWidth" : 1920,
	"renderHeight" : 1060,
	"secondsFromVsyncToPhotons" : 0.01111111,
	"displayFrequency" : 60.0
}
  }

C:\Program Files (x86)\Steam\steamapps\common\SteamVR\drivers\null\resources\settings\default.vrsettings "

Don’t close the default.vrsettings page.

After setting and saving these, open SteamVR. Go to your settings, which should now work. Enable your add-ons again, more importantly the Pimax add-on.

Quit SteamVR.

Go back to the default.vrsettings document. Change “true” back to “false” and save.

Make sure PiTool is running, then reopen SteamVR. Everything should work again.

Credit goes to balderik and bendotcom

After you did step one the first time, you only need to change default.vrsettings from “true” to “false” and vice versa; there is no need to remove the text from the first step.

UPDATE:
@dillanski has found a better solution:

I recommend making steamvr.vrsettings a read-only file to prevent this from happening in later versions

@Alex.liu

13 Likes

Sounds like we need to make a backup of the steamvr settings file and create a script to undo Valve’s poor hofix update.

Hard to believe Valve would create such a poor update.

2 Likes

If steam refused to start the pimax 5k+ headset after having used a vive pro , it automatically blocked several apps from starting including the pimax driver .
Had to go to “C:\Program Files (x86)\Steam\config\steamvr.vrsettings” to enable the pimax

},
“dashboard” : {
“lastAccessedExternalOverlayKey” : “matzman666.AdvancedSettings”
},
“driver_00vrinputemulator” : {
“blocked_by_safe_mode” : true
},
“driver_01spacecalibrator” : {
“blocked_by_safe_mode” : true
},
“driver_aapvr” : {
“blocked_by_safe_mode” : false
},
“driver_gamepad” : {
“blocked_by_safe_mode” : true
},
“driver_manx” : {
“blocked_by_safe_mode” : false
},
“openvr.tool.steamvr_environments” : {
“motionSmoothingOverride” : 0,
“resolutionScale” : 100
},
“steam.app.955610” : {
“disableAsync” : true,

8 Likes

Just to make it absolutely clear, this is the part (i.e. “driver_aapvr” is the Pimax driver) that has to be changed from true to false, right? :slight_smile:

4 Likes

yes 20…!
sorry didn’t know someone else had had this issue

3 Likes

No problem… :wink: Nice find! :slight_smile:

1 Like

No worries as I believe yours has a direct fix to turn off safemode due to pimax restart etc…

1 Like

Restarting Pimax service, while running SteamVR is equivalent to pulling the headset cable from the PC (while running SteamVR), i.e. definitely not an expected behavior. Plus, you cannot get into recovered state while doing this, you have to restart SteamVR in order to be able to use the headset.

So, why not simply stop SteamVR before restarting Pimax service?

6 Likes

@risa2000 It’s not a common issue, but if it does ever happen for any reason, it’s way too complicated to get SteamVR up and running again, and shouldn’t be something a user should have to deal with

@dillanski thanks so much for your input. I will update the topic with your comment. Thx

2 Likes

Yeah it seems like @dillanski has already found a fix to keep it from happening.

Valve is definitely doing some braindead things lately. Like Lighthouse v2.0 is not to be updated by usb connection as it will mess up the LH?

I will pin your topic as it has a high level of importance.

4 Likes

Not a bad idea. But better if Pitool sends a shutdown request as we know many will skip steps. dillanski though seems to have found the setting that should remove the issue.

:pi_smiley: txt :pi_smiley:

2 Likes

Closing PiTool is not a problem, it is not in any way connected to SteamVR. Restarting PimaxService with SteamVR running is and if someone does that the assumption is that he knows what he is doing. The same as rewriting the registry in Windows.

I guess Pimax has added that to PiTool at the request of the users, and I think it was not a good idea, because know they will face support requests of users restarting the service and having the Pimax OpenVR driver quarantined by SteamVR.

This whole thread is misleading, because it suggests that SteamVR is responsible for this mess, while what it only does is isolating the bad behaving OpenVR drivers in the safe mode and the purpose of the safe mode is to allow SteamVR start safely so this behavior is understandable.

3 Likes

They simply made the restart service easier to find in pitool. However there has beem an easy fix.

Yes it is a bad steam update as it doesn’t ask you if you want to boot in safe mode like Windows does. It forces safe mode and as reported is a pain to get it to load out of safe mode.

2 Likes

wow i wish i found this sooner. the other day i couldnt figure out why i couldnt get out of safe mode at all. i tried switching in and out of the neta. and i kept getting errors in the logs about aapvr.

1 Like

say what? …twenty chars

1 Like

Apparently Valve recommends only updating LH v2.0 through Bluetooth in HTC and Index headsets.

Usb can apparently cause issues. A user posted here that was what Valve support told him after trying to update firmware through USB.

1 Like

Could you imagine if Windows forced safe mode boot and you had to re enable all your device drivers?

2 Likes

I am not sure what exactly happens with Pimax and the safe mode in SteamVR (I have just sent my 5k+ for an RMA), I guess the Pimax driver gets disabled in safe mode because it crashes SteamVR (regularily?).

My own experience with SteamVR safe mode is however this:

  1. If some SteamVR driver crashed, and I believe it should happen several times in a row, SteamVR starts in “Safe mode”.
  2. When it starts in the safe mode, it disables all 3rd party drivers (including Pimax one).
  3. It also displays a message that it runs in a safe mode and shows a button to “disable safe mode” (i.e. basically restart SteamVR back in regular mode).

From what I read here the problem is that with Pimax driver disabled, SteamVR does not start at all(?), possibly because there is no other driver (headset). The workaround seems to be simple (but I have not verified it) - enable Pimax driver in the safe mode as well.

The Valve’s implementation is a bit spartan on this point and letting the user acknowledging the safe mode would be definitely better. On the other hand, this is not an excuse for Pimax driver behavior. If Pimax driver indeed crashes SteamVR regularly (and it is its intended behavior) it is perfectly reasonable to me that SteamVR takes an action and isolates the culprit. Like if you design an app which is supposed to systematically crash Windows.

3 Likes