Not detecting DP connection after re-install

Not detecting DP connection after re-install
0

So I got a new graphics card and decided to optimize my settings for a round of HL Alyx. But I couldn’t see an FFR option, probably because when I installed pitool I didn’t have a compatible graphics card? Anyways I reinstalled it to hopefully fix it, but now it doesn’t work at all. Tried installing the HLA version, 258, 255, 249, none of them works. In the newest version it does tell me there’s some issue with the software as well as the missing DP connection and tells me to reinstall, which doesn’t work.

My Specs
specs
Using a Pimax 5k+

1 Like

Welcome to the OpenMR!

You said pitool diagnostic says there is a problem with software can you a post a pic please?

Your RTX 2070 should be ablevto do ffr.

Here is a link to pitools.

If you reinstalled or have a fresh w10 install you might be missing some dependencies

1 Like

Ye, just had to reinstall the latest version again.
application-integrity

Not sure what you mean by your last sentence tbh, what kind of dependencies?

Updates windows 10 you may not have installed.

2 Likes

If you have a fresh install of W10 you may be missing visual c redistribute, net framework, directX.

Also check your Antivirus reports as it may have blocked part of the install.

You could try righr clicking installer and choose install as admin.

Have you had pitool work before the Gpu upgrade?

Anyone want to give me a brief explanation of how to use the firmware flasher? I would like to try 144hz version on my 203 5K+. When I run stm_dfu_3040_64.exe, I get a welcome message window, and then a completing device driver install window, and then a finish window.
Thanks, in advance, for any help.

1 Like

Not sure if that runs like the Dfu.exe in pitool directory.

I used that one. It detected headset and gave me and option to choose a firmware file to install. I used browse and chose the firmware for the 5k.

Thanks a lot. Used your algorithm. Everything went fine.

1 Like

No I should have all the dependencies, not a fresh install of w10.
After the upgrade I had it running before I re-installed and everything was in order.
No reports on antivirus, running as administrator made no difference.

Yeah. I ran the one in the Pitool dir, too. It does the same thing. It never gives me a chance to pick the update file. Should I have the HMD on for this? Should I have Pitool started? Do I have to put the HMD in update mode?
What gives?

The headset needs to plugged in. It should show the headset is there. Then browse and pick the firmware file to upload. It should show it uploads firmware to headset.

Not sure maybe try using a different Web browser to download. I would reccommend filing a support ticket as you may need a teamviewer session to find out what is going wrong during install.

Guess I might have to, anyone else have any ideas by chance?

When I went from a 10 series card to a 2070 super I had no issues. That said, try completely uninstalling pitool as well as your gpu drivers and update windows. There are some files the uninstaller doesn’t touch.

I’m assuming other games work fine? Does your monitor use DP? There are multiple display ports so I doubt they’re all busted on the gpu, still worth asking

2 Likes

What kind of files aren’t removed? Maybe if I manually clear them out and then install.
There was actually a small windows update, I reinstalled gpu drivers and then pitool, no luck though.

Other games work fine, two of my 3 monitors use DP and the headset is connected with DP. I have tried swapping them around with no difference with my issue.

Ohh and I updated from a 980 TI, not the 10 series, don’t think it would make a difference though.

There’s a pimax folder somewhere in appdata (type %appdata% in explorer). Don’t remember if it’s in local or roaming though. Then manually delete the pimax folder in the C drive as well. Might be another one in your documents, but that’s all I can think of without being at a PC.

Did you run three monitors with your 980ti? I run a single 4k monitor, so I’m just trying to figure out any obvious hardware differences in our cases. You said you played around with their connections, if you havent, try disconnecting them and running an HDMI out to a single display. Highly doubt this is the issue but worth a shot.

2 Likes

There were left over data in both local and roaming, but removing it didn’t seem to make any difference.
No change in the monitor setup, three 1080p monitors. Swapped around a lot with the connections, leaving only 1 monitor and the headset connected as well as another monitor and the headset. Also tried swapping around the USB connection and disconnecting others. Though no luck yet, thanks for all the suggestions.

This is so weird, I might just have to do a fresh windows install lol, probably wouldn’t be a bad idea in general. It’s just a pain.

1 Like

W10 re install not as bad as it was with W7. I am curious though about the Application integrity.

You might want to try other display ports on your gpu if it has more than one.

On my 1080ti the 8k prefers the first port while the 5k+ only seems to like the 2nd port if mem serves. While on my r9 390 both work on the first.

You can save some time by copying you steam library folder on to an external drive or non C Drive.

1 Like

Tried all the different ports.
Definitely backing up almost everything, also mostly just have the OS and programs installed on my small m2 drive. Going to do it later today unless I get a response to my ticket.

So I re-installed windows, but I still get the same error.
Except, that the headset lights up showing me my desktop when I look inside.
Not what I woulda hoped, but progress? At least now I know it’s not the DP cable itself

edit: and fyi I did install everything I think I need, net framework, visual c stuffs, directx as well as a thorough driver update with Snappy Driver Installation

1 Like