Pi_Overlay.exe Application error

Pi_Overlay.exe Application error
0

Hello there.

It’s fairly typical that when I shut down my PC, I’m getting a memory reference error from PiTool and PI_Overlay.

Instruction at 0x00007ff6C4E1DCE4 referenced memory at 0x000000000000E8. The memory could not be read

Any ideas?.

@Alex.liu

Welcome to OpenMR forum!

I haven’t seen that myself. Though windows does complain during ahutdown if it’s running and takes longer to shutdown unless I intervene.

Have you checked your task manager to insure no elements of Pitool are loaded twice?

That type of error can revolve around duplicate references.

Nope, don’t see it. This is Pitool V1.0.1.255, HMD FW V2.1.255.255, SteamVR V 1.10.22

pi_overlay.exe
pi_server.exe
PiService.exe
PiServiceLauncher.exe
Pitool.exe

These are the PI related applications loaded.

1 Like

@tigermaster and @Enopho might have some ideas on this.

Have you tried running Memtest on you Ram?

https://www.techpowerup.com/memtest64/

@Heliosurge That’s not it… I would’ve run Memtest, but recently upgraded memory (all 4 dimm) - it was doing this before.

@PimaxUSA I believe it correct. I’ve chased it back to SteamVR crashing if the Vive controllers are powered and paired before PiTool starts SteamVR. This under some circumstances starts another instance Pitool.

Without vive controllers paired, Steam starts fine. So now all I have is Pitool closing slow.

Hi doggo, is it happend everytime?

1 Like

I have same problem, I will check some info later …(dump etc…)
Now every time, I am still trying

1 Like

It wasn’t, but it is close to every time now.

I tried uninstalling Pitool and SteamVR. This was needed as the latest SteamVR broke Pimax integration. Will report back when it happens again.

转储文件,开发者看看吧…
pi_overlay.DMP:链接: https://pan.baidu.com/s/1SBKwiC41Lspy_Hnekyxngg 提取码: jwvu
@Alex.liu
另一个 崩溃时rip都一样
链接: https://pan.baidu.com/s/1bscgqimJAZabJj1G32a5gg 提取码: 1vg1

图片
出错的调用


跳过报错之类到ret后的调用栈
图片
寄存器
图片

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.