Pimax 4k Display flashing colours but no image

I just got my Pimax 4k and I’m really excited about getting to use it, but I’m having endless problems getting it to work properly.

I’ve installed PiPlay from a link I found on this forum since PiTool doesn’t seem to support the 4K. I also installed the oculus software as most of my games render for the Rift.

If I go into piplay and set the HMD to Video mode, I can watch 2D movies without any problems, but if I switch back to Pimax mode and try to run SteamVR or any of my games, the HMD does not display any images properly. If I look at my PC monitor, I can see the image and it is tracking properly, but all I get in the HMD is a blank screen that seems to flash in solid colours, based on what I should be seeing. So for example, if i’m supposed to be seeing an image of grass, the display might flash green and if I look up at the sky the display flashes blue. By holding my head still in some positions, i can get it to display the solid colour on the HMD constantly, but it ONLY displays these solid colours and not any kind of image.

It must be some kind of software setting that I’m just not getting right, but I have no idea where to look any more because I’ve tried everything I can think of.

Setup Info:
Windows 7
16Gig RAM
NVidia 1050GTX ti
Currently running 2 monitors and Pimax from same Graphics card.

Okay haven’t used the 4k in sometime. I think other 4k users have used pitool 132. Though Windows 7 has seemingly caused a few users issues in newer pitools. Just be sure to make sure your 4k is in pimax mode and not video mode.

Check for recent posts in the 4k category as there are others whom can likely make Reccommendations.

1 Like

Yeah, I tried using the latest Pitools from the pimax site, but it kept asking me to connect base stations when running the SteamVR room set-up. I uninstalled pitool completely and downloaded PiPlay from a link I found on the Open MR forums and the old Pi Play software should support the 4K. I am running it in Pimax mode, was only mentioning that I ONLY get a recognisable picture in the HMD if i’m running in video mode… The search for a solution continues…

You just turn off Lighthouse tracking. Then click through room setup til you can manually enter your height. You will need to run steam room setup in piplay as well manually.

After room setup complete you will get picture in hmd in steam.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.