Pimax 4K has both displays shaded out black on the outer edges

My Pimax 4k started to have this issue a few months ago, its seems software related??? Anyhow the left and the right display is cut off on the edges, its shaded black, almost like it goes from 100 FOV to about 60 FOV, see pics. This issue happened one time so I rebooted PC and it went away, then the next time I fired up the headset it came back and I can get rid of it. Not much in the Pitool as far as adjustments. I have Firmware V1.0.0.265 and Pitool is the V1.0.1.180Beta. Any help would be appreciated @PimaxQuorra

Hello Stixvr,

For your problem, you need to download and install the latest Pitool version, the download link is as follows. (Please temporarily turn off the anti-virus software during installation and install it with administrator privileges)
Please kindly hit this link PiToolSetup to download the file.

Have a nice day.

Sincerely,
Quorra.Pimax

3 Likes

I now have the new Pitool installed V1.0.1.249 and I still have the same problem. I believe this started after the Windows update that was installed a couple months ago.

Hello Stixvr,

For this, you might submit a ticket at Personal Support. As our technician will contact with you shortly, they need to figure what’s happening right there.

Have a nice day.

Sincerely,
Quorra.Pimax

2 Likes

I recently reformatted my computer, and went from piplay to PiTool. I have been having the same issue ever since.

Mine worked ok for a while on Pitool, then I believe right after my computer did an “automatic” Windows update I believe thats when this happened, maybe when you formatted you got newly updated version of Windows?? I still havnt made a ticket yet because I might just use the headphones from the Pimax 4K for the 8KX, the sound from them was really good IMO. Let me know if you find a fix, if needed maybe we both put in tickets and see what happens. :beers:

Hello. I’m having the same problem after upgrading from 1.0.1.180 to the latest software version.
Is the problem coming from this from version 1.0.1.197
Improvements:
Physical resolution reduction
–The adaptive physical limitation of panel pixel area utilization when FOV is reduced. Approx 10% performance / framerate increase in VR.

Reducing on 200° is ok. But the original one…
I also try to change Hidden area Mask in the option but that doesn’t make any difference…

So do you have any news?
Thanks.

Pimax wants me to put in a service ticket. I just havnt got around to doing that yet…

I’m also having the same problem after upgrading… Help only install old version…

Nothing to add here. I tried my old PiPlay software and had the same issue. Right now I cant even get SteamVr to run in PiPlay or PiTool. :unamused:

1 Like

Hey ! Same problem here…

I found a thing on reddit, but I have to do the thing everytime I reboot my computer… This is soooo annoying !!

After many many hours of reverse engineering, I have come up with a solution to the problem!

PiService.exe will load json configuration options from C:\Users\User\AppData\Local\Pimax\PiService\config.json. After some digging I managed to determine the accepted parameters and values of this file.

{
  "log_level": 0-65535,
  "audio": 0 or 1,
  "firmware_debug": 0 or 1,
  "external_mode_caps": unknown integer value
  "mode": see below
}

The mode field is what fixed my issue, after cycling through the various options I was able to get the Pimax 4K to return to the full FOV again. Why this fixed it is unknown, but it did.

The valid options for mode are:

  • “oculus” - I think this is to use an Oculus Rift instead with this service
  • “DK1” - Same as above, but the development kit version 1
  • “DK2” - Same as above again, but the development kit version 2
  • “video” - Unknown, seems to attempt to render directly to the primary monitor
  • “pvr_extend” - Pimax PVR in Extended Desktop Mode (this works, and from reading it seems tons of people have been looking for this mode)
  • “pvr_direct” - Pimax PVR in Direct Mode (I think this is the default if omitted but the disassembly suggests it might not be).

To recover my device to full FOV, after messing around with these values in the following order it returned to normal operation.

“pvr_extend” -> “video” -> “oculus” -> none

none as in I removed the setting to use the default.

PiTool also will work fine with Pimax 4K but you may need to adjust the profile.conf file as per the following:

C:\Users\User\AppData\Local\Pimax\runtime\profile.json

{
  "Pimax P1": {
    "fov_level": 1,
    "fov_outer_adjust_degree": 1
  },
  "dbg_hidden_area_enable": 1,
  "pixels_per_display_pixel_rate": 2
}

Hopefully, this information helps someone in the future should they also have this issue

2 Likes

I cant find any config.json inside the PiService folder.
Not working for me…

Any one with v1.0.0.265 experiencing that ?
I just got my 4K pimax and installed lastest software and its really blurry at the edges and chopped from left

Also happens with the latest PiTool (255) and V2020.3.24 on Firmware v1.0.0.265
It displays 2560*1440 as max. possible Resolution, ive already tried Custom Resolution Utility but that dident help. We do need a Patch for the Software or a Way to enforce the Resolution manually.

My Pimax 4K has served me well but it is ready to go to the auction block at Ebay, unfortunately its a “brick” until a fix in the Firmware or software will fix the issue. Otherwise its useless to a new owner :rage:

Hey,
did you tried the manual flashing Tool? > Attention: Pimax Official Firmware - Manual Update Tool
Ime not experienced with flashing Pimax Devices, but it shouldent be that Diff.
Ive also flashed my Nolo Hardware manually without bigger Problems, it uses similar Tools.

#Solved
The Pimax Support was quick, they promised me to fix this Bug in the next Releases.
To do it yourself, you have todo the following:

  1. Open a new Explorer Window like an Folder
  2. Paste the following into the Address Bar at the Top: %AppData%\PiTool\manifest\PiTool
  3. Open up ‘Common Setting.json’
  4. Search for ‘comboFov:1’
  5. Change the 1 to a 0 and save the File
  6. Restart the PiService or your Computer
3 Likes

what kind of version of piplay/pitool do you use ?

This Bug happens with all PiTool Versions starting from 1.0.1.132_212
Ime using the latest: 1.0.1.258 / 2020.3.24

Thanks for doing all the leg work. So will the fix be in the next Pitool update?