Pimax 4k view rotated by 90 degrees

Good day
There was a problem with Pimax 4k, tried to solve for 3 days, but no …
I will describe the sequence:

  • there is Pimakh 4k, and it always worked well
  • PiPlay was installed
  • bought a tracking system Nolo
  • but plugged it in, set it up, synchronized it, turned on the Steam VR and in the Pimax lenses the image becomes flooded with light blue color. I read that there is a problem with PiPlay + Nolo, and need to remove PiPlay and install PiTool. And so I did. And now in Pimax the image is always rotated 90 degrees clockwise. But the problem with the light blue screen was solved, now I see the application launched by the VR.

But I don’t know how to fix an image that is rotated 90 degrees. I reinstalled different versions of PiTool and PiPlay, both together and separately. Nothing helps.
And a note: turning 90 degrees now even if Nolo is not connected and steam VR is turned off …

Hello,

Please file a service ticket with our technician.

They would love to inspect your issue and provide an appropriate solution.
Which Piplay Version you’re currently on?

I deleted the PiPlay 2.0.7.54, since it does not allow interacting with the Nolo system. And installed PiTool 1.0.1.132. In general, I tried a lot of different versions of both PiPlay and PiTool, but rotate 90 degrees everywhere(
Before I connected Nolo and installed the PiTool for the first time - Pimax 4k worked fine. But now the view in it is always rotated, even if nothing is connected except the helmet.
If I run Steam VR, then I can directly see that the grid of the floor is to the left and the top grid right of me, and not below and above.

Yesterday I reset the settings by simultaneously pressing 3 buttons on the helmet. Then he connected USB, pressed off the power button, after a few seconds 1 sound button, and after a few seconds 2 sound button. The indicator was while, then blinking white, then green, and finally blue. But that didn’t fix the problem.
Tried reconfiguring the room through PiTool. Does not help.
Setting up a room through Steam does not help either.
Disconnected all devices from USB, except for Pimax 4k, also does not help.

Hello,

Could you please follow this guide?
This will allows you to reset the headset direction.

Many thanks.
When I am at home, I will definitely check. Could you also indicate which version of PiTool has this setting? In my current one, I don’t seem to have seen this.

1 Like

Hello,

This configuration is present in the majority of the versions.
Either way, you may create a service with our technician.
They can provide a proper Pitool & Firmware version to ensure your 4K is connected and works fine with Nolo.

I reinstalled the PiTool on 1.0.1.132 version, looking for the setting you suggested, and found a button (in Settings->HMD) to re-center horizontall. This solved my problem. Has successfully launched Steam VR apps. Then I decided to take a screenshot of the button and put it here, but it disappeared … as if the headset knew that there were problems with the horizontal position and temporarily displayed the setting. Anyway, thanks for the help. I hope all this information will be useful to someone in the future.