Pimax 5K XR heavy stuttering with all pitool with GPU catalyst

Hello, so recently I finally decided to update my pitool to the latest verison, however once I did I have been getting heavy stuttering no matter what I did with the GPU catalyst option. I never had these issues before the update and I cannot find anywhere on how to fix this issue. The main thing I use VR for is DCS, so I have not been able to play it because of these issues.

I am currently running it with a 3900x ryzen CPU, and sapphire 5700xt nitro+ GPU and my entire system is watercooled.

1 Like

The only Catalyst setting which works properly for me is 0.0. Apparently, the latest version isn’t as fast as some previous versions, maybe 253(???).

2 Likes

Yea I set it to 0.0 as well but still get really heavy stuttering, I forgot which version I was using before that which was working properly. I will probably try the other previous versions but im also hoping that there is a solution for the current 260 version that I could use to solve the issue.

1 Like

It’s unfortunate that it didn’t help. I’m using 260 and it seems fine, but I only play a few VR games.

All I can suggest is to try reducing the super-sampling in SteamVR and/or lowering the in-game graphics options.

Might try lowering the super sampling because I already lowered the settings in DCS by quite a bit already so I dont think it would be graphic settings for DCS itself

1 Like

I also have 260 & my performance is ok, it’s worse than on 254, but it’s decent & I don’t have stuttering, I had it with catalyst, not matter what setting I use for catalyst it starts stutter (i7700K 32GB RAM 1080ti)

I would propose to try disable all usb devices apart of pimax, check task manager for processes that use CPU/GPU & kill those).

But for me it seems like AMD has more poor support than intel & nvidia, at least in this pitool version

Feel free to downgrade your Firmware & pitool https://www.youtube.com/watch?v=4Ec0AKuS8ms
Older Pitool Version's links broken

Once your figure it out, it really easy process

1 Like

I noticed similar problems on Halflife Alyx. I’ve had to turn my Catayst setting down to halfway. I had it on max 10 previously. I’m running v1.0.1.260 on Ryzen 5 3600 with 16GB@3600 DDR4 on a MSI B450M Mortar Max and an Asus GTX 1070 8GB (using VIVE v1 tracking LASERs)

I did have to cold start the HMD, and restart the service several times to get to that point, but I was able to turn up and on a few of the 1070’s defaults which I think improved some of the rendering a little (Warning!: potentially anecdotal BS).

I’ve noticed since the latest update, I’ve had a higher incidence of stuttering on first VR experience after power-up. As standard; I’m now testing the HMD before I start a session. I can usually tell without even wearing the headset. I just dangle it so I can see into the eye-pieces from about a foot away, and I pan it right to left. If stuttering/juddering; it’s usually obvious and so I do a service restart.

Does anyone understand what is actually causing this phenomenon? I get the feeling like it’s somehow being caused by a process or interrupt somewhere, doubling up on itself. At the very least I would expect that the PiTool should be able to detect the issue and either self correct or as a minimum, indicate awareness of the problem to the driver or even the user.

Regards,
TX

2 Likes

lol, you always tend to put stuff so nicely :slight_smile:
you‘re basically saying that due to utter uselessness you have turned the setting off.

3 Likes

Thanks! Yeah, it was an odd experience. When I tested it, I started seeing stuttering and other visual artifacts people had complained of, but I had never seen before. It mostly worked at 0.25, but stuttered in detail-heavy areas.

3 Likes

For me it doesnt matter what I set it to, though when I push it to 10 it does stutter less but then the image is really “dragging” persay. I am about to test the disabling of the steamVR supersampling potential solution since that for some reason seems like it could be the issue.

2 Likes

Just to be sure, what do you mean with „worked“?
I have the feeling you mean „it did not bother too much“ but was was there any noticeable benefit?
I couldn‘t see any improvements at all between 0-1, no trade-off improvements even. (no difference in utilization)
Guess I just have issues that you use the word „worked“ in a way that I don‘t comprehend.
I‘m a glass half full guy as well, but this I don‘t get.

Performance wise, there is no better version than 254a.

Max GPU utilization on RTX2080ti. No frametime jumping/skipping/judder.

Everything that follows afterwards has terribly GPU utilization. GPU Catalyst = 0.0 is the only setting that works without producing skipping/judder.

The problem is hardware agnostic - same behavior on different systems.

3 Likes

I mean that there weren’t any visual issues (except for the stuttering in detail-heavy areas). Higher Catalyst settings had frequent (or continuous) stutters, weird double images, or other strange drawing artifacts.

1 Like

Hmm I still think you did not get my point😄

I was wondering how you can speak of the „only setting that works“ is the setting that actually must be turned off. Because from any other setting you don‘t get any improvement either, even likely the opposite = stutterings.

So basically leaving something off means that it doesn‘t work at all.

I really tried to OC and UC my gpu and despite the horrible laggies, I could not see any change in gpu utilization in any sliderrange.

Just to make sure because I have not heard from anyone that this slider is any good, in any case?
I also think that it is no RTX related issue?

OK, we’re down to semantics.

The context of this thread is the Catalyst setting and if I change the value to 0.0, I see no visual artifacts. I write technical doc (and code) for a living, so I’m trained to be precise with my wording. The setting is labeled “0.0”, not “off”, so that is how I worded it. Internally, the setting might actually be mapped with an additive offset, so that 0 really means a low number and Catalyst isn’t really off, just minimizing its action.

But it’s not a bug for 0.0 to do what it’s supposed to do (which is nothing). That’s “working properly”.

2 Likes

Thanks for clarification. I always thought that 0 means off. Did not know that professionals (I‘m not, so I gladly take your input, see it like that + there actually might run something behind the scenes.
And apart of that I try to grasp what the catalyst actually does.

1 Like

It probably controls some sort of timing loop (or interrupt) that determines how much time the GPU gets to complete the rendering. If the work cannot be completed by that time, the old frame might be reused or Smart Smoothing might insert a calculated intermediate frame.

I hope that makes sense to you. Basically, the GPU and CPU resources need to be carefully managed, to maximize the frame rate and the Catalyst setting somehow affects the balance.

2 Likes

On off states are often represented by 0/1(bonary) however can be different when there is a range of values.

1 Like

Alright so I disabled supersampling in steamVR and moved the GPU catalyst back down to 0.0, the stuttering has significantly been reduced however im still getting it which still is bad enough for me not to be able to use my headset. I dont know what more to do honestly, and this is getting extremely annoying for me, it seems ever-since I bought this thing it has been nothing but problems. Took months for them to even make it use-able for the 5700xt, now it seems it will take months just to fix this issue now.

Maybe not. It sounds like your system is still straining. I know you have a water-cooled system, but I’m not that familiar with recent AMD products, although I’ve used both their CPUs and GPUs in the past. I do know that DCS is very demanding.

Try reducing the SteamVR super-sampling some more (or reduce your PiTool Quality, especially if it’s greater than 1.0). I only have an i7-8700K with an RTX 2080 and I have to do that. If that gets rid of the stuttering, then we can look at optimizing your experience.

1 Like