Pimax 8k, display goes black when haptic goes on for too long

Tried to post in the 8k forum but kept getting an error, i assume this category replaced it and is for both 8k and 8k+ so here it is.

This bug is on a pimax 8k, with valve index controllers.
pitool 1.0.1.271
firmware 2.1.255.271

It’s a rather rare set of circumstances, i only noticed it in beat saber recently after keeping my sabers colliding for like 30sec (which give haptic at 100% on both controller for the whole duration).

Whenever the haptic on both controller run for an excessive period on 2 index controller (20-40sec), the headset seem to blank the display, shutting down the backlight or the panels im not sure, but the result is black screen for about 10 sec before it comes back on.

Disabling the haptic on the controller “fix” the issue, but obviously not ideal.

It’s a pretty rare thing to have the haptic motor just running for such long period at 100% power with no interruption for so long and honestly haven’t seen it happen “naturally” in any game yet. but using the saber collision in beat sabers or the chaperone proximity haptic feedback can very easily reproduce it. I assume any application that send haptic at 100% to both controller can cause it to happen.

2 Likes

after some more testings, full haptic on a single controller for a bit longer will also cause it to happen. when it happens, the entire headset “reset” with pitool showing it as disconnected for a few seconds before it comes back online.

i tried everything i can think off in pitool to see if anything had an impact. lowering the blacklight thinking it may be a power issue, lowering the fps, changing the fov etc. nothing made a difference, anything vibrating the haptic for too long cause the headset to crash.

1 Like

i can confirm its an issue with the headset, im assuming some kind of current overdraw or whatever happen when a signal is sent non stop to the controller.

connecting the controller to the pc with usb instead of the wireless connection in the headset (connect and make sure the controllers are “paired” with the computer before connecting the headset) make the issue go away, until i unplug the controller. at which point in the view you see it disappear and reappear a few seconds later when it pair with the headset again.

obviously playing with cable isnt really ideal, so i ordered some usb dongles to pair my controllers directly with those instead of the hmd, hopefully will “resolve” the issue.

Would really appreciate some kind of software fix tho, even if its just turning off haptic for a few seconds if its going on for more than x sec in a row as a config in pitool, or straight out reseting the controller connection instead of the whole headset crashing whenever that happen.