Pimax 8k user since yesterday, totally desperate with "OPEN SSL FATAL ERROR"

I took a look into the Windows event viewer. The PiTool crashes are logged there.

Application name: PiTool.exe
Version: 0.0.0.0
Timestamp: 0x5bc1a7ff
Module name: ucrtbase.dll
Version: 10.0.17134.319
Timestamp: 0x40b70dec
Exception Code: 0xc0000409
Process ID: 0x354c
Starting time: 0x01d46bb85ae7ef65
Application path: C:\Program Files\Pimax\Runtime\PiTool.exe
Module path: C:\WINDOWS\System32\ucrtbase.dll

The exception code is interesting. According to https://msdn.microsoft.com/en-us/library/cc704588(d=lightweight,l=en-us,v=PROT.10).aspx this exception code indicates a stack overflow.

Did you try installing 1.76 and upgrading to 1.84? Don’t install 1.84 by itself. Some people have mentioned that upgrading from 1.76 to 1.84 got past other problems.

Do you have everything else installed?
DirectX, NetFramework etc…maybe Java, nerver know

Do you have any antivirus installed on the PC?

If so, Uninstall the antivirus and all pimax software, restart and install the pimax software.

Do not install from the same pimax installer, download a new one, from another place and different link seems that it could be an error in the compilation of the same.

It is possible that it is a communication error between the headset and the PC, do you know if there is any way to reinstall the firmware on the headset? Is it possible that the cable to the PC is in some USB port that is malfunctioning?

I hope it is not that the firmware has been installed badly, or if so, I hope it has a solution.

If it persists I’m running out of ideas.

I wouldn’t uninstall. Just pause it, download PiTool, disconnect from the internet, and try using PiTool. If it succeeds, then turn the antivirus back on and reconnect to the internet.

On another note, I had heard that some people had issues if they installed v84 directly but it worked if they installed v76 and upgraded to v84. Maybe they aren’t properly calling out their dependencies in v84?

EDIT: Maybe I missed a post :sweat: (aka scrolling up)

A bit of disassembling led me to a quick and dirty solution. The error message is only written if some value is set, which is set directly after ssleay32.dll is loaded.
By renaming “C:\Program Files\Pimax\Runtime\ssleay32.dll” into “_ssleay32.dll” seems to get rid of this problem. However, this leads to many “Warning: QSslSocket: cannot call unresolved function xyz” in the log.

But still better than nothing I guess.

2 Likes

Is you clock/date correctly set? I had some strange SSL issues once because of that.

@Headcool, I think it’s your case:
Timestamp: 0x5bc1a7ff => 1539418111 => GMT: Saturday, 13 October 2018 08:08:31 (epoch)

My time is set correctly. The timestamp you are refering to is the modification date of PiTool.exe.

ok.

Do you have openssl installed somewhere or in your PATH?

@predator036

Please help send the log to us by sean.huang@pimaxvr.com, we will analyse it.

C:\Users\user name\AppData\Local\Pimax

3 Likes

FANTASTIC FRIEND HEADCOOL !!!..

You are a real genius !!!, after following thousands of tips and doing dozens of tests, only one thing has managed to eliminate the damn “ssd fatal error” and that have been your indications of add the script and modify the “ssleay32.dll”.

Desperate to try things and not work any, I have followed your wise advice and it has worked the first time !!!, what a great joy dear friend !!!.

Should hire you the pimax team and pay you thousands of dollars per month.

I’ve been using it for about an hour and at no time has it thrown on the screen the message you mention called “Warning: QSslSocket: you can not call the unresolved function xyz”.

I hope it does not happen to me, as I said, my sincere thanks for this valuable contribution you have made to solve my problem.

Thank you so much.

Greetings !!!

3 Likes

A reflection, I do not understand programming but I want to launch a question to who can answer it, including our dear friend and genius Headpool …

Why is it that changing the name of the file ssleay32.dll has solved the fatal error message ssl that I always launched the Pitool 76 when trying to run it ???

So important is this action to eliminate an error that for days and doing hundreds of things I have not been able to solve ???

Greetings friends

The error happens during certain function calls. If you remove the whole DLL, those functions can’t be called any more. So other things are now going wrong. However at least those other things don’t seem to push error messages to the screen. But something is not working anymore when you remove the DLL, that’s for sure.

2 Likes

So, I found out following. Qt5Network.dll loads libeay32.dll and ssleay32.dll and searches for certain exports. However, the exports for SSL_set_alpn_protos, SSL_CTX_set_alpn_select_cb, SSL_get0_alpn_selected are not contained in these files. That is why the error message appears/is logged. I’m not sure how this leads to a stack overflow.

It should be possible to solve this problem by:

  • Choosing the correct versions of OpenSSL and Qt
  • By using the same toolchain to compile both OpenSSL and Qt

Sadly that is something Pimax needs to do. We can just wait.

The question, why this only affects some users stays. Figuring that out would be a way to find a better workaround.

So - how is the experience so far (the VR experience, not the „you‘ll rather hack the NASA servers than get your 8K to work“ experience…)

This is my friend, it is Pimax who has to do their job and solve this serious error, your contribution is a great achievement to be able to solve this and eventually use the pitool.

a pimax technician is offered above to give us support, what a great joy, three days ago I wrote an email with the problem, attached photos and videos and did not receive a response.

I guess they’re overworked.

I take the opportunity to thank you for your great contribution.

greetings genius of the vr.

2 Likes

thanks for your help, three days ago I reported email with photos and videos of the error, I have not received a refund.

I thank you very much for your interest, for the moment I have been able to solve it by modifying the name of the dll file that is described above.

Now I have had time to try four experiences.

The blue and the nefertari experience through steam have worked without problem.

nevertheless I have bought pimax for my passion that is to fly in simulators, with the dcs in steam, with the dcs with the installer of “eagle dynamics” out of steam and with the aerofly fs 2 of steam, I can not see the image correctly.

As soon as the menu of these simulators appears, I remain blind, the image is impossible to see, the vision of the left eye is assembled with the image of the right eye, impossible to see, if I close one eye if the problem disappears, with both Eyes at once is impossible to see.

I leave the simulator, I charge the experience of the blu and everything goes perfect.

I have the ipd correctly selected in my value of 63.

my team is I7 7700k, 32 ram, Titan Xp, ssd.

What can be the solution ???

thank you so much

greetings

Sounds like you need to enable the “Compatible with parallel projections” option in PiTool. With this option enabled the LED will emit purple light, and the blue stripe will keep flashing. However, I believe this option costs some performance, so you should disable it for games for which you do not need it.

More info: PiTool setting suggestions

1 Like

@predator036 What country are you from? I adore the way you express yourself in English.

My dear friend Headcool, as always, you have been successful with your observation, effectively, modifying the value you have told me, I have been able to solve the problem I had.

Once again, thank you very much for your great help.

You’re very kind.

Greetings.

2 Likes