Pimax 8KX: 90hz Beta is out for nvidea 30 series cards is out,share your opinions here please

@PimaxQuorra and update on when the Firmware will release? Any updates on Pimax Experience @arminelec & @SweViver?

6 Likes

What’s your deal man? I have 90hz working fine on 471.11. I wouldn’t be rushing to help you either with that attitude.

are you using amd card? i have 3090 rtx and its black screen in 90 hz . fw 298

sorry for my attitude, but alot off people ask for a eta or what is happining.but no one are responding.

1 Like

I received a different iteration of the 298 beta via email with Pimax support.
After a few initial hiccups, it now finally works. I played various games at 90hz, for up to 1.5 hours or so.
This is the one that worked: P2_RELEASE_8KX_M298_t20210706102848_r97afdca_laptop_exclude.dfu
Contact support and make a ticket, and maybe they will send it to you.
I have a 3080 Ti. 6m optical.

I won’t say this is the definite one that will work, but I will just say “knock on wood” so far.

4 Likes

Nope, 3080 FTW3. I got a response within 10 minutes (literally) of opening a ticket. I just find it hard to understand why people are getting mad on the forums when they can open a tech support ticket which is what it’s for.

5 Likes

Does that version have the 114hz? I’m on the 110hz version and I can play hours of 90hz native with no hiccups at all. It’s really made me fall in love with this headset even more.

1 Like

Can you please confirm the Nvidia driver version ?

1 Like

5 minutes after i sent in a ticket for tech support, email came with with firmware, indeed working on latest nvidia driver on a 3080.

Looks like the support is stepping up, good job pimax.

6 Likes

I’ve just tried the firmware, can confirm it works on nvidia 471.41

3 Likes

Just tried it too and it’s working AFTER disabling the onboard igpu (which i didn’t even know was enabled).

Amazing work Pimax ! :star_struck:

5 Likes

471.11 is the driver version
edit: oh, and congrats! :smiley:
seems Pimax is getting closer to a public fw release

3 Likes

New firmware announced:


Discussion:

6 Likes

I don’t have a ton of data to back this up but it seems that the issue with the 8kx blackout might have to do with bandwidth and overheating? On large fov I had several sessions with 2 or 3 blackouts in 45 minute races. Switching to normal fov i have no issue… all other settings the same. Experience is over a couple days. Not a ton of data but…

3 Likes

Did you know linux easily lists the SOC relevant here
(ambiguity intended)
Anyways, if i didnt have to [hack into] the firmware, if have had 120hz long ago.
we all know how DP and LVDS works.

Ok, I asked the support to send me the new .298 firmware. They responded fast and I installed the firmware without troubles on my 8kx.

Everything works fine as usual, but still no picture in Native 90Hz. So I uninstalled NVIDIA 471.41 with DDU, restarted my system, installed 471.41 freshly. Everything works, but no picture in 90Hz on native resolution. 110Hz in upscaled works good, seems to have less distortions as 114Hz before. So I am fine with that.

I guess, it might be, that 90Hz on native does not work here, because I am on the newest Windows 11 Beta. Since Win11 introduces the WDDM 3.0 driver model and 471.41 is the first NVIDIA driver that supports WDDM 3.0, this may be the reason for the failing.

My 3090 worked with the old 457.30 on 90Hz very well, but still no luck with the new drivers, though. Everything else works as intended.

2 Likes

hi all

I try to use the dfu.exe with the M298 engineertest.dfu but when it is ready the headset is flashing red-green-blue leds is is don’t stop.
what to do

You may need to contact support.

I had the same issue as you I believe, constant flashing and not detectable by any flashing tool. This procedure allowed me to re-flash and get it back online :slight_smile:

2 Likes

Speak for yourself, I got a Pimax so that I can have FOV larger than the competition, and that Includes small.

Instead of

Potato, Small, Normal, Large.

It should be

Normal, Large, Larger, Huge

7 Likes

Driver version: 471.68
RTX 3090

Downloaded and flashed the firmware this morning. No issues.
Only tried 90Hz in Alyx, but I get occasional quick flashes (less than a second) of the display going black. Some times this happens after a few seconds, others after several. Moved back to 75Hz and it’s stable.

3 Likes