Pimax 8kX Index controllers keep drifting off

I’ve had the 8KX for about a week. Tracking and use had been fairly normal. The Index controllers w/ base stations v1 had the normal tracking even with the Index headset–so no issue.
A couple days ago the Index controllers decided they were 2 meters away and a meter below me. Didn’t matter what I did (reboot computer, turn off on component/headset/computer) I could not bring them back. I noticed this on the Pimax start “planet” so even if they are also bad in Steam it’s obviously a Pimax issue. So I re-did PiTool Room Setup. I tried multiple times to reset floor setting on room setup but nothing works controllers track with movement but are still away from me
I uninstall re-install PiTool. No change.
I plug in my Index re-mated controllers to Index. No tracking issue for headset or controllers with Index headset. So not a base station issue. Base stations are V1, BTW
So I uninstall PiTool and then deleted Appdata/local/Pimax and appdata/local/Pitool folders. After this I had to do setup and (agonizingly) reset all ipd and clarity fixes. This worked fine but after a reboot headset on the floor and controllers two meters away.

1 Like

I am having a similar problem. I just received my 8KX which is an upgrade from my 5K+. Just unplugged the old HMD and plugged in the new one. I have been trying to play No Man’s Sky to check out the new update but sometimes, my Index controllers drift. I can be perfectly still and the controllers start to move away on their own. They often disappear entirely when I am flying my ship. I will try to wave them around and click random buttons to get them to start working again and they will just drift around, sometimes. I have tried moving my position around thinking one of my V1 lighthouses might be losing me and it settles down for awhile but they will start randomly drifting around.
Not sure what to do?

1 Like

Mine aren’t drifting. If they appear where they are supposed to be (at my hands) then for the entire play session they’ll remain where they are supposed to be. However if reboot headset/computer then at start of session (on the planet) the controllers are 3 meters away.

1 Like

I’m very sorry that I titled this “drifting off” because they don’t drift off. I thought I had it solved by using dongles and pairing with dongles but after a reboot it went back to the same problem.
In the course of troubleshooting I discovered a way to more accurately describe the issue.

When I start Pimax 8kX + PiTool + either Index or original Vive wands
The view of wands appears as though my headset is located at one of the lighthouse positions and not where my head currently is.
That is to say: the view of my controllers is not where my hands are as seen from my headset, but rather where the wands are as seen from one of my base stations. Which is why they seem about 3 meters away from my headset.

I always solved it with my 5k+ by rebooting the pc. Try powering on the headset and controllers before starting the pc.